summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucio Rubens2018-01-09 16:05:31 -0300
committerLucio Rubens2018-01-09 16:05:31 -0300
commit38a506fc54c6bd27bb1aec74bf330f3b80c77bf3 (patch)
treef5bdd810d40f81f3d38a95ff1e24293625ebf3f0
parent4e350d7937675e0e90e13b5a9d1aab65e113abef (diff)
downloadaur-38a506fc54c6bd27bb1aec74bf330f3b80c77bf3.tar.gz
1.5.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
-rw-r--r--arkclient.desktop14
-rw-r--r--arkclient.pngbin13809 -> 0 bytes
-rw-r--r--arkclient.svg97
5 files changed, 137 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e39cb2c48fb..601cffcee633 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = ark-desktop
pkgdesc = Multi Platform Ark Lite Client
- pkgver = 1.4.3
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/ArkEcosystem/ark-desktop
- arch = any
+ arch = x86_64
license = MIT
makedepends = npm
depends = nodejs
depends = electron
- source = https://github.com/ArkEcosystem/ark-desktop/releases/download/{1.4.3}/ArkClient-Linux-1.4.3.tar.xz
+ source = https://github.com/ArkEcosystem/ark-desktop/releases/download/1.5.0/ArkClient-Linux-1.5.0.tar.xz
+ source = https://raw.githubusercontent.com/ArkEcosystem/ark-desktop/1.5.0/LICENSE.md
source = arkclient.desktop
- source = arkclient.png
- sha1sums = 945c04d6124eb2eb11ba547f0ac9318d112ece12
- sha1sums = 687295fc60638fdd828646e7fc44eaf38eca3cd0
- sha1sums = 77c1f8707a779be883283150732d3477709af7da
+ source = arkclient.svg
+ sha1sums = 05cd7fd4f8ada3bcda2d8e24673dfb2b8ca33de3
+ sha1sums = 3886ec650e2912c8b0d153076ecda1d824993592
+ sha1sums = 6969963b6e3096c26d20855a7b7bbaabadc9eb1d
+ sha1sums = 9f1b28b118ee7d6071fc4d446aa018f1512406cf
pkgname = ark-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 6b7bcdfee003..e1d5a73b91c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,40 @@
_npmname=ArkClient
_appname=arkclient
pkgname=ark-desktop
-pkgver=1.4.3
+pkgver=1.5.0
pkgrel=1
pkgdesc="Multi Platform Ark Lite Client"
-arch=(any)
+arch=(x86_64)
url="https://github.com/ArkEcosystem/ark-desktop"
license=(MIT)
depends=('nodejs' 'electron')
makedepends=('npm')
-checkdepends=()
-optdepends=()
-provides=()
-options=()
-install=
source=(
- "https://github.com/ArkEcosystem/$pkgname/releases/download/{$pkgver}/$_npmname-Linux-${pkgver}.tar.xz"
- "$_appname.desktop"
- "$_appname.png"
+ "https://github.com/ArkEcosystem/${pkgname}/releases/download/${pkgver}/${_npmname}-Linux-${pkgver}.tar.xz"
+ "https://raw.githubusercontent.com/ArkEcosystem/${pkgname}/${pkgver}/LICENSE.md"
+ "${_appname}.desktop"
+ "${_appname}.svg"
)
+
sha1sums=(
- "945c04d6124eb2eb11ba547f0ac9318d112ece12"
- "687295fc60638fdd828646e7fc44eaf38eca3cd0"
- "77c1f8707a779be883283150732d3477709af7da"
+ "05cd7fd4f8ada3bcda2d8e24673dfb2b8ca33de3"
+ "3886ec650e2912c8b0d153076ecda1d824993592"
+ "6969963b6e3096c26d20855a7b7bbaabadc9eb1d"
+ "9f1b28b118ee7d6071fc4d446aa018f1512406cf"
)
package() {
- cd "$srcdir/$_npmname-$pkgver"
+ cd "${srcdir}/${_npmname}-${pkgver}"
- install -d $pkgdir/{opt/$pkgname,usr/bin}
- cp -a * $pkgdir/opt/$pkgname
- rm $pkgdir/opt/$pkgname/LICENSE*
- ln -s /opt/$pkgname/$_appname $pkgdir/usr/bin/$_appname
+ install -d ${pkgdir}/{opt/${pkgname},usr/bin}
+ cp -a * ${pkgdir}/opt/${pkgname}
+ rm ${pkgdir}/opt/${pkgname}/LICENSE*
+ ln -s /opt/${pkgname}/${_appname} ${pkgdir}/usr/bin/${_appname}
- install -Dm644 "$srcdir/$_appname.desktop" "$pkgdir/usr/share/applications/$_appname.desktop"
- install -Dm644 "$srcdir/$_appname.png" "$pkgdir/usr/share/pixmaps/$_appname.png"
+ install -Dm644 "${srcdir}/${_appname}.desktop" "${pkgdir}/usr/share/applications/${_appname}.desktop"
+ install -Dm644 "${srcdir}/${_appname}.svg" "${pkgdir}/usr/share/pixmaps/${_appname}.svg"
+ install -Dm644 "${srcdir}/LICENSE.md" "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
- chmod -R ugo+rX $pkgdir/opt
+ chmod -R ugo+rX "${pkgdir}/opt"
}
diff --git a/arkclient.desktop b/arkclient.desktop
index 098212807512..0cf25381ac11 100644
--- a/arkclient.desktop
+++ b/arkclient.desktop
@@ -1,7 +1,15 @@
[Desktop Entry]
-Name=ArkClient
-Comment=Ark Desktop
+Version=1.0
+Name=Ark Desktop
+Comment=Ark Wallet Lite Client
+TryExec=/usr/bin/arkclient
Exec=/usr/bin/arkclient
Terminal=false
Type=Application
-Icon=/usr/share/pixmaps/arkclient.png
+Icon=arkclient
+Categories=Finance;
+Actions=Explorer;
+
+[Desktop Action Explorer]
+Exec=xdg-open https://explorer.ark.io
+Name=Ark Blockchain Explorer \ No newline at end of file
diff --git a/arkclient.png b/arkclient.png
deleted file mode 100644
index f8a738414bab..000000000000
--- a/arkclient.png
+++ /dev/null
Binary files differ
diff --git a/arkclient.svg b/arkclient.svg
new file mode 100644
index 000000000000..69498873216b
--- /dev/null
+++ b/arkclient.svg
@@ -0,0 +1,97 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="512"
+ height="512"
+ viewBox="0 0 135.46666 135.46666"
+ version="1.1"
+ id="svg0"
+ inkscape:version="0.92.2 5c3e80d, 2017-08-06"
+ sodipodi:docname="arkclient.svg">
+ <defs
+ id="defs0" />
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="0.70710678"
+ inkscape:cx="-29.456852"
+ inkscape:cy="381.20528"
+ inkscape:document-units="mm"
+ inkscape:current-layer="layer0"
+ showgrid="true"
+ units="px"
+ showguides="true"
+ inkscape:guide-bbox="true"
+ inkscape:window-width="1657"
+ inkscape:window-height="957"
+ inkscape:window-x="228"
+ inkscape:window-y="45"
+ inkscape:window-maximized="0">
+ <inkscape:grid
+ type="xygrid"
+ id="grid4517" />
+ <sodipodi:guide
+ position="67.73333,0"
+ orientation="1,0"
+ id="guide4522"
+ inkscape:locked="false"
+ inkscape:label=""
+ inkscape:color="rgb(0,0,255)" />
+ <sodipodi:guide
+ position="0,67.73333"
+ orientation="0,1"
+ id="guide4524"
+ inkscape:locked="false"
+ inkscape:label=""
+ inkscape:color="rgb(0,0,255)" />
+ <sodipodi:guide
+ position="108.47916,39.687498"
+ orientation="0,1"
+ id="guide4532"
+ inkscape:locked="false" />
+ </sodipodi:namedview>
+ <metadata
+ id="metadata0">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title />
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Ebene 0"
+ inkscape:groupmode="layer"
+ id="layer0">
+ <g
+ id="arkclient">
+ <circle
+ r="67.73333"
+ cy="67.73333"
+ id="path4519"
+ style="fill:#ff233f;fill-opacity:1;stroke-width:2.73795772"
+ cx="67.73333" />
+ <path
+ id="rect4515"
+ d="M 67.733332,34.395856 26.19375,100.54169 67.733332,58.208356 109.27292,100.54169 Z m 10e-7,33.33747 -6.879166,7.40834 H 74.6125 Z m -11.641667,12.17086 -6.879166,7.14375 h 37.041665 l -6.879166,-7.14375 z"
+ style="opacity:1;fill:#ffffff;fill-opacity:1;stroke:none;stroke-width:0.13229166;stroke-linecap:round;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:0.2"
+ inkscape:connector-curvature="0"
+ sodipodi:nodetypes="cccccccccccccc" />
+ </g>
+ </g>
+</svg>