summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-15 19:35:58 +0200
committerMarcell Meszaros2022-06-15 21:09:02 +0200
commit14f408a9bff68d9577128bfbe37945513b43da63 (patch)
tree07c445e2895946b6f7f2ac1b8fe2634d2bf6eeec
parentbc8ced90a642983bedc0330221dd12cbd37bdd5a (diff)
downloadaur-14f408a9bff68d9577128bfbe37945513b43da63.tar.gz
sync build params and dependencies with [extra] ark; cosmetic changes
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD81
-rw-r--r--ark-git.install11
4 files changed, 75 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c39394a96fd..f771270140a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,33 @@
pkgbase = ark-git
- pkgdesc = Archiving Tool
- pkgver = 22.04.0.r13.g3981425a
+ pkgdesc = Compressed archive manager from KDE Gear
+ pkgver = 22.04.1.r57.g6037bcd0
pkgrel = 1
- url = http://kde.org/applications/utilities/ark/
+ url = https://apps.kde.org/ark/
arch = i686
arch = x86_64
+ groups = kde-applications
+ groups = kde-utilities
license = GPL
makedepends = extra-cmake-modules-git
makedepends = git
makedepends = kdoctools-git
makedepends = python
+ depends = hicolor-icon-theme
+ depends = kitemmodels-git
depends = kparts-git
depends = kpty-git
depends = libarchive-git
depends = libzip
- depends = kitemmodels-git
- depends = hicolor-icon-theme
- optdepends = p7zip
- optdepends = zip
- optdepends = unzip
- optdepends = unrar
- provides = ark
+ optdepends = lrzip: LRZ format support
+ optdepends = lzop: LZO format support
+ optdepends = p7zip: 7Z format support
+ optdepends = unrar: RAR decompression support
+ optdepends = unarchiver: alternative support for RAR and multipart ZIP formats
+ optdepends = unzip: legacy extraction support for single-part ZIP files
+ optdepends = zip: legacy compression support for single-part ZIP files
+ provides = ark=22.04.1.r57.g6037bcd0
conflicts = ark
source = git+https://invent.kde.org/utilities/ark.git
- md5sums = SKIP
+ b2sums = SKIP
pkgname = ark-git
diff --git a/.gitignore b/.gitignore
index 6264719ed9d8..33f4e24f5b6e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,7 @@
!.gitignore
!.SRCINFO
!PKGBUILD
-!ark-git.install
-
+!*.diff
+!*.hook
+!*.install
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index 70261c7e74fc..352f212aaf30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,46 @@
-# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Maintainer: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: Alexey D. <lq07829icatm at rambler.ru>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
-pkgname=ark-git
-pkgver=22.04.0.r13.g3981425a
+pkgname='ark-git'
+_basename="${pkgname%-git}"
+pkgver=22.04.1.r57.g6037bcd0
pkgrel=1
-pkgdesc="Archiving Tool"
-arch=(i686 x86_64)
-url='http://kde.org/applications/utilities/ark/'
-license=(GPL)
-depends=(kparts-git kpty-git libarchive-git libzip kitemmodels-git hicolor-icon-theme)
-makedepends=(extra-cmake-modules-git git kdoctools-git python)
-optdepends=(p7zip zip unzip unrar)
-provides=(ark)
-conflicts=(ark)
-source=('git+https://invent.kde.org/utilities/ark.git')
-md5sums=('SKIP')
+pkgdesc='Compressed archive manager from KDE Gear'
+arch=('i686' 'x86_64')
+url="https://apps.kde.org/${_basename}/"
+license=('GPL')
+groups=('kde-applications' 'kde-utilities')
+depends=(
+ 'hicolor-icon-theme'
+ 'kitemmodels-git'
+ 'kparts-git'
+ 'kpty-git'
+ 'libarchive-git'
+ 'libzip'
+)
+makedepends=(
+ 'extra-cmake-modules-git'
+ 'git'
+ 'kdoctools-git'
+ 'python'
+)
+optdepends=(
+ 'lrzip: LRZ format support'
+ 'lzop: LZO format support'
+ 'p7zip: 7Z format support'
+ 'unrar: RAR decompression support'
+ 'unarchiver: alternative support for RAR and multipart ZIP formats'
+ 'unzip: legacy extraction support for single-part ZIP files'
+ 'zip: legacy compression support for single-part ZIP files'
+)
+provides=("${_basename}=${pkgver}")
+conflicts=("${_basename}")
+source=("git+https://invent.kde.org/utilities/${_basename}.git")
+b2sums=('SKIP')
pkgver() {
- cd ${pkgname%-git}
+ cd "${_basename}"
# Generate git tag based version. Count only proper v#.#* [#=number] tags.
local _gitversion=$(git describe --long --tags --match 'v[0-9][0-9.][0-9.]*' | sed -e 's|^v||' | tr '[:upper:]' '[:lower:]')
@@ -31,21 +53,28 @@ pkgver() {
}
prepare() {
- mkdir -p build
+ printf 'Configuring external build flags for CMake...\n'
+ printf '# Adding CPPFLAGS to CFLAGS, CXXFLAGS; otherwise CMake might ignore the former.\n'
+
+ export CFLAGS+=" ${CPPFLAGS}" # CMake ignores CPPFLAGS
+ export CXXFLAGS+=" ${CPPFLAGS}" # CMake ignores CPPFLAGS
+
+ printf '# Adding LDFLAGS to CMake LINKER_FLAGS_INIT vars, otherwise CMake might ignore the former.\n\n'
+
+ printf 'Configuring CMake build...\n'
+ cmake -B build -S "${_basename}" \
+ -DCMAKE_BUILD_TYPE='RelWithDebInfo' \
+ -DCMAKE_EXE_LINKER_FLAGS_INIT="${LDFLAGS}" \
+ -DCMAKE_SHARED_LINKER_FLAGS_INIT="${LDFLAGS}" \
+ -DCMAKE_MODULE_LINKER_FLAGS_INIT="${LDFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DBUILD_TESTING='OFF'
}
build() {
- cd build
- cmake ../ark \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_INSTALL_DIR=lib \
- -DBUILD_TESTING=OFF \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
- make
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
}
diff --git a/ark-git.install b/ark-git.install
deleted file mode 100644
index ccb9b0a4a311..000000000000
--- a/ark-git.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- [[ -x xdg-icon-resource ]] && xdg-icon-resource forceupdate --theme hicolor &> /dev/null || true
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}