summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralex2020-07-27 17:39:36 +0300
committeralex2020-07-27 17:39:36 +0300
commit99742c16b8c00a86a5fef459402d99c1468711ae (patch)
tree60f6af02433f3c23780456acf983408cea3331e9
downloadaur-99742c16b8c00a86a5fef459402d99c1468711ae.tar.gz
init
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD49
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e543e3b3b68d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = arkade-bin
+ pkgdesc = Your one-stop CLI for Kubernetes. provides a simple CLI with strongly-typed flags to install charts and apps to your cluster in one command.
+ pkgver = 0.5.1
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/alexellis/arkade/
+ arch = x86_64
+ arch = aarch64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ depends = openssh
+ optdepends = k3sup-bin
+ optdepends = k3s-bin
+ optdepends = kubernetes-bin
+ optdepends = helm
+ optdepends = terraform
+ optdepends = azure-cli: Command-line tools for Azure
+ optdepends = aws-cli: cli for Amazon Web Services
+ optdepends = google-cloud-sdk: gcloud - command-line tools for the Google Cloud Platform
+ provides = arkade
+ source = arkade-bin-0.5.1::https://github.com/alexellis/arkade/releases/download/0.5.1/arkade
+ sha256sums = a73bdf6ce6eaffd78823f3f785fa95104bf793fe65dfb249c5db5059d6dc17d0
+
+pkgname = arkade-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..283e1b85f9c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: alex4ip <alex4ip@gmail.com>
+# Contiributer: Alex Ellis <alex@openfaas.com>
+
+pkgname=arkade-bin
+_pkgname=arkade
+pkgver=0.5.1
+pkgrel=1
+epoch=1
+pkgdesc='Your one-stop CLI for Kubernetes. provides a simple CLI with strongly-typed flags to install charts and apps to your cluster in one command.'
+arch=('x86_64' 'aarch64' 'arm' 'armv6h' 'armv7h')
+url='https://github.com/alexellis/arkade/'
+license=(MIT)
+depends=('openssh')
+#depends=('docker')
+optdepends=('k3sup-bin'
+ 'k3s-bin'
+ 'kubernetes-bin'
+ 'helm'
+ 'terraform'
+ 'azure-cli: Command-line tools for Azure'
+ 'aws-cli: cli for Amazon Web Services'
+ 'google-cloud-sdk: gcloud - command-line tools for the Google Cloud Platform')
+provides=('arkade')
+#makedepends=('go')
+_OWNER=alexellis
+
+case "${CARCH}" in
+ x86_64) _CARCH='' && sha256sums=('a73bdf6ce6eaffd78823f3f785fa95104bf793fe65dfb249c5db5059d6dc17d0');;
+ aarch64) _CARCH='-arm64' && sha256sums=('SKIP');;
+ arm*) _CARCH='-armhf' && sha256sums=('SKIP');;
+esac
+
+source=("$pkgname-$pkgver::https://github.com/${_OWNER}/${_pkgname}/releases/download/${pkgver}/${provides}${_CARCH}")
+
+package() {
+ #mkdir -p "${pkgdir}/opt"
+ install -Dm 755 "$srcdir/$pkgname-$pkgver" "${pkgdir}/usr/local/bin/${provides}"
+
+ # mkdir -p "${pkgdir}/usr/local/bin"
+ # ln -nfs /opt/${pkgname}/${provides} "${pkgdir}"/usr/local/bin/${provides}
+
+ # Add command completion
+ # install -dm 755 "$pkgdir/usr/share/bash-completion/completions"
+ # install -dm 755 "$pkgdir/usr/share/zsh/site-functions"
+ # "$pkgdir/usr/bin/provides" completion bash > "$pkgdir/usr/share/bash-completion/completions/provides"
+ # "$pkgdir/usr/bin/provides" completion zsh > "$pkgdir/usr/share/zsh/site-functions/_provides"
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file