summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2017-05-23 10:48:20 -0700
committerTyler Veness2017-05-23 10:48:20 -0700
commit31d39101551389058b7d355602c7d458c4cb6e43 (patch)
tree1f517f902107cd9d1bb4982d1d57b945c1a04a89
parentd7164dbed771d0c82ad120ebe0ae6d8c414632bf (diff)
downloadaur-31d39101551389058b7d355602c7d458c4cb6e43.tar.gz
Updated PKGBUILD to follow extra/gdb package
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 308c3f90cd13..daf25e922c18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = arm-frc-linux-gnueabi-gdb
pkgdesc = The GNU Debugger (arm-frc-linux-gnueabi)
pkgver = 7.12.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnu.org/software/gdb/
arch = i686
arch = x86_64
groups = frc-2017
license = GPL3
makedepends = texinfo
- depends = xz
+ makedepends = python
+ makedepends = guile2.0
+ makedepends = xz
depends = ncurses
depends = expat
- depends = python2
- depends = guile
+ depends = xz
+ depends = gdb-common=7.12.1
optdepends = openocd: for debugging JTAG targets
optdepends = stlink: for debugging over STLINK
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index 70696dee53d2..9102cb2a256c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_target=arm-frc-linux-gnueabi
pkgname=$_target-gdb
pkgver=7.12.1
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Debugger (${_target})"
arch=(i686 x86_64)
url='http://www.gnu.org/software/gdb/'
license=(GPL3)
groups=('frc-2017')
-depends=(xz ncurses expat python2 guile)
-makedepends=(texinfo)
+depends=(ncurses expat xz gdb-common=$pkgver)
+makedepends=(texinfo python guile2.0 xz)
optdepends=('openocd: for debugging JTAG targets'
'stlink: for debugging over STLINK')
options=(!emptydirs)
@@ -22,13 +22,11 @@ build() {
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
- ./configure --target=${_target} \
- --prefix=/usr \
- --with-pkgversion='GDB for FRC' \
+ ./configure --prefix=/usr \
+ --target=${_target} \
--disable-nls \
- --with-libexpat \
- --datadir=/usr/share/frc \
- --with-system-gdbinit=/usr/share/frc/gdb/gdbinit \
+ --with-python=/usr/bin/python3 \
+ --with-guile=guile-2.0 \
--with-sysroot=/usr/${_target} \
--enable-lto
make
@@ -39,9 +37,10 @@ package() {
make DESTDIR="$pkgdir" install
- # Following files conflict with 'gdb' package
- rm -r "$pkgdir"/usr/share/info
- # TOTHINK: we remove python module used for debugging. It means arm-*-gdb alone will not be able to debug and 'gdb' package
- # should be installed. File a bug upstream - ask a separate python module folder for cross tools.
- rm -r "$pkgdir"/usr/include/gdb
+ # fix conflicts with gdb
+ rm -r $pkgdir/usr/include/gdb
+ rm -r $pkgdir/usr/share/info
+
+ # comes from gdb-common
+ rm -r $pkgdir/usr/share/gdb
}