summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2017-09-25 17:30:34 -0700
committerTyler Veness2017-09-25 18:40:50 -0700
commit3cbf8e2bb6d879123df9b94cff1e44e3a994d8ae (patch)
treee2d303c8f6611f6f4b284fd2284cc4967863fa83
parent3a696054a0516967db4650aa7943830d24309322 (diff)
downloadaur-3cbf8e2bb6d879123df9b94cff1e44e3a994d8ae.tar.gz
Added missing libs to package from build directory and removed Gazebo from depends()
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD38
2 files changed, 26 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9be1bc65c56c..b8fe4fa0b92e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arm-frc-linux-gnueabi-wpilib
pkgdesc = The WPI FIRST Robotics Competition C/C++ library for the arm-frc-linux-gnueabi toolchain
pkgver = 2017.3.1
- pkgrel = 3
+ pkgrel = 4
url = https://usfirst.collab.net/sf/projects/wpilib/
arch = i686
arch = x86_64
@@ -12,7 +12,6 @@ pkgbase = arm-frc-linux-gnueabi-wpilib
makedepends = doxygen
makedepends = unzip
depends = arm-frc-linux-gnueabi-gcc
- depends = gazebo
options = !strip
options = libtool
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 77b7830b6bf0..54bf42327a89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Tyler Veness <calcmogul at gmail dot com>
-pkgname=arm-frc-linux-gnueabi-wpilib
+_target=arm-frc-linux-gnueabi
+pkgname=${_target}-wpilib
pkgver=2017.3.1
-pkgrel=3
+pkgrel=4
pkgdesc="The WPI FIRST Robotics Competition C/C++ library for the arm-frc-linux-gnueabi toolchain"
arch=(i686 x86_64)
url="https://usfirst.collab.net/sf/projects/wpilib/"
license=('custom=FRC-BSD')
groups=('frc-toolchain')
-depends=('arm-frc-linux-gnueabi-gcc' 'gazebo')
+depends=("${_target}-gcc")
makedepends=('git' 'java-environment=8' 'doxygen' 'unzip')
options=('!strip' 'libtool' 'staticlibs' '!emptydirs')
source=("git+git://github.com/wpilibsuite/allwpilib#tag=v2017.3.1")
@@ -24,18 +25,29 @@ build() {
package() {
cd "$srcdir/allwpilib"
- mkdir -p $pkgdir/usr/lib
- mkdir -p $pkgdir/usr/include
+ mkdir -p $pkgdir/usr/${_target}/include
+ mkdir -p $pkgdir/usr/${_target}/lib
- # HAL includes
- cp -r hal/include/* $pkgdir/usr/include
+ # HAL
+ pushd hal/build > /dev/null
+ unzip -u -q athena-runtime.zip include/* -d $pkgdir/usr/${_target}
+ unzip -u -q athena-runtime.zip lib/* -d $pkgdir/usr/${_target}
+ unzip -u -q hal.zip lib/* -d $pkgdir/usr/${_target}
+ popd > /dev/null
- # Documentation
- cd "$srcdir/allwpilib/wpilibc/build"
- mkdir -p $pkgdir/usr/arm-frc-linux-gnueabi/share/doc/wpilib
- yes A | unzip -d $pkgdir/usr/arm-frc-linux-gnueabi/share/doc/wpilib distributions/wpilibc.zip
+ # wpilibc
+ pushd wpilibc/build > /dev/null
+ unzip -u -q wpilibc.zip -d $pkgdir/usr/arm-frc-linux-gnueabi
- yes A | unzip -d $pkgdir/usr/arm-frc-linux-gnueabi wpilibc.zip
+ mkdir -p $pkgdir/usr/${_target}/share/doc/wpilib
+ unzip -u -q distributions/wpilibc.zip -d $pkgdir/usr/${_target}/share/doc/wpilib
+ popd > /dev/null
- install -Dm644 ../../license.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ # dependencies
+ pushd build/dependencies > /dev/null
+ cp -r cscore/include/* $pkgdir/usr/${_target}/include
+ cp -r cscore/lib/* $pkgdir/usr/${_target}/lib
+ popd > /dev/null
+
+ install -Dm644 license.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}