summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2017-10-26 16:17:52 -0700
committerTyler Veness2017-10-26 16:17:52 -0700
commit7101c4539f87e521ebe2f0676e8f6dd198404651 (patch)
tree73c8e5a815e38b7e8bd8be33dc80fcb0b64d8ccc
parent328f1f5ce516c90ddb3e062faf5f771ccedb92ea (diff)
downloadaur-7101c4539f87e521ebe2f0676e8f6dd198404651.tar.gz
Updated license file name and included libwpi.so linker script in install
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97203a3a868d..062af9642e32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arm-frc-linux-gnueabi-wpilib-git
pkgdesc = The WPI FIRST Robotics Competition C/C++ library for the arm-frc-linux-gnueabi toolchain
- pkgver = 1827.57ba5891
+ pkgver = 1860.ce4c9edd
pkgrel = 1
url = https://github.com/wpilibsuite/allwpilib
arch = i686
@@ -17,7 +17,7 @@ pkgbase = arm-frc-linux-gnueabi-wpilib-git
options = libtool
options = staticlibs
options = !emptydirs
- source = git+git://github.com/wpilibsuite/allwpilib
+ source = git+git://github.com/calcmogul/allwpilib
sha512sums = SKIP
pkgname = arm-frc-linux-gnueabi-wpilib-git
diff --git a/PKGBUILD b/PKGBUILD
index 1b841299d8ef..eed014078b9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_target="arm-frc-linux-gnueabi"
pkgname=${_target}-wpilib-git
-pkgver=1827.57ba5891
+pkgver=1860.ce4c9edd
pkgrel=1
pkgdesc="The WPI FIRST Robotics Competition C/C++ library for the arm-frc-linux-gnueabi toolchain"
arch=(i686 x86_64)
@@ -13,7 +13,7 @@ license=('custom=FRC-BSD')
depends=("${_target}-gcc")
makedepends=('git' 'java-environment=8' 'doxygen' 'unzip')
options=('!strip' 'libtool' 'staticlibs' '!emptydirs')
-source=("git+git://github.com/wpilibsuite/allwpilib")
+source=("git+git://github.com/calcmogul/allwpilib")
sha512sums=('SKIP')
pkgver() {
@@ -55,8 +55,9 @@ package() {
unzip -u -q -j zipcppwpilibc-classifier-linuxathena.zip -d $pkgdir/usr/${_target}/lib
unzip -u -q -j zipcppwpilibc-classifier-linuxx86-64.zip -d $pkgdir/usr/lib
popd > /dev/null
+ cp wpilibc/build/libwpi.so $pkgdir/usr/${_target}/lib
- find $pkgdir -type f -name license.txt -exec rm {} \;
+ find $pkgdir -type f -name LICENSE.txt -exec rm {} \;
- install -Dm644 license.txt $pkgdir/usr/share/licenses/${_target}-wpilib/LICENSE
+ install -Dm644 LICENSE.txt $pkgdir/usr/share/licenses/${_target}-wpilib/LICENSE
}