summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid P2018-05-05 20:02:02 -0300
committerDavid P2018-05-05 20:02:02 -0300
commit1f54699df21c4ea93ced857fcaaed1be777579af (patch)
tree7485d6b130eed984868d2f27d1c120d4a7d873e1
downloadaur-1f54699df21c4ea93ced857fcaaed1be777579af.tar.gz
upgpkg: arm-linux-gnueabi-gcc 8.1.0+20180427-1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD98
2 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..894f6d05518c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = arm-linux-gnueabi-gcc
+ pkgdesc = The GNU Compiler Collection - cross compiler for ARM target
+ pkgver = 8.1.0+20180427
+ pkgrel = 1
+ url = http://gcc.gnu.org/
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ license = GPL
+ license = LGPL
+ license = FDL
+ makedepends = gmp
+ makedepends = mpfr
+ depends = arm-linux-gnueabi-binutils
+ depends = libmpc
+ depends = zlib
+ options = !emptydirs
+ options = !strip
+ source = https://gcc.gnu.org/pub/gcc/snapshots/8-20180427/gcc-8-20180427.tar.xz
+ source = http://isl.gforge.inria.fr/isl-0.19.tar.bz2
+ sha512sums = c38c382f2246e2164d5f8d0402c4cfad7de0084f0d63d2ef9b489b7fa1695b157a2983f282811b6089dcb447432866d80dae4e84561c7f41395558cd96901d67
+ sha512sums = 08f4db964d9e02ec8aa9779378ed76e0ddf1d56f81f87664dbf787555ce496cdc87e836f8a51ae137f45e648c604870cce07ee45919eafb549e404afb8f27083
+
+pkgname = arm-linux-gnueabi-gcc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8694b323e763
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,98 @@
+# Maintainer: David P. <megver83@parabola.nu>
+
+_target=arm-linux-gnueabi
+pkgname=$_target-gcc
+_pkgver=8.1.0
+pkgver=$_pkgver+20180427
+_islver=0.19
+pkgrel=1
+_snapshot=${pkgver:0:1}-${pkgver##$_pkgver+}
+pkgdesc="The GNU Compiler Collection - cross compiler for ARM target"
+arch=('x86_64' 'i686' 'armv7h')
+url='http://gcc.gnu.org/'
+license=(GPL LGPL FDL)
+depends=($_target-binutils libmpc zlib)
+makedepends=(gmp mpfr)
+options=(!emptydirs !strip)
+source=(#https://gcc.gnu.org/pub/gcc/releases/gcc-$_pkgver/gcc-$_pkgver.tar.bz2
+ https://gcc.gnu.org/pub/gcc/snapshots/$_snapshot/gcc-$_snapshot.tar.xz
+ http://isl.gforge.inria.fr/isl-$_islver.tar.bz2)
+sha512sums=('c38c382f2246e2164d5f8d0402c4cfad7de0084f0d63d2ef9b489b7fa1695b157a2983f282811b6089dcb447432866d80dae4e84561c7f41395558cd96901d67'
+ '08f4db964d9e02ec8aa9779378ed76e0ddf1d56f81f87664dbf787555ce496cdc87e836f8a51ae137f45e648c604870cce07ee45919eafb549e404afb8f27083')
+
+if [ -n "$_snapshot" ]; then
+ _basedir=gcc-$_snapshot
+else
+ _basedir=gcc-$_pkgver
+fi
+
+prepare() {
+ cd $_basedir
+
+ # link isl for in-tree builds
+ ln -sf ../isl-$_islver isl
+
+ echo $_pkgver > gcc/BASE-VER
+
+ # hack! - some configure tests for header files using "$CPP $CPPFLAGS"
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" "$srcdir"/$_basedir/{libiberty,gcc}/configure
+
+ mkdir $srcdir/build-gcc
+}
+
+build() {
+ cd build-gcc
+
+ # using -pipe causes spurious test-suite failures
+ # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
+ CFLAGS=${CFLAGS/-pipe/}
+ CXXFLAGS=${CXXFLAGS/-pipe/}
+
+ $srcdir/$_basedir/configure \
+ --target=$_target \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --enable-languages=c,c++ \
+ --enable-plugins \
+ --enable-shared \
+ --disable-decimal-float \
+ --disable-libffi \
+ --disable-libgomp \
+ --disable-libmudflap \
+ --disable-libquadmath \
+ --disable-libssp \
+ --disable-libstdcxx-pch \
+ --disable-nls \
+ --disable-threads \
+ --disable-tls \
+ --disable-multilib \
+ --with-gnu-as \
+ --with-gnu-ld \
+ --with-system-zlib \
+ --with-gmp \
+ --with-mpfr \
+ --with-mpc \
+ --with-isl \
+ --with-libelf \
+ --enable-gnu-indirect-function \
+ --with-pkgversion='Parabola Repository' \
+ --with-bugurl='https://labs.parabola.nu/'
+
+ make $MAKEFLAGS all-gcc
+}
+
+package() {
+ cd build-gcc
+
+ make DESTDIR="$pkgdir" install-gcc
+
+ # strip target binaries
+ find "$pkgdir"/usr/lib/gcc/$_target/ -type f -and \( -name \*.a -or -name \*.o \) -exec $_target-objcopy -R .comment -R .note -R .debug_info -R .debug_aranges -R .debug_pubnames -R .debug_pubtypes -R .debug_abbrev -R .debug_line -R .debug_str -R .debug_ranges -R .debug_loc '{}' \;
+
+ # strip host binaries
+ find "$pkgdir"/usr/bin/ "$pkgdir"/usr/lib/gcc/$_target/ -type f -and \( -executable \) -exec strip '{}' \;
+
+ # Remove files that conflict with host gcc package
+ rm -r "$pkgdir"/usr/share/man/man7
+ rm -r "$pkgdir"/usr/share/info
+}