summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken Gottwalt2023-08-02 16:37:24 +0200
committerWilken Gottwalt2023-08-02 16:37:24 +0200
commit7c543f541c95d35c8e2f20b03a4ac69d4ede266b (patch)
tree17205a0c656886b1a924d3c72fc70c5897293778
parent35f5c8a9c25e92c5af0629b052e57bf90559fb85 (diff)
downloadaur-7c543f541c95d35c8e2f20b03a4ac69d4ede266b.tar.gz
update to version 2.41
- cleaned up PKGBUILD sections - more accurate dependencies - only include stuff in the final package, that makes sense
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD92
3 files changed, 56 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f28b1eba7a9..c769c1553e2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = arm-linux-gnueabihf-binutils
- pkgdesc = A set of programs to assemble and manipulate binary and object files (arm-linux-gnueabihf)
- pkgver = 2.40
+ pkgdesc = A set of programs to assemble and manipulate binary and object files
+ pkgver = 2.41
pkgrel = 1
url = https://www.gnu.org/software/binutils/
- arch = i686
arch = x86_64
license = GPL
+ makedepends = gcc
+ makedepends = glibc
+ makedepends = libelf
+ makedepends = zlib
+ makedepends = zstd
depends = glibc
+ depends = libelf
depends = zlib
- depends = elfutils
- depends = jansson
- options = staticlibs
- options = !distcc
- options = !ccache
- source = https://ftp.gnu.org/gnu/binutils/binutils-2.40.tar.xz
- source = https://ftp.gnu.org/gnu/binutils/binutils-2.40.tar.xz.sig
+ depends = zstd
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.41.tar.xz
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.41.tar.xz.sig
validpgpkeys = 3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F
- sha256sums = 0f8a4c272d7f17f369ded10a4aca28b8e304828e95526da482b0ccc4dfc9d8e1
+ sha256sums = ae9a5789e23459e59606e6714723f2d3ffc31c03174191ef0d015bdf06007450
sha256sums = SKIP
pkgname = arm-linux-gnueabihf-binutils
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 2215228ab6d0..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-*.pkg.*
-src/
-pkg/
-binutils-*.tar.*
-*.sig
-*.sign
-*.part
diff --git a/PKGBUILD b/PKGBUILD
index f49787a184f4..dd6da2a7c76d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-# Maintainer: Vyacheslav Razykov <v.razykov@gmail.com>
# Contributor: Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
# Contributor: toha257 <toha257@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
@@ -6,64 +5,60 @@
# Contributor: Kevin Mihelich <kevin@archlinuxarm.org>
# Contributor: Felipe Balbi <felipe@balbi.sh>
# Contributor: Tavian Barnes <tavianator@tavianator.com>
+# Contributor: Vyacheslav Razykov <v.razykov@gmail.com>
+# Maintainer: Wilken Gottwalt <wilken dot gottwalt at posteo dot net>
_target="arm-linux-gnueabihf"
-pkgname=${_target}-binutils
-pkgver=2.40
+pkgname="${_target}-binutils"
+pkgver=2.41
pkgrel=1
-pkgdesc="A set of programs to assemble and manipulate binary and object files (${_target})"
-arch=(i686 x86_64)
+pkgdesc="A set of programs to assemble and manipulate binary and object files"
+arch=(x86_64)
url='https://www.gnu.org/software/binutils/'
license=(GPL)
-depends=(glibc zlib elfutils jansson)
-options=(staticlibs !distcc !ccache)
-source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig})
-sha256sums=('0f8a4c272d7f17f369ded10a4aca28b8e304828e95526da482b0ccc4dfc9d8e1'
+depends=(glibc libelf zlib zstd)
+makedepends=(gcc glibc libelf zlib zstd)
+source=(https://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.xz{,.sig})
+sha256sums=('ae9a5789e23459e59606e6714723f2d3ffc31c03174191ef0d015bdf06007450'
'SKIP')
-validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
+validpgpkeys=('3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
prepare() {
mkdir -p binutils-build
- cd binutils-$pkgver
-
- # Turn off development mode (-Werror, gas run-time checks, date in sonames)
- sed -i '/^development=/s/true/false/' bfd/development.sh
-
- # hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
+ cd binutils-${pkgver}
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+
+ cd ../binutils-build
}
build() {
cd binutils-build
- "$srcdir/binutils-$pkgver/configure" \
- --prefix=/usr \
- --program-prefix=${_target}- \
- --with-lib-path=/usr/lib/binutils/${_target}:/usr/${_target}/lib \
- --with-local-prefix=/usr/lib/${_target} \
- --with-sysroot=/usr/${_target} \
- --enable-deterministic-archives \
- --enable-gold \
- --enable-ld=default \
- --enable-lto \
- --enable-jansson \
- --enable-plugins \
- --enable-relro \
- --enable-targets=${_target} \
- --enable-threads \
- --disable-gdb \
- --disable-werror \
- --with-debuginfod \
- --with-pic \
- --with-system-zlib \
- --disable-sim \
- --target=${_target} \
- --host=${CHOST} \
- --build=${CHOST}
+ ../binutils-${pkgver}/configure \
+ --build=$CHOST \
+ --host=$CHOST \
+ --target=$_target \
+ --prefix=/usr \
+ --with-sysroot=/usr/${_target} \
+ --with-debuginfod \
+ --with-pic \
+ --with-system-zlib \
+ --with-gnu-as \
+ --with-gnu-ld \
+ --enable-cet \
+ --enable-deterministic-archives \
+ --enable-gold \
+ --enable-ld=default \
+ --enable-lto \
+ --enable-plugins \
+ --enable-relro \
+ --enable-threads \
+ --enable-multilib \
+ --disable-gdb \
+ --disable-werror
- make configure-host
- make tooldir=/usr
+ make
}
check() {
@@ -76,11 +71,12 @@ check() {
package() {
cd binutils-build
- make DESTDIR="$pkgdir" install
- # Remove unwanted files
- rm -rf "$pkgdir/usr/share"
- rm -rf "$pkgdir/usr/include"
- rm -rf "$pkgdir/usr/lib"
- rm -f "$pkgdir/usr/bin/"{ar,as,ld,nm,objdump,ranlib,readelf,strip,objcopy}
+ make DESTDIR="${pkgdir}" install
+
+ # elfedit does not support ARM and gprof makes no sense as a cross tool
+ rm -rf "${pkgdir}"/usr/bin/*-{elfedit,gprof}
+ # collides with system installation of binutils
+ rm -rf "${pkgdir}"/usr/lib
+ rm -rf "${pkgdir}"/usr/share
}