summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorРазыков Вячеслав2021-01-25 13:33:17 +0300
committerРазыков Вячеслав2021-01-25 15:06:19 +0300
commitac1aaf707e06899853e4f7e396dfe0b4e2ac3d59 (patch)
tree02a3dff8467dac98c3bca1be8f585b2cbd2e05a7
parent7210791fbbb8b5b733d2a27c83c51a5e7cba39a0 (diff)
downloadaur-ac1aaf707e06899853e4f7e396dfe0b4e2ac3d59.tar.gz
Update to 2.35.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--0001-AArch64-Set-the-correct-ELF-class-for-AArch64-stubs-.patch145
-rw-r--r--PKGBUILD20
-rw-r--r--binutils-cb5f6a3e146cc70bc2d864989386df80acec5d3e.patch.xzbin61192 -> 0 bytes
4 files changed, 15 insertions, 162 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd5ef441a8ca..4f96b3ccc28f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arm-linux-gnueabihf-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files (arm-linux-gnueabihf)
- pkgver = 2.34
- pkgrel = 5
+ pkgver = 2.35.1
+ pkgrel = 1
url = https://www.gnu.org/software/binutils/
arch = i686
arch = x86_64
@@ -13,13 +13,11 @@ pkgbase = arm-linux-gnueabihf-binutils
options = staticlibs
options = !distcc
options = !ccache
- source = https://ftp.gnu.org/gnu/binutils/binutils-2.34.tar.xz
- source = https://ftp.gnu.org/gnu/binutils/binutils-2.34.tar.xz.sig
- source = binutils-cb5f6a3e146cc70bc2d864989386df80acec5d3e.patch.xz
+ source = https://ftpmirror.gnu.org/gnu/binutils/binutils-2.35.1.tar.xz
+ source = https://ftpmirror.gnu.org/gnu/binutils/binutils-2.35.1.tar.xz.sig
validpgpkeys = 3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F
- sha256sums = f00b0e8803dc9bab1e2165bd568528135be734df3fabf8d0161828cd56028952
+ sha256sums = 3ced91db9bf01182b7e420eab68039f2083aed0a214c0424e257eae3ddee8607
sha256sums = SKIP
- sha256sums = e2115d42efde1b6e254dc21c37afd2f948631d2396a7615e03331299e3652dde
pkgname = arm-linux-gnueabihf-binutils
diff --git a/0001-AArch64-Set-the-correct-ELF-class-for-AArch64-stubs-.patch b/0001-AArch64-Set-the-correct-ELF-class-for-AArch64-stubs-.patch
deleted file mode 100644
index c41bd5958760..000000000000
--- a/0001-AArch64-Set-the-correct-ELF-class-for-AArch64-stubs-.patch
+++ /dev/null
@@ -1,145 +0,0 @@
-From 8a49de34004f86920bb6fea16ff0784fa377d83d Mon Sep 17 00:00:00 2001
-From: Kevin Mihelich <kevin@archlinuxarm.org>
-Date: Tue, 7 Jan 2020 17:41:03 -0700
-Subject: [PATCH] AArch64: Set the correct ELF class for AArch64 stubs
- (PR/25210)
-
-This fixes PR 25210 by specifying the the correct ELF class for AArch64 stubs.
-After doing this the stub section starts behaving like a normal object file
-loaded from disk. That is SEC_LINKER_CREATED causes us to have to write the
-section manually.
-
-This flag was added as a fix for PR 24753. I believe that
-fix to still be correct as linker created sections don't have a size on disk
-and it fixes the Arm bootstrap regression. But in this case specifying the
-correct section class also makes the stub section not be considered by
-compress.c.
-
-So I'm partially revert this change so that we don't have to manage the section
-manually as implied by SEC_LINKER_CREATED.
-
-bfd/ChangeLog:
-
- PR 25210
- PR 24753
- * elfnn-aarch64.c (_bfd_aarch64_create_stub_section): Set ELF class.
-
-ld/ChangeLog:
-
- PR 25210
- PR 24753
- * emultempl/aarch64elf.em (elf${ELFSIZE}_aarch64_add_stub_section):
- Remove SEC_LINKER_CREATED.
- * testsuite/ld-aarch64/aarch64-elf.exp: Add erratum835769-843419.
- * testsuite/ld-aarch64/erratum835769-843419.d: New test.
----
- bfd/elfnn-aarch64.c | 4 ++
- ld/emultempl/aarch64elf.em | 2 +-
- ld/testsuite/ld-aarch64/aarch64-elf.exp | 1 +
- .../ld-aarch64/erratum835769-843419.d | 54 +++++++++++++++++++
- 4 files changed, 60 insertions(+), 1 deletion(-)
- create mode 100644 ld/testsuite/ld-aarch64/erratum835769-843419.d
-
-diff --git a/bfd/elfnn-aarch64.c b/bfd/elfnn-aarch64.c
-index fd44505da4..6b1b7b55e4 100644
---- a/bfd/elfnn-aarch64.c
-+++ b/bfd/elfnn-aarch64.c
-@@ -3176,6 +3176,10 @@ _bfd_aarch64_create_stub_section (asection *section,
- if (s_name == NULL)
- return NULL;
-
-+ /* PR 25210. Set the right class on the stub_bfd. */
-+ elf_elfheader (htab->stub_bfd)->e_ident[EI_CLASS] = ELFCLASSNN;
-+ BFD_ASSERT (ELFCLASSNN == get_elf_backend_data (htab->stub_bfd)->s->elfclass);
-+
- memcpy (s_name, section->name, namelen);
- memcpy (s_name + namelen, STUB_SUFFIX, sizeof (STUB_SUFFIX));
- return (*htab->add_stub_section) (s_name, section);
-diff --git a/ld/emultempl/aarch64elf.em b/ld/emultempl/aarch64elf.em
-index 93f60a9b61..4c13f26f4e 100644
---- a/ld/emultempl/aarch64elf.em
-+++ b/ld/emultempl/aarch64elf.em
-@@ -169,7 +169,7 @@ elf${ELFSIZE}_aarch64_add_stub_section (const char *stub_sec_name,
- lang_output_section_statement_type *os;
- struct hook_stub_info info;
-
-- flags = (SEC_ALLOC | SEC_LOAD | SEC_READONLY | SEC_CODE | SEC_LINKER_CREATED
-+ flags = (SEC_ALLOC | SEC_LOAD | SEC_READONLY | SEC_CODE
- | SEC_HAS_CONTENTS | SEC_RELOC | SEC_IN_MEMORY | SEC_KEEP);
- stub_sec = bfd_make_section_anyway_with_flags (stub_file->the_bfd,
- stub_sec_name, flags);
-diff --git a/ld/testsuite/ld-aarch64/aarch64-elf.exp b/ld/testsuite/ld-aarch64/aarch64-elf.exp
-index 631fde0f31..d02bc25091 100644
---- a/ld/testsuite/ld-aarch64/aarch64-elf.exp
-+++ b/ld/testsuite/ld-aarch64/aarch64-elf.exp
-@@ -93,6 +93,7 @@ run_dump_test "erratum843419-far-adr"
- run_dump_test "erratum843419-far-full"
- run_dump_test "erratum843419-full"
- run_dump_test "erratum843419-no-args"
-+run_dump_test "erratum835769-843419"
-
- # Relocation Tests
- run_dump_test_lp64 "weak-undefined"
-diff --git a/ld/testsuite/ld-aarch64/erratum835769-843419.d b/ld/testsuite/ld-aarch64/erratum835769-843419.d
-new file mode 100644
-index 0000000000..728765f61d
---- /dev/null
-+++ b/ld/testsuite/ld-aarch64/erratum835769-843419.d
-@@ -0,0 +1,54 @@
-+#source: erratum835769.s
-+#as:
-+#ld: --fix-cortex-a53-835769 --fix-cortex-a53-843419=full -e0x400000
-+#objdump: -dr
-+#...
-+Disassembly of section .text:
-+#...
-+[0-9a-f]+ <a1ldr>:
-+[ \t0-9a-f]+:[ \t]+b8408c87[ \t]+ldr[ \t]+w7, \[x4, #8\]\!
-+[ \t0-9a-f]+:[ \t]+1b017c06[ \t]+mul[ \t]+w6, w0, w1
-+[ \t0-9a-f]+:[ \t]+f9400084[ \t]+ldr[ \t]+x4, \[x4\]
-+[ \t0-9a-f]+:[ \t0-9a-z]+[ \t]+b[ \t]+[0-9a-f]+ <__erratum_835769_veneer_0>
-+[ \t0-9a-f]+:[ \t]+aa0503e0[ \t]+mov[ \t]+x0, x5
-+[ \t0-9a-f]+:[ \t]+d65f03c0[ \t]+ret
-+
-+[0-9a-f]+ <a5ldr>:
-+[ \t0-9a-f]+:[ \t]+b8408c87[ \t]+ldr[ \t]+w7, \[x4, #8\]!
-+[ \t0-9a-f]+:[ \t]+1b017c06[ \t]+mul[ \t]+w6, w0, w1
-+[ \t0-9a-f]+:[ \t]+f9400084[ \t]+ldr[ \t]+x4, \[x4\]
-+[ \t0-9a-f]+:[ \t0-9a-z]+[ \t]+b[ \t]+[0-9a-f]+ <__erratum_835769_veneer_1>
-+[ \t0-9a-f]+:[ \t]+aa0503e0[ \t]+mov[ \t]+x0, x5
-+[ \t0-9a-f]+:[ \t]+d65f03c0[ \t]+ret
-+
-+[0-9a-f]+ <a6ldr>:
-+[ \t0-9a-f]+:[ \t]+b8408c87[ \t]+ldr[ \t]+w7, \[x4, #8\]!
-+[ \t0-9a-f]+:[ \t]+1b017c06[ \t]+mul[ \t]+w6, w0, w1
-+[ \t0-9a-f]+:[ \t]+f9400084[ \t]+ldr[ \t]+x4, \[x4\]
-+[ \t0-9a-f]+:[ \t]+9b031885[ \t]+madd[ \t]+x5, x4, x3, x6
-+[ \t0-9a-f]+:[ \t]+aa0503e0[ \t]+mov[ \t]+x0, x5
-+[ \t0-9a-f]+:[ \t]+d65f03c0[ \t]+ret
-+
-+[0-9a-f]+ <a7str>:
-+[ \t0-9a-f]+:[ \t]+b8408c87[ \t]+ldr[ \t]+w7, \[x4, #8\]!
-+[ \t0-9a-f]+:[ \t]+1b017c06[ \t]+mul[ \t]+w6, w0, w1
-+[ \t0-9a-f]+:[ \t]+f9000084[ \t]+str[ \t]+x4, \[x4\]
-+[ \t0-9a-f]+:[ \t0-9a-z]+[ \t]+b[ \t]+[0-9a-f]+ <__erratum_835769_veneer_2>
-+[ \t0-9a-f]+:[ \t]+aa0503e0[ \t]+mov[ \t]+x0, x5
-+[ \t0-9a-f]+:[ \t]+d65f03c0[ \t]+ret
-+
-+[ \t0-9a-f]+:[ \t]+d503201f[ \t]+nop
-+[ \t0-9a-f]+:[ \t]+14000400[ \t]+b[ \t]+[0-9a-f]+ <__erratum_835769_veneer_0\+0xfe8>
-+[ \t0-9a-f]+:[ \t]+d503201f[ \t]+nop
-+[0-9a-f]+ <__erratum_835769_veneer_2>:
-+[ \t0-9a-f]+:[ \t]+9b031885[ \t]+madd[ \t]+x5, x4, x3, x6
-+[ \t0-9a-f]+:[ \t0-9a-z]+[ \t]+b[ \t]+[0-9a-f]+ <a7str\+0x[0-9a-f]+>
-+
-+[0-9a-f]+ <__erratum_835769_veneer_1>:
-+[ \t0-9a-f]+:[ \t]+9ba31845[ \t]+umaddl[ \t]+x5, w2, w3, x6
-+[ \t0-9a-f]+:[ \t0-9a-z]+[ \t]+b[ \t]+[0-9a-f]+ <a5ldr\+0x[0-9a-f]+>
-+
-+[0-9a-f]+ <__erratum_835769_veneer_0>:
-+[ \t0-9a-f]+:[ \t]+9b031845[ \t]+madd[ \t]+x5, x2, x3, x6
-+[ \t0-9a-f]+:[ \t0-9a-z]+[ \t]+b[ \t]+[0-9a-f]+ <a1ldr\+0x[0-9a-f]+>
-+#pass
---
-2.24.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 08064ccf2568..3e2740b84d8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,24 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Kevin Mihelich <kevin@archlinuxarm.org>
# Contributor: Felipe Balbi <felipe@balbi.sh>
-# Maintainer: Tavian Barnes <tavianator@tavianator.com>
+# Contributor: Tavian Barnes <tavianator@tavianator.com>
+# Maintainer: Vyacheslav Razykov <v.razykov@gmail.com>
_target="arm-linux-gnueabihf"
pkgname=${_target}-binutils
-pkgver=2.34
-pkgrel=5
+pkgver=2.35.1
+pkgrel=1
pkgdesc="A set of programs to assemble and manipulate binary and object files (${_target})"
arch=(i686 x86_64)
url='https://www.gnu.org/software/binutils/'
license=(GPL)
depends=(glibc zlib elfutils)
-makedepends=('elfutils')
+#makedepends=('elfutils')
options=(staticlibs !distcc !ccache)
-source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig}
- binutils-cb5f6a3e146cc70bc2d864989386df80acec5d3e.patch.xz)
-sha256sums=('f00b0e8803dc9bab1e2165bd568528135be734df3fabf8d0161828cd56028952'
- 'SKIP'
- 'e2115d42efde1b6e254dc21c37afd2f948631d2396a7615e03331299e3652dde')
+#source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig}
+source=(https://ftpmirror.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig})
+sha256sums=('3ced91db9bf01182b7e420eab68039f2083aed0a214c0424e257eae3ddee8607'
+ 'SKIP')
validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
prepare() {
@@ -36,7 +36,7 @@ prepare() {
# hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
- patch -Np1 -i ../binutils-cb5f6a3e146cc70bc2d864989386df80acec5d3e.patch
+ #patch -Np1 -i ../binutils-cb5f6a3e146cc70bc2d864989386df80acec5d3e.patch
}
build() {
diff --git a/binutils-cb5f6a3e146cc70bc2d864989386df80acec5d3e.patch.xz b/binutils-cb5f6a3e146cc70bc2d864989386df80acec5d3e.patch.xz
deleted file mode 100644
index de43b49ec74a..000000000000
--- a/binutils-cb5f6a3e146cc70bc2d864989386df80acec5d3e.patch.xz
+++ /dev/null
Binary files differ