summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTavian Barnes2019-07-04 16:51:39 -0400
committerTavian Barnes2019-07-04 16:51:39 -0400
commit457989228382f787980dbc53c92c4fea0c99268d (patch)
tree857a56dcdc2e0cb83f9273cd24b3795de6842843
parent5c6803fd9cd31c40154b7af92080cb0a1130c626 (diff)
downloadaur-457989228382f787980dbc53c92c4fea0c99268d.tar.gz
Bump to 9.1.0-2
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD30
-rw-r--r--bz90397.patch14
-rw-r--r--bz90949.patch88
4 files changed, 142 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d2d77dc6496..7478c45eabe8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Sun Feb 3 02:33:49 UTC 2019
pkgbase = arm-linux-gnueabihf-gcc
pkgdesc = The GNU Compiler Collection (arm-linux-gnueabihf)
- pkgver = 8.2.1+20181127
- pkgrel = 1
- url = http://gcc.gnu.org
+ pkgver = 9.1.0
+ pkgrel = 2
+ url = https://gcc.gnu.org
arch = i686
arch = x86_64
license = GPL
@@ -13,13 +11,13 @@ pkgbase = arm-linux-gnueabihf-gcc
license = custom
checkdepends = dejagnu
checkdepends = inetutils
- depends = arm-linux-gnueabihf-binutils>=2.31.1-4
- depends = arm-linux-gnueabihf-glibc>=2.28-5
+ depends = arm-linux-gnueabihf-binutils>=2.32-2
+ depends = arm-linux-gnueabihf-glibc>=2.29-3
depends = libmpc
depends = elfutils
depends = zlib
- provides = arm-linux-gnueabihf-gcc-stage1=8.2.1+20181127
- provides = arm-linux-gnueabihf-gcc-stage2=8.2.1+20181127
+ provides = arm-linux-gnueabihf-gcc-stage1=9.1.0
+ provides = arm-linux-gnueabihf-gcc-stage2=9.1.0
conflicts = arm-linux-gnueabihf-gcc-stage1
conflicts = arm-linux-gnueabihf-gcc-stage2
replaces = arm-linux-gnueabihf-gcc-stage1
@@ -27,12 +25,20 @@ pkgbase = arm-linux-gnueabihf-gcc
options = !emptydirs
options = !distcc
options = !strip
- source = https://sources.archlinux.org/other/gcc/gcc-8.2.1-20181127.tar.xz
- source = https://sources.archlinux.org/other/gcc/gcc-8.2.1-20181127.tar.xz.sig
- source = http://isl.gforge.inria.fr/isl-0.20.tar.bz2
- sha256sums = 6f64ffda2839e96a8551b767bf4f92be4e7a09377ea40058355b4eeb13bc3800
+ source = https://ftp.gnu.org/gnu/gcc/gcc-9.1.0/gcc-9.1.0.tar.xz
+ source = https://ftp.gnu.org/gnu/gcc/gcc-9.1.0/gcc-9.1.0.tar.xz.sig
+ source = http://isl.gforge.inria.fr/isl-0.21.tar.bz2
+ source = bz90397.patch
+ source = bz90949.patch
+ validpgpkeys = F3691687D867B81B51CE07D9BBE43771487328A9
+ validpgpkeys = 86CFFCA918CF3AF47147588051E8B148A9999C34
+ validpgpkeys = 13975A70E63C361C73AE69EF6EEB81F8981C74C7
+ validpgpkeys = 33C235A34C46AA3FFB293709A328C3A2C3C45C06
+ sha256sums = 79a66834e96a6050d8fe78db2c3b32fb285b230b855d0a66288235bc04b327a0
sha256sums = SKIP
- sha256sums = b587e083eb65a8b394e833dea1744f21af3f0e413a448c17536b5549ae42a4c2
+ sha256sums = d18ca11f8ad1a39ab6d03d3dcb3365ab416720fcb65b42d69f34f51bf0a0e859
+ sha256sums = cc20d05bcc6cb35bf0944b391f0b0380af375f2a8a03ce1cd67835884bc41fac
+ sha256sums = c860819e730faf1621e1286ebe3a0179df6e25182b81a9ca0a3db02633982a14
pkgname = arm-linux-gnueabihf-gcc
diff --git a/PKGBUILD b/PKGBUILD
index 78c9f63712c0..b3a586ef4f6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,30 +6,34 @@
_target="arm-linux-gnueabihf"
pkgname="${_target}-gcc"
-pkgver=8.2.1+20181127
+pkgver=9.1.0
_majorver=${pkgver:0:1}
-_islver=0.20
-pkgrel=1
+_islver=0.21
+pkgrel=2
pkgdesc="The GNU Compiler Collection (${_target})"
arch=(i686 x86_64)
license=(GPL LGPL FDL custom)
-url='http://gcc.gnu.org'
-depends=("${_target}-binutils>=2.31.1-4" "${_target}-glibc>=2.28-5" libmpc elfutils zlib)
+url='https://gcc.gnu.org'
+depends=("${_target}-binutils>=2.32-2" "${_target}-glibc>=2.29-3" libmpc elfutils zlib)
checkdepends=(dejagnu inetutils)
options=(!emptydirs !distcc !strip)
conflicts=("${_target}-gcc-stage1" "${_target}-gcc-stage2")
replaces=("${_target}-gcc-stage1" "${_target}-gcc-stage2")
provides=("${_target}-gcc-stage1=${pkgver}" "${_target}-gcc-stage2=${pkgver}")
-#source=(https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz{,.sig}
-source=(https://sources.archlinux.org/other/gcc/gcc-${pkgver/+/-}.tar.xz{,.sig}
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
+#source=(https://sources.archlinux.org/other/gcc/gcc-${pkgver/+/-}.tar.xz{,.sig}
+source=(https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz{,.sig}
+ http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
+ bz90397.patch
+ bz90949.patch)
validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
33C235A34C46AA3FFB293709A328C3A2C3C45C06) # Jakub Jelinek <jakub@redhat.com>
-sha256sums=('6f64ffda2839e96a8551b767bf4f92be4e7a09377ea40058355b4eeb13bc3800'
+sha256sums=('79a66834e96a6050d8fe78db2c3b32fb285b230b855d0a66288235bc04b327a0'
'SKIP'
- 'b587e083eb65a8b394e833dea1744f21af3f0e413a448c17536b5549ae42a4c2')
+ 'd18ca11f8ad1a39ab6d03d3dcb3365ab416720fcb65b42d69f34f51bf0a0e859'
+ 'cc20d05bcc6cb35bf0944b391f0b0380af375f2a8a03ce1cd67835884bc41fac'
+ 'c860819e730faf1621e1286ebe3a0179df6e25182b81a9ca0a3db02633982a14')
_svnrev=264010
_svnurl=svn://gcc.gnu.org/svn/gcc/branches/gcc-${_majorver}-branch
@@ -39,6 +43,12 @@ prepare() {
[[ ! -d gcc ]] && ln -s gcc-${pkgver/+/-} gcc
cd gcc
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=90397
+ patch -p0 -i "$srcdir/bz90397.patch"
+
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=90949
+ patch -p0 -i "$srcdir/bz90949.patch"
+
# link isl for in-tree build
ln -s ../isl-${_islver} isl
diff --git a/bz90397.patch b/bz90397.patch
new file mode 100644
index 000000000000..d41252af50e4
--- /dev/null
+++ b/bz90397.patch
@@ -0,0 +1,14 @@
+Index: libstdc++-v3/include/std/variant
+===================================================================
+--- libstdc++-v3/include/std/variant (revision 271082)
++++ libstdc++-v3/include/std/variant (revision 271083)
+@@ -1556,7 +1556,8 @@
+ #endif
+
+ template<size_t _Np, typename _Vp>
+- friend constexpr decltype(auto) __detail::__variant::__get(_Vp&& __v);
++ friend constexpr decltype(auto)
++ __detail::__variant::__get(_Vp&& __v) noexcept;
+
+ template<typename _Vp>
+ friend void* __detail::__variant::__get_storage(_Vp&& __v);
diff --git a/bz90949.patch b/bz90949.patch
new file mode 100644
index 000000000000..e545844c5d7e
--- /dev/null
+++ b/bz90949.patch
@@ -0,0 +1,88 @@
+Index: gcc/testsuite/gcc.c-torture/execute/pr90949.c
+===================================================================
+--- gcc/testsuite/gcc.c-torture/execute/pr90949.c (nonexistent)
++++ gcc/testsuite/gcc.c-torture/execute/pr90949.c (revision 272555)
+@@ -0,0 +1,42 @@
++void __attribute__ ((noipa, noinline)) my_puts (const char *str) { }
++
++void __attribute__ ((noipa, noinline)) my_free (void *p) { }
++
++
++struct Node
++{
++ struct Node *child;
++};
++
++struct Node space[2] = { };
++
++struct Node * __attribute__ ((noipa, noinline)) my_malloc (int bytes)
++{
++ return &space[0];
++}
++
++void
++walk (struct Node *module, int cleanup)
++{
++ if (module == 0)
++ {
++ return;
++ }
++ if (!cleanup)
++ {
++ my_puts ("No cleanup");
++ }
++ walk (module->child, cleanup);
++ if (cleanup)
++ {
++ my_free (module);
++ }
++}
++
++int
++main ()
++{
++ struct Node *node = my_malloc (sizeof (struct Node));
++ node->child = 0;
++ walk (node, 1);
++}
+Index: gcc/tree-ssa-copy.c
+===================================================================
+--- gcc/tree-ssa-copy.c (revision 272554)
++++ gcc/tree-ssa-copy.c (revision 272555)
+@@ -545,13 +545,12 @@
+ duplicate_ssa_name_ptr_info (copy_of[i].value,
+ SSA_NAME_PTR_INFO (var));
+ /* Points-to information is cfg insensitive,
+- but alignment info might be cfg sensitive, if it
+- e.g. is derived from VRP derived non-zero bits.
+- So, do not copy alignment info if the two SSA_NAMEs
+- aren't defined in the same basic block. */
++ but [E]VRP might record context sensitive alignment
++ info, non-nullness, etc. So reset context sensitive
++ info if the two SSA_NAMEs aren't defined in the same
++ basic block. */
+ if (var_bb != copy_of_bb)
+- mark_ptr_info_alignment_unknown
+- (SSA_NAME_PTR_INFO (copy_of[i].value));
++ reset_flow_sensitive_info (copy_of[i].value);
+ }
+ else if (!POINTER_TYPE_P (TREE_TYPE (var))
+ && SSA_NAME_RANGE_INFO (var)
+Index: gcc/tree-ssanames.c
+===================================================================
+--- gcc/tree-ssanames.c (revision 272554)
++++ gcc/tree-ssanames.c (revision 272555)
+@@ -820,7 +820,12 @@
+ {
+ /* points-to info is not flow-sensitive. */
+ if (SSA_NAME_PTR_INFO (name))
+- mark_ptr_info_alignment_unknown (SSA_NAME_PTR_INFO (name));
++ {
++ /* [E]VRP can derive context sensitive alignment info and
++ non-nullness properties. We must reset both. */
++ mark_ptr_info_alignment_unknown (SSA_NAME_PTR_INFO (name));
++ SSA_NAME_PTR_INFO (name)->pt.null = 1;
++ }
+ }
+ else
+ SSA_NAME_RANGE_INFO (name) = NULL;