summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken Gottwalt2023-08-17 06:31:23 +0200
committerWilken Gottwalt2023-08-17 06:31:23 +0200
commit908b5e0c52a2890ef46e10fb8eda765745b6a9e1 (patch)
tree6049d176b0082720a21ef9d7f1b326ca2b9203d4
parent04b2abbd7e10a91f6f13a742862cb34593155e65 (diff)
downloadaur-908b5e0c52a2890ef46e10fb8eda765745b6a9e1.tar.gz
add objc and objc++ support
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f4f64e97317..ae11af60b6ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arm-linux-gnueabihf-gcc
pkgdesc = The GNU Compiler Collection
pkgver = 13.2.0
- pkgrel = 5
+ pkgrel = 6
url = https://gcc.gnu.org
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 971cfba629c8..6a9fae829341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ _gmpver=6.3.0
_islver=0.26
_mpcver=1.3.1
_mpfrver=4.2.0
-pkgrel=5
+pkgrel=6
pkgdesc="The GNU Compiler Collection"
arch=(x86_64)
license=(GPL LGPL FDL custom)
@@ -90,7 +90,7 @@ build() {
--with-arch=armv6 \
--with-float=hard \
--with-fpu=vfp \
- --enable-languages=c,c++,fortran,lto \
+ --enable-languages=c,c++,fortran,lto,objc,obj-c++ \
--enable-__cxa_atexit \
--enable-cet=auto \
--enable-checking=release \
@@ -99,7 +99,6 @@ build() {
--enable-default-ssp \
--enable-gnu-indirect-function \
--enable-gnu-unique-object \
- --enable-install-libiberty \
--enable-libstdcxx-backtrace \
--enable-link-serialization=1 \
--enable-linker-build-id \
@@ -110,6 +109,7 @@ build() {
--enable-libquadmath \
--enable-libvtv \
--disable-nls \
+ --disable-install-libiberty \
--disable-libssp \
--disable-libstdcxx-pch \
--disable-multilib \
@@ -121,7 +121,7 @@ build() {
package() {
cd gcc-build
- make DESTDIR="${pkgdir}" install-gcc install-target-{libatomic,libgcc,libgfortran,libgomp,libitm,libquadmath,libsanitizer,libstdc++-v3,libvtv}
+ make DESTDIR="${pkgdir}" install-gcc install-target-{libatomic,libgcc,libgfortran,libgomp,libitm,libobjc,libquadmath,libsanitizer,libstdc++-v3,libvtv}
rm -rf "${pkgdir}"/usr/share/{gcc-${pkgver},info,man/man7}