summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTavian Barnes2017-02-02 19:22:14 -0500
committerTavian Barnes2017-02-02 19:35:04 -0500
commit09d8b5a2dc1f73458385ef8c5330d78d161ac46a (patch)
tree4b036852cfdd3455898836c99ab5bed044540254
parent496feeadea44a6c5a32ca21ce9cf79a55050da03 (diff)
downloadaur-09d8b5a2dc1f73458385ef8c5330d78d161ac46a.tar.gz
Bump to 6.3.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD52
2 files changed, 40 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50bb395c3af9..63e2732870f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Jul 21 15:18:45 UTC 2016
+# Fri Feb 3 00:34:59 UTC 2017
pkgbase = arm-linux-gnueabihf-gcc-stage1
pkgdesc = The GNU Compiler Collection. Stage 1 for toolchain building (arm-linux-gnueabihf)
- pkgver = 6.1.1
- pkgrel = 3
+ pkgver = 6.3.1
+ pkgrel = 1
url = http://gcc.gnu.org
arch = i686
arch = x86_64
@@ -11,15 +11,15 @@ pkgbase = arm-linux-gnueabihf-gcc-stage1
license = LGPL
license = FDL
license = custom
- depends = arm-linux-gnueabihf-binutils>=2.26.1-1
+ depends = arm-linux-gnueabihf-binutils>=2.27-1
depends = libmpc
depends = zlib
options = !emptydirs
options = !distcc
options = !strip
- source = https://github.com/gcc-mirror/gcc/archive/1bbd3999.tar.gz
+ source = https://github.com/gcc-mirror/gcc/archive/4ca53f06ff7d346ef8021a23108f23a5406a0417.tar.gz
source = http://isl.gforge.inria.fr/isl-0.16.1.tar.bz2
- md5sums = d4c4546f927b2984d66574b1b5cb817e
+ md5sums = e65d06ed7c00e68bc84f6989752a09eb
md5sums = ac1f25a0677912952718a51f5bc20f32
pkgname = arm-linux-gnueabihf-gcc-stage1
diff --git a/PKGBUILD b/PKGBUILD
index 32b665ada5bf..553e00b4625e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,20 @@
_target="arm-linux-gnueabihf"
pkgname=${_target}-gcc-stage1
-pkgver=6.1.1
+pkgver=6.3.1
_pkgver=6
_islver=0.16.1
-pkgrel=3
-_commit=1bbd3999
+pkgrel=1
+_commit=4ca53f06ff7d346ef8021a23108f23a5406a0417
pkgdesc="The GNU Compiler Collection. Stage 1 for toolchain building (${_target})"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL' 'custom')
url="http://gcc.gnu.org"
-depends=("${_target}-binutils>=2.26.1-1" 'libmpc' 'zlib')
+depends=("${_target}-binutils>=2.27-1" 'libmpc' 'zlib')
options=('!emptydirs' '!distcc' '!strip')
source=(https://github.com/gcc-mirror/gcc/archive/${_commit}.tar.gz
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
-md5sums=('d4c4546f927b2984d66574b1b5cb817e'
+md5sums=('e65d06ed7c00e68bc84f6989752a09eb'
'ac1f25a0677912952718a51f5bc20f32')
prepare() {
@@ -53,20 +53,36 @@ build() {
--with-build-sysroot=/usr/${_target} \
--with-as=/usr/bin/${_target}-as \
--with-ld=/usr/bin/${_target}-ld \
- --libdir=/usr/lib --libexecdir=/usr/lib \
- --with-arch=armv6 --with-float=hard --with-fpu=vfp \
- --target=${_target} --host=${CHOST} --build=${CHOST} \
- --disable-nls --with-newlib \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --disable-nls \
+ --with-newlib \
--enable-languages=c,c++ \
- --disable-shared --disable-threads \
- --with-system-zlib --with-isl --enable-__cxa_atexit \
- --disable-libunwind-exceptions --enable-clocale=gnu \
- --disable-libstdcxx-pch --disable-libssp \
- --enable-gnu-unique-object --enable-linker-build-id \
- --disable-lto --disable-plugin --enable-install-libiberty \
- --with-linker-hash-style=gnu --enable-gnu-indirect-function \
- --disable-multilib --disable-werror \
- --enable-checking=release
+ --disable-shared \
+ --disable-threads \
+ --with-system-zlib \
+ --with-isl \
+ --enable-__cxa_atexit \
+ --disable-libunwind-exceptions \
+ --enable-clocale=gnu \
+ --disable-libstdcxx-pch \
+ --disable-libssp \
+ --enable-gnu-unique-object \
+ --enable-linker-build-id \
+ --disable-lto \
+ --disable-plugin \
+ --enable-install-libiberty \
+ --with-linker-hash-style=gnu \
+ --enable-gnu-indirect-function \
+ --disable-multilib \
+ --disable-werror \
+ --enable-checking=release \
+ --target=${_target} \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --with-arch=armv6 \
+ --with-float=hard \
+ --with-fpu=vfp
make all-gcc all-target-libgcc
}