summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTavian Barnes2020-05-15 14:58:30 -0400
committerTavian Barnes2020-05-15 15:02:50 -0400
commit82f6f29e3112ab2aa078a514966490fd8b91571b (patch)
treec8076c91a015f71890177efde1fb880a389dbbfe
parent261f92784ed4bd1c87525b6251dcab5f85bf1065 (diff)
downloadaur-82f6f29e3112ab2aa078a514966490fd8b91571b.tar.gz
Bump to 10.1.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD51
-rw-r--r--fs64270.patch26
3 files changed, 62 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2331b3dd4837..3071b5f9821a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arm-linux-gnueabihf-gcc-stage1
pkgdesc = The GNU Compiler Collection. Stage 1 for toolchain building (arm-linux-gnueabihf)
- pkgver = 9.2.0
- pkgrel = 4
+ pkgver = 10.1.0
+ pkgrel = 1
url = https://gcc.gnu.org
arch = i686
arch = x86_64
@@ -9,22 +9,24 @@ pkgbase = arm-linux-gnueabihf-gcc-stage1
license = LGPL
license = FDL
license = custom
- depends = arm-linux-gnueabihf-binutils>=2.33.1-2.1
+ depends = arm-linux-gnueabihf-binutils>=2.34-3
depends = libmpc
depends = zlib
options = !emptydirs
options = !distcc
options = !strip
- source = https://ftp.gnu.org/gnu/gcc/gcc-9.2.0/gcc-9.2.0.tar.xz
- source = https://ftp.gnu.org/gnu/gcc/gcc-9.2.0/gcc-9.2.0.tar.xz.sig
- source = http://isl.gforge.inria.fr/isl-0.21.tar.bz2
+ source = https://sourceware.org/pub/gcc/releases/gcc-10.1.0/gcc-10.1.0.tar.xz
+ source = https://sourceware.org/pub/gcc/releases/gcc-10.1.0/gcc-10.1.0.tar.xz.sig
+ source = http://isl.gforge.inria.fr/isl-0.21.tar.xz
+ source = fs64270.patch
validpgpkeys = F3691687D867B81B51CE07D9BBE43771487328A9
validpgpkeys = 86CFFCA918CF3AF47147588051E8B148A9999C34
validpgpkeys = 13975A70E63C361C73AE69EF6EEB81F8981C74C7
validpgpkeys = 33C235A34C46AA3FFB293709A328C3A2C3C45C06
- sha256sums = ea6ef08f121239da5695f76c9b33637a118dcf63e24164422231917fa61fb206
+ sha256sums = b6898a23844b656f1b68691c5c012036c2e694ac4b53a8918d4712ad876e7ea2
sha256sums = SKIP
- sha256sums = d18ca11f8ad1a39ab6d03d3dcb3365ab416720fcb65b42d69f34f51bf0a0e859
+ sha256sums = 777058852a3db9500954361e294881214f6ecd4b594c00da5eee974cd6a54960
+ sha256sums = 1ef190ed4562c4db8c1196952616cd201cfdd788b65f302ac2cc4dabb4d72cee
pkgname = arm-linux-gnueabihf-gcc-stage1
diff --git a/PKGBUILD b/PKGBUILD
index 6e8ef308e381..6c1767ea9a51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,30 +6,27 @@
_target="arm-linux-gnueabihf"
pkgname=${_target}-gcc-stage1
-pkgver=9.2.0
-_majorver=${pkgver:0:1}
+pkgver=10.1.0
+_majorver=${pkgver%%.*}
_islver=0.21
-pkgrel=4
+pkgrel=1
pkgdesc="The GNU Compiler Collection. Stage 1 for toolchain building (${_target})"
arch=(i686 x86_64)
license=(GPL LGPL FDL custom)
url='https://gcc.gnu.org'
-depends=("${_target}-binutils>=2.33.1-2.1" libmpc zlib)
+depends=("${_target}-binutils>=2.34-3" libmpc zlib)
options=(!emptydirs !distcc !strip)
-#source=(https://sources.archlinux.org/other/gcc/gcc-${pkgver/+/-}.tar.xz{,.sig}
-source=(https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz{,.sig}
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
+source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz{,.sig}
+ http://isl.gforge.inria.fr/isl-${_islver}.tar.xz
+ fs64270.patch)
validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
33C235A34C46AA3FFB293709A328C3A2C3C45C06) # Jakub Jelinek <jakub@redhat.com>
-sha256sums=('ea6ef08f121239da5695f76c9b33637a118dcf63e24164422231917fa61fb206'
+sha256sums=('b6898a23844b656f1b68691c5c012036c2e694ac4b53a8918d4712ad876e7ea2'
'SKIP'
- 'd18ca11f8ad1a39ab6d03d3dcb3365ab416720fcb65b42d69f34f51bf0a0e859')
-
-_svnrev=264010
-_svnurl=svn://gcc.gnu.org/svn/gcc/branches/gcc-${_majorver}-branch
-_libdir=usr/lib/gcc/$CHOST/${pkgver%%+*}
+ '777058852a3db9500954361e294881214f6ecd4b594c00da5eee974cd6a54960'
+ '1ef190ed4562c4db8c1196952616cd201cfdd788b65f302ac2cc4dabb4d72cee')
prepare() {
[[ ! -d gcc ]] && ln -s gcc-${pkgver/+/-} gcc
@@ -44,6 +41,10 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
+ # Turn off SSP for nostdlib|nodefaultlibs|ffreestanding
+ # https://bugs.archlinux.org/task/64270
+ patch -p1 -i "$srcdir/fs64270.patch"
+
mkdir -p "$srcdir/gcc-build"
}
@@ -67,27 +68,27 @@ build() {
--disable-nls \
--with-newlib \
--enable-languages=c,c++ \
- --disable-shared \
- --disable-threads \
- --with-system-zlib \
--with-isl \
+ --with-linker-hash-style=gnu \
+ --with-system-zlib \
--enable-__cxa_atexit \
- --disable-libunwind-exceptions \
+ --enable-checking=release \
--enable-clocale=gnu \
- --disable-libstdcxx-pch \
- --disable-libssp \
+ --enable-default-pie \
+ --enable-default-ssp \
+ --enable-gnu-indirect-function \
--enable-gnu-unique-object \
+ --enable-install-libiberty \
--enable-linker-build-id \
--disable-lto \
--disable-plugin \
- --enable-install-libiberty \
- --with-linker-hash-style=gnu \
- --enable-gnu-indirect-function \
+ --disable-shared \
+ --disable-threads \
+ --disable-libssp \
+ --disable-libstdcxx-pch \
+ --disable-libunwind-exceptions \
--disable-multilib \
--disable-werror \
- --enable-checking=release \
- --enable-default-pie \
- --enable-default-ssp \
--target=${_target} \
--host=${CHOST} \
--build=${CHOST} \
diff --git a/fs64270.patch b/fs64270.patch
new file mode 100644
index 000000000000..7b9e142c6be8
--- /dev/null
+++ b/fs64270.patch
@@ -0,0 +1,26 @@
+Disable ssp on -nostdlib, -nodefaultlibs and -ffreestanding
+
+--- a/gcc/gcc.c 2017-07-04 09:15:57.740793000 +0200
++++ b/gcc/gcc.c 2018-03-02 13:58:44.387741114 +0100
+@@ -857,6 +857,12 @@ proper position among the other output f
+ #define LINK_GCC_C_SEQUENCE_SPEC "%G %L %G"
+ #endif
+
++#ifdef ENABLE_DEFAULT_SSP
++#define NO_SSP_SPEC "%{nostdlib|nodefaultlibs|ffreestanding:-fno-stack-protector} "
++#else
++#define NO_SSP_SPEC ""
++#endif
++
+ #ifndef LINK_SSP_SPEC
+ #ifdef TARGET_LIBC_PROVIDES_SSP
+ #define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all" \
+@@ -1131,7 +1148,7 @@ static const char *cc1_options =
+ %{-version:--version}\
+ %{-help=*:--help=%*}\
+ %{!fsyntax-only:%{S:%W{o*}%{!o*:-o %b.s}}}\
+- %{fsyntax-only:-o %j} %{-param*}\
++ %{fsyntax-only:-o %j} %{-param*} " NO_SSP_SPEC "\
+ %{coverage:-fprofile-arcs -ftest-coverage}\
+ %{fprofile-arcs|fprofile-generate*|coverage:\
+ %{!fprofile-update=singel:\