summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTavian Barnes2016-02-29 11:53:27 -0500
committerTavian Barnes2016-02-29 11:53:27 -0500
commitbfc4cf7ec7b86842f39bf61b0b5dfaed0e3dc7f2 (patch)
treee3b9d4518a7da66b22497f8f8ff06aae041eaff7
parente3d50f8abefaeac17daaea692a4c28f7e36566d7 (diff)
downloadaur-bfc4cf7ec7b86842f39bf61b0b5dfaed0e3dc7f2.tar.gz
Bump to 5.3.0-5.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--Unlink-the-response-file.patch54
3 files changed, 74 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6f1d3905165..c87fa8a55394 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Dec 11 22:21:18 UTC 2015
+# Mon Feb 29 16:52:54 UTC 2016
pkgbase = arm-linux-gnueabihf-gcc-stage1
pkgdesc = The GNU Compiler Collection. Stage 1 for toolchain building (arm-linux-gnueabihf)
pkgver = 5.3.0
- pkgrel = 2
+ pkgrel = 5
url = http://gcc.gnu.org
arch = i686
arch = x86_64
@@ -11,16 +11,18 @@ pkgbase = arm-linux-gnueabihf-gcc-stage1
license = LGPL
license = FDL
license = custom
- depends = arm-linux-gnueabihf-binutils>=2.25
+ depends = arm-linux-gnueabihf-binutils>=2.26
depends = libmpc
depends = zlib
options = !emptydirs
options = !distcc
options = !strip
- source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-5.3.0/gcc-5.3.0.tar.bz2
+ source = ftp://gcc.gnu.org/pub/gcc/snapshots/5-20160209/gcc-5-20160209.tar.bz2
source = http://isl.gforge.inria.fr/isl-0.15.tar.bz2
- md5sums = c9616fd448f980259c31de613e575719
+ source = Unlink-the-response-file.patch
+ md5sums = 499161c65b639aa5c12a14944582b7ec
md5sums = 8428efbbc6f6e2810ce5c1ba73ecf98c
+ md5sums = 1f4d4ef71004261376d26d5ba6a84499
pkgname = arm-linux-gnueabihf-gcc-stage1
diff --git a/PKGBUILD b/PKGBUILD
index 6fffd1ea1203..d9013818d7ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,19 +9,21 @@ pkgname=${_target}-gcc-stage1
pkgver=5.3.0
_pkgver=5
_islver=0.15
-pkgrel=2
-#_snapshot=5-20150623
+pkgrel=5
+_snapshot=5-20160209
pkgdesc="The GNU Compiler Collection. Stage 1 for toolchain building (${_target})"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL' 'custom')
url="http://gcc.gnu.org"
-depends=("${_target}-binutils>=2.25" 'libmpc' 'zlib')
+depends=("${_target}-binutils>=2.26" 'libmpc' 'zlib')
options=('!emptydirs' '!distcc' '!strip')
-source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
- #ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
-md5sums=('c9616fd448f980259c31de613e575719'
- '8428efbbc6f6e2810ce5c1ba73ecf98c')
+source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
+ http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
+ Unlink-the-response-file.patch)
+md5sums=('499161c65b639aa5c12a14944582b7ec'
+ '8428efbbc6f6e2810ce5c1ba73ecf98c'
+ '1f4d4ef71004261376d26d5ba6a84499')
if [ -n "${_snapshot}" ]; then
_basedir=gcc-${_snapshot}
@@ -43,6 +45,9 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
+ # https://bugs.archlinux.org/task/47874 - commit f591a95d
+ patch -p1 -i $srcdir/Unlink-the-response-file.patch
+
mkdir ${srcdir}/gcc-build
}
diff --git a/Unlink-the-response-file.patch b/Unlink-the-response-file.patch
new file mode 100644
index 000000000000..55c95a7972c9
--- /dev/null
+++ b/Unlink-the-response-file.patch
@@ -0,0 +1,54 @@
+From f591a95d1532ac7791c146a8e55ba3a32b3e476f Mon Sep 17 00:00:00 2001
+From: ebotcazou <ebotcazou@138bc75d-0d04-0410-961f-82ee72b054a4>
+Date: Tue, 23 Jun 2015 20:48:07 +0000
+Subject: [PATCH] * collect-utils.c (collect_wait): Unlink the
+ response file here instead of... (do_wait): ...here.
+ (utils_cleanup): ...and here.
+
+git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@224858 138bc75d-0d04-0410-961f-82ee72b054a4
+---
+ gcc/ChangeLog | 7 +++++++
+ gcc/collect-utils.c | 14 ++++++--------
+ 2 files changed, 13 insertions(+), 8 deletions(-)
+
+diff --git a/gcc/collect-utils.c b/gcc/collect-utils.c
+index 6bbe9eb..517a075 100644
+--- a/gcc/collect-utils.c
++++ b/gcc/collect-utils.c
+@@ -68,6 +68,12 @@ collect_wait (const char *prog, struct pex_obj *pex)
+ fatal_error (input_location, "can't get program status: %m");
+ pex_free (pex);
+
++ if (response_file && !save_temps)
++ {
++ unlink (response_file);
++ response_file = NULL;
++ }
++
+ if (status)
+ {
+ if (WIFSIGNALED (status))
+@@ -90,12 +96,6 @@ do_wait (const char *prog, struct pex_obj *pex)
+ int ret = collect_wait (prog, pex);
+ if (ret != 0)
+ fatal_error (input_location, "%s returned %d exit status", prog, ret);
+-
+- if (response_file && !save_temps)
+- {
+- unlink (response_file);
+- response_file = NULL;
+- }
+ }
+
+
+@@ -224,7 +224,5 @@ utils_cleanup (bool from_signal)
+ calls to maybe_unlink fails. */
+ cleanup_done = true;
+
+- if (response_file)
+- maybe_unlink (response_file);
+ tool_cleanup (from_signal);
+ }
+--
+2.7.1
+