summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Razykov2021-04-04 04:15:32 +0300
committerVyacheslav Razykov2021-04-04 04:15:32 +0300
commit3fbde1547d89d5fff03488b1b09e6221ad885e0a (patch)
tree3343e7bcfe4f8cd7f9384484976ccf211653e988
parent64c846ca20204f7ca8c9d71527e13b524cf9e9c0 (diff)
downloadaur-3fbde1547d89d5fff03488b1b09e6221ad885e0a.tar.gz
Update to 2.33-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--bz26534.patch11
-rw-r--r--bz27343.patch48
4 files changed, 62 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d79072914fed..a52ccfe9fcb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,30 @@
pkgbase = arm-linux-gnueabihf-glibc-headers
pkgdesc = GNU C Library headers (arm-linux-gnueabihf)
- pkgver = 2.32
+ pkgver = 2.33
pkgrel = 1
url = https://www.gnu.org/software/libc/
arch = any
license = GPL
license = LGPL
- makedepends = arm-linux-gnueabihf-gcc-stage1>=10.2.0-1
+ makedepends = arm-linux-gnueabihf-gcc-stage1>=10.2.0-3
makedepends = python
depends = arm-linux-gnueabihf-linux-api-headers>=5.10.9-2
options = !buildflags
options = !strip
options = staticlibs
options = debug
- source = https://ftp.gnu.org/gnu/glibc/glibc-2.32.tar.xz
- source = https://ftp.gnu.org/gnu/glibc/glibc-2.32.tar.xz.sig
+ source = https://ftp.gnu.org/gnu/glibc/glibc-2.33.tar.xz
+ source = https://ftp.gnu.org/gnu/glibc/glibc-2.33.tar.xz.sig
source = sdt.h
source = sdt-config.h
- source = bz26534.patch
+ source = bz27343.patch
validpgpkeys = 7273542B39962DF7B299931416792B4EA25340F8
validpgpkeys = BC7C7372637EC10C57D7AA6579C43DFBF1CF2187
- md5sums = 720c7992861c57cf97d66a2f36d8d1fa
+ md5sums = 390bbd889c7e8e8a7041564cb6b27cca
md5sums = SKIP
md5sums = 91fec3b7e75510ae2ac42533aa2e695e
md5sums = 680df504c683640b02ed4a805797c0b2
- md5sums = fc57038c1297c7c11258e8dda1623ec2
+ md5sums = cfe57018d06bf748b8ca1779980fef33
pkgname = arm-linux-gnueabihf-glibc-headers
diff --git a/PKGBUILD b/PKGBUILD
index 048e7aaca9d0..aaf7e2f9d3e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,25 +8,25 @@
_target="arm-linux-gnueabihf"
pkgname=${_target}-glibc-headers
-pkgver=2.32
+pkgver=2.33
pkgrel=1
pkgdesc="GNU C Library headers (${_target})"
arch=('any')
url="https://www.gnu.org/software/libc/"
license=(GPL LGPL)
depends=("${_target}-linux-api-headers>=5.10.9-2")
-makedepends=("${_target}-gcc-stage1>=10.2.0-1" python)
+makedepends=("${_target}-gcc-stage1>=10.2.0-3" python)
options=(!buildflags !strip staticlibs debug)
source=(https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz{,.sig}
sdt.h sdt-config.h
- bz26534.patch)
+ bz27343.patch)
validpgpkeys=(7273542B39962DF7B299931416792B4EA25340F8 # Carlos O'Donell
BC7C7372637EC10C57D7AA6579C43DFBF1CF2187) # Siddhesh Poyarekar
-md5sums=('720c7992861c57cf97d66a2f36d8d1fa'
+md5sums=('390bbd889c7e8e8a7041564cb6b27cca'
'SKIP'
'91fec3b7e75510ae2ac42533aa2e695e'
'680df504c683640b02ed4a805797c0b2'
- 'fc57038c1297c7c11258e8dda1623ec2')
+ 'cfe57018d06bf748b8ca1779980fef33')
prepare() {
mkdir -p glibc-build
@@ -34,14 +34,8 @@ prepare() {
[[ -d glibc-$pkgver ]] && ln -s glibc-$pkgver glibc
cd glibc
- local i; for i in ${source[@]}; do
- case ${i%::*} in
- *.patch)
- echo "Applying ${i}"
- patch -p1 -i "$srcdir/${i}"
- ;;
- esac
- done
+ # commit c3479fb7939898ec22c655c383454d6e8b982a67
+ patch -p1 -i "$srcdir/bz27343.patch"
}
build() {
diff --git a/bz26534.patch b/bz26534.patch
deleted file mode 100644
index 5a2fdd8e2f81..000000000000
--- a/bz26534.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/sysdeps/x86_64/fpu/multiarch/ifunc-fma4.h 2020-08-25 15:08:15.049364392 +0200
-+++ b/sysdeps/x86_64/fpu/multiarch/ifunc-fma4.h 2020-08-25 15:08:20.012697875 +0200
-@@ -32,7 +32,7 @@
- && CPU_FEATURE_USABLE_P (cpu_features, AVX2))
- return OPTIMIZE (fma);
-
-- if (CPU_FEATURE_USABLE_P (cpu_features, FMA))
-+ if (CPU_FEATURE_USABLE_P (cpu_features, FMA4))
- return OPTIMIZE (fma4);
-
- return OPTIMIZE (sse2);
diff --git a/bz27343.patch b/bz27343.patch
new file mode 100644
index 000000000000..3db6a9440eb2
--- /dev/null
+++ b/bz27343.patch
@@ -0,0 +1,48 @@
+From c3479fb7939898ec22c655c383454d6e8b982a67 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Fri, 5 Feb 2021 07:32:18 +0000
+Subject: [PATCH] nsswitch: return result when nss database is locked [BZ
+ #27343]
+
+Before the change nss_database_check_reload_and_get() did not populate
+the '*result' value when it returned success in a case of chroot
+detection. This caused initgroups() to use garage pointer in the
+following test (extracted from unbound):
+
+```
+
+int main() {
+ // load some NSS modules
+ struct passwd * pw = getpwnam("root");
+
+ chdir("/tmp");
+ chroot("/tmp");
+ chdir("/");
+ // access nsswitch.conf in a chroot
+ initgroups("root", 0);
+}
+```
+
+Reviewed-by: DJ Delorie <dj@redhat.com>
+---
+ nss/nss_database.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/nss/nss_database.c b/nss/nss_database.c
+index cf0306adc4..e1bef6bd75 100644
+--- a/nss/nss_database.c
++++ b/nss/nss_database.c
+@@ -398,8 +398,9 @@ nss_database_check_reload_and_get (struct nss_database_state *local,
+ && (str.st_ino != local->root_ino
+ || str.st_dev != local->root_dev)))
+ {
+- /* Change detected; disable reloading. */
++ /* Change detected; disable reloading and return current state. */
+ atomic_store_release (&local->data.reload_disabled, 1);
++ *result = local->data.services[database_index];
+ __libc_lock_unlock (local->lock);
+ __nss_module_disable_loading ();
+ return true;
+--
+2.27.0
+