summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTavian Barnes2020-05-18 13:37:53 -0400
committerTavian Barnes2020-05-18 13:38:25 -0400
commit97be464fab65f184b63b5b256637dc0189c5802e (patch)
tree766f1d399dac593b93a5861d62b98e385c40acaf
parent8a648207bc653be676efb5f206182e67965cf444 (diff)
downloadaur-97be464fab65f184b63b5b256637dc0189c5802e.tar.gz
Fix debug build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0cb3e4dca09..53bbb02728bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arm-linux-gnueabihf-glibc-headers
pkgdesc = GNU C Library headers (arm-linux-gnueabihf)
pkgver = 2.31
- pkgrel = 3.1
+ pkgrel = 3.2
url = https://www.gnu.org/software/libc/
arch = any
license = GPL
@@ -12,6 +12,7 @@ pkgbase = arm-linux-gnueabihf-glibc-headers
options = !buildflags
options = !strip
options = staticlibs
+ options = debug
source = https://ftp.gnu.org/gnu/glibc/glibc-2.31.tar.xz
source = https://ftp.gnu.org/gnu/glibc/glibc-2.31.tar.xz.sig
source = glibc-18fdba553dd9b907e9812b90d2cea593f776058f.patch
diff --git a/PKGBUILD b/PKGBUILD
index c91635d93388..cc0e62bcb4cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,14 @@
_target="arm-linux-gnueabihf"
pkgname=${_target}-glibc-headers
pkgver=2.31
-pkgrel=3.1
+pkgrel=3.2
pkgdesc="GNU C Library headers (${_target})"
arch=('any')
url="https://www.gnu.org/software/libc/"
license=(GPL LGPL)
depends=("${_target}-linux-api-headers>=5.6.11-1")
makedepends=("${_target}-gcc-stage1" python)
-options=(!buildflags !strip staticlibs)
+options=(!buildflags !strip staticlibs debug)
_commit=18fdba553dd9b907e9812b90d2cea593f776058f
#source=(git+https://sourceware.org/git/glibc.git#commit=$_commit
source=(https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz{,.sig}
@@ -73,8 +73,8 @@ build() {
CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
#
- CFLAGS=${CFLAGS/-fno-plt/}
- CXXFLAGS=${CXXFLAGS/-fno-plt/}
+ CFLAGS="${CFLAGS/-fno-plt/} -g -O2"
+ CXXFLAGS="${CXXFLAGS/-fno-plt/} -g -O2"
LDFLAGS=${LDFLAGS/,-z,now/}
export BUILD_CC=gcc