summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphilanecros2016-09-01 22:32:20 +0900
committerphilanecros2016-09-01 22:32:20 +0900
commit9f6a62b08874e399fc9ab458d1ddbce3392892da (patch)
tree538ef04592398209d447fe1d60ef83c9c909b425
downloadaur-9f6a62b08874e399fc9ab458d1ddbce3392892da.tar.gz
Initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c73387a2ad3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = arm-linux-gnueabihf-musl
+ pkgdesc = Lightweight implementation of C standard library
+ pkgver = 1.1.15
+ pkgrel = 1
+ url = http://www.musl-libc.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = arm-linux-gnueabihf-binutils
+ makedepends = arm-linux-gnueabihf-gcc
+ options = staticlibs
+ options = !buildflags
+ options = !strip
+ source = https://www.musl-libc.org/releases/musl-1.1.15.tar.gz
+ source = https://www.musl-libc.org/releases/musl-1.1.15.tar.gz.asc
+ validpgpkeys = 836489290BB6B70F99FFDA0556BCDB593020450F
+ md5sums = 9590a9d47ee64f220b3c12f7afb864ca
+ md5sums = SKIP
+
+pkgname = arm-linux-gnueabihf-musl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97a82767fb76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# $Id$
+# Maintainer: philanecros <philanecros@gmail.com>
+
+_pkgname=musl
+_target=arm-linux-gnueabihf
+pkgname=$_target-$_pkgname
+pkgver=1.1.15
+pkgrel=1
+pkgdesc='Lightweight implementation of C standard library'
+arch=('i686' 'x86_64')
+url='http://www.musl-libc.org/'
+license=('MIT')
+options=('staticlibs' '!buildflags' '!strip')
+makedepends=('arm-linux-gnueabihf-binutils' 'arm-linux-gnueabihf-gcc')
+validpgpkeys=('836489290BB6B70F99FFDA0556BCDB593020450F')
+source=(https://www.musl-libc.org/releases/musl-$pkgver.tar.gz{,.asc})
+md5sums=('9590a9d47ee64f220b3c12f7afb864ca'
+ 'SKIP')
+_sysroot=/usr/lib/$_target
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=$_sysroot --sysroot=$_sysroot \
+ --bindir=/usr/bin --target=$_target \
+ --enable-wrapper=all
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ install -dm755 "$pkgdir$_sysroot"
+ mv "$pkgdir"/lib/ld-musl*.so* "$pkgdir$_sysroot"
+ rmdir "$pkgdir"/lib
+
+ pushd "$pkgdir"/usr/bin
+ for _bin in *; do
+ mv "$_bin" $_target-$_bin
+ done
+ popd
+
+ install -Dm0644 README "$pkgdir"/usr/share/doc/$pkgname/README
+ install -Dm0644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/COPYRIGHT
+}