summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwtx2020-08-16 08:13:39 +0200
committerwtx2020-08-16 08:13:39 +0200
commit48504dba8847f3f8e728e77a04c2098204fa1006 (patch)
tree123c5a68cc7ab7f99e2f423db0b377af182b725a
parent798c4cbe60c8f3df34dd9c45a9eef7e7266b0616 (diff)
downloadaur-48504dba8847f3f8e728e77a04c2098204fa1006.tar.gz
update path to newlib and disable building info
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile-info.patch11
-rwxr-xr-xPKGBUILD17
3 files changed, 27 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 583095688e07..dba7df11fbdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arm-none-eabi-gcc47-linaro-alternative
pkgdesc = The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) target.
pkgver = 4.7_2014.06
- pkgrel = 1
+ pkgrel = 2
url = https://releases.linaro.org/
arch = i686
arch = x86_64
@@ -21,15 +21,17 @@ pkgbase = arm-none-eabi-gcc47-linaro-alternative
options = zipman
options = docs
source = https://launchpad.net/gcc-linaro/4.7/4.7-2014.06/+download/gcc-linaro-4.7-2014.06.tar.bz2
- source = http://releases.linaro.org/14.09/components/toolchain/newlib-linaro/newlib-linaro-2.1.0-2014.09.tar.bz2
+ source = http://releases.linaro.org/archive/14.09/components/toolchain/newlib-linaro/newlib-linaro-2.1.0-2014.09.tar.bz2
source = gcc-4.7-multilib2.patch
source = gcc-4.7-no-exceptions.patch
source = libc_name_p.patch
+ source = Makefile-info.patch
sha256sums = 4fc5c9fb78882857f988bec979947fc2e55a3ea31640b7ace601bcee3c86fd37
sha256sums = ed92e8547246834725a3c5743fa41d3f573e3e5d2e5066d433ac3c29e6676fc8
sha256sums = 104b9aa652804a56338470983e6975af1d1e5440eb8bddae3a01a966d2b332cf
sha256sums = 3cd19aac3d1c4f46377bf6d82a0130686c6677ee5e817a702a34238f6a748dcd
sha256sums = 9bc036c18d91593dc7cdece388723f38df9a7115d0c7857be35893f42ddda338
+ sha256sums = SKIP
pkgname = arm-none-eabi-gcc47-linaro-alternative
diff --git a/Makefile-info.patch b/Makefile-info.patch
new file mode 100644
index 000000000000..b2cf8daf4023
--- /dev/null
+++ b/Makefile-info.patch
@@ -0,0 +1,11 @@
+--- gcc/Makefile.in 2014-06-25 16:33:29.000000000 +0200
++++ gcc/Makefile.in 2020-08-16 07:42:25.100115012 +0200
+@@ -723,7 +723,7 @@ LIBCONVERT =
+ INSTALL_HEADERS=install-headers install-mkheaders
+
+ # Control whether Info documentation is built and installed.
+-BUILD_INFO = @BUILD_INFO@
++BUILD_INFO =
+
+ # Control whether manpages generated by texi2pod.pl can be rebuilt.
+ GENERATED_MANPAGES = @GENERATED_MANPAGES@
diff --git a/PKGBUILD b/PKGBUILD
index d1540d2defa9..c6697e51a524 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Johnny Halfmoon <jhalfmoon@milksnot.com>
+# Maintainer: wtx <sdrb.onet.eu>
pkgname=arm-none-eabi-gcc47-linaro-alternative
_relver=4.7
@@ -8,7 +8,7 @@ _relverdate=${_relver}-${_reldate}
# This is how I want to define the pkgver, but the AUR doesn't understand it, because multiple _ characters are not allowed
#pkgver=${_relver}_${_reldate//-/_}
pkgver=4.7_2014.06
-pkgrel=1
+pkgrel=2
_newlibver=linaro-2.1.0-2014.09
#_newlibver=2.0.0
pkgdesc="The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) target."
@@ -22,10 +22,11 @@ makedepends=('flex' 'bison')
#conflicts=()
options=(staticlibs !libtool !emptydirs !strip zipman docs)
source=(https://launchpad.net/gcc-linaro/${_relver}/${_relverdate}/+download/gcc-linaro-${_relverdate}.tar.bz2
- http://releases.linaro.org/14.09/components/toolchain/newlib-linaro/newlib-${_newlibver}.tar.bz2
+ http://releases.linaro.org/archive/14.09/components/toolchain/newlib-linaro/newlib-${_newlibver}.tar.bz2
gcc-${_relver}-multilib2.patch
gcc-${_relver}-no-exceptions.patch
- libc_name_p.patch)
+ libc_name_p.patch
+ Makefile-info.patch)
_basedir=gcc-linaro-${_relverdate}
build() {
@@ -38,6 +39,10 @@ build() {
patch -Np0 -i "${srcdir}/gcc-${_relver}-no-exceptions.patch"
patch -Np1 -i "${srcdir}/libc_name_p.patch"
+
+ patch -Np0 -i "${srcdir}/Makefile-info.patch"
+
+
mkdir build
cd build
@@ -72,6 +77,7 @@ build() {
# --libexecdir=/usr/lib \
+
make
}
@@ -88,4 +94,5 @@ sha256sums=('4fc5c9fb78882857f988bec979947fc2e55a3ea31640b7ace601bcee3c86fd37'
'ed92e8547246834725a3c5743fa41d3f573e3e5d2e5066d433ac3c29e6676fc8'
'104b9aa652804a56338470983e6975af1d1e5440eb8bddae3a01a966d2b332cf'
'3cd19aac3d1c4f46377bf6d82a0130686c6677ee5e817a702a34238f6a748dcd'
- '9bc036c18d91593dc7cdece388723f38df9a7115d0c7857be35893f42ddda338')
+ '9bc036c18d91593dc7cdece388723f38df9a7115d0c7857be35893f42ddda338'
+ 'SKIP')