summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Sarawinski2017-06-19 09:09:00 +0200
committerTimo Sarawinski2017-06-19 09:09:00 +0200
commit765375b8a758c3667deb4224ecb1369db636089f (patch)
tree6ea7ac7dfc26c662dab545d0209234ffbd081f93
parent7630e52be6679bdf1bb681044b2d1a12bff19f95 (diff)
downloadaur-765375b8a758c3667deb4224ecb1369db636089f.tar.gz
update to latest snapshot
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD20
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6480555029b4..b71faba45e4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arm-none-eabi-gcc60-linaro
pkgdesc = The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) target.
- pkgver = 6.2_2016.10
+ pkgver = 6.3_2017.06
pkgrel = 1
url = https://releases.linaro.org/
arch = i686
@@ -12,7 +12,7 @@ pkgbase = arm-none-eabi-gcc60-linaro
makedepends = bison
depends = arm-none-eabi-binutils>=2.26-1
depends = gmp
- depends = cloog-git
+ depends = cloog
depends = arm-none-eabi-newlib-linaro-git
depends = mpfr
depends = libmpc
@@ -25,11 +25,11 @@ pkgbase = arm-none-eabi-gcc60-linaro
options = !strip
options = zipman
options = docs
- source = http://snapshots.linaro.org/components/toolchain/gcc-linaro/6.2-2016.10/gcc-linaro-snapshot-6.2-2016.10.tar.xz
+ source = http://snapshots.linaro.org/components/toolchain/gcc-linaro/6.3-2017.06/gcc-linaro-snapshot-6.3-2017.06.tar.xz
source = 0200-gcc-no-exceptions.patch
source = 0300-gcc-multilib2.patch
source = 1039-libcc1-fix-libcc1-s-install-path-and-rpath.patch
- sha256sums = d0082159bd5bb609e07c24a414666e1c2820d9b8ce6e39462f5927d6104fd3d8
+ sha256sums = 173ed3dc04260875cfdad203906532521401a621670c58b7c191e14850a60824
sha256sums = 76eab14830216c774291d2ac35d4b4690f3273aa8c630a2c1546f02538847d8a
sha256sums = c9b6bc1dd53f9b4b80f5fdacdef94c9fce0e516c16fb78063107b66ba2e9fdd1
sha256sums = fa08269d6a748631b07b55a5fe00fa518b2f6e04356a3d6634c60f3c3ece3b07
diff --git a/PKGBUILD b/PKGBUILD
index c4cd33b547a6..97401863b56b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Latest sources are at http://snapshots.linaro.org/components/toolchain/gcc-linaro/
pkgname=arm-none-eabi-gcc60-linaro
-_relver=snapshot-6.2
-_relshortdate=16.10
+_relver=snapshot-6.3
+_relshortdate=17.06
_reldate=20${_relshortdate}
_relverdate=${_relver}-${_reldate}
# This is how I want to define the pkgver, but the AUR doesn't understand it, because multiple _ characters are not allowed
#pkgver=${_relver}_${_reldate//-/_}
-pkgver=6.2_2016.10
-_pkgver=6.2-2016.10
+pkgver=6.3_2017.06
+_pkgver=6.3-2017.06
pkgrel=1
pkgdesc="The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) target."
arch=(i686 x86_64)
url="https://releases.linaro.org/"
license=('GPL' 'LGPL')
groups=('arm-none-eabi-toolchain')
-depends=('arm-none-eabi-binutils>=2.26-1' 'gmp' 'cloog-git' 'arm-none-eabi-newlib-linaro-git' 'mpfr' 'libmpc')
+depends=('arm-none-eabi-binutils>=2.26-1' 'gmp' 'cloog' 'arm-none-eabi-newlib-linaro-git' 'mpfr' 'libmpc')
makedepends=('flex' 'bison')
provides=('arm-none-eabi-gcc')
conflicts=('arm-none-eabi-gcc' 'cross-arm-none-eabi-gcc')
@@ -27,6 +27,11 @@ source=(http://snapshots.linaro.org/components/toolchain/gcc-linaro/${_pkgver}/g
1039-libcc1-fix-libcc1-s-install-path-and-rpath.patch)
_basedir=gcc-linaro-${_relverdate}
+sha256sums=('173ed3dc04260875cfdad203906532521401a621670c58b7c191e14850a60824'
+ '76eab14830216c774291d2ac35d4b4690f3273aa8c630a2c1546f02538847d8a'
+ 'c9b6bc1dd53f9b4b80f5fdacdef94c9fce0e516c16fb78063107b66ba2e9fdd1'
+ 'fa08269d6a748631b07b55a5fe00fa518b2f6e04356a3d6634c60f3c3ece3b07')
+
build() {
cd ${srcdir}
@@ -75,8 +80,3 @@ package() {
}
# vim: set ts=2 sw=2 ft=sh et:
-
-sha256sums=('d0082159bd5bb609e07c24a414666e1c2820d9b8ce6e39462f5927d6104fd3d8'
- '76eab14830216c774291d2ac35d4b4690f3273aa8c630a2c1546f02538847d8a'
- 'c9b6bc1dd53f9b4b80f5fdacdef94c9fce0e516c16fb78063107b66ba2e9fdd1'
- 'fa08269d6a748631b07b55a5fe00fa518b2f6e04356a3d6634c60f3c3ece3b07')