summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2015-06-11 14:54:28 -0400
committerJoey Dumont2015-06-11 14:54:28 -0400
commit1b4b22aaf3b8bc0eee8296bb98b49ee7eafa0f72 (patch)
treeb3497b1ef0d03ac1617d9927e98acd1cd546e24f
downloadaur-1b4b22aaf3b8bc0eee8296bb98b49ee7eafa0f72.tar.gz
Added armadillo to AUR4.
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD33
-rw-r--r--armadillo.install5
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5098c53e921a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = armadillo
+ pkgdesc = C++ linear algebra library
+ pkgver = 5.200.1
+ pkgrel = 1
+ url = http://arma.sourceforge.net/
+ install = armadillo.install
+ arch = i686
+ arch = x86_64
+ license = MPL 2.0
+ makedepends = cmake
+ depends = lapack
+ depends = blas
+ depends = arpack
+ depends = superlu=4.3
+ optdepends = hdf5: HDF5 output
+ source = http://downloads.sourceforge.net/sourceforge/arma/armadillo-5.200.1.tar.gz
+ sha512sums = 750e18a7c464bfe17ed113014312cce54793780d2c5d1f6510faaedac44bc6c055955b0ffba6884ab1111be5c22740a0b3ddcd9533caf51afe1bda33074177f4
+
+pkgname = armadillo
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..67f8c18f0637
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+*.jar
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..018135fb7589
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Joey Dumont <joey.dumont@gmail.com>
+# Contributor: Lucas Hermann Negri <lucashnegri at gmail dot com>
+
+pkgname=armadillo
+pkgver=5.200.1
+pkgrel=1
+pkgdesc="C++ linear algebra library"
+arch=('i686' 'x86_64')
+url="http://arma.sourceforge.net/"
+license=('MPL 2.0')
+depends=('lapack' 'blas' 'arpack' 'superlu=4.3')
+optdepends=('hdf5: HDF5 output')
+makedepends=('cmake')
+source=("http://downloads.sourceforge.net/sourceforge/arma/$pkgname-$pkgver.tar.gz")
+install=("armadillo.install")
+sha512sums=('750e18a7c464bfe17ed113014312cce54793780d2c5d1f6510faaedac44bc6c055955b0ffba6884ab1111be5c22740a0b3ddcd9533caf51afe1bda33074177f4')
+
+build() {
+ if [ "$CARCH" == "x86_64" ]; then
+ ARMA64LIBDIR="-DINSTALL_LIB_DIR:PATH=/usr/lib"
+ fi
+
+ cd "${srcdir}/$pkgname-$pkgver"
+ cmake $ARMA64LIBDIR -DCMAKE_INSTALL_PREFIX:PATH=/usr .
+ make
+}
+
+package() {
+ cd "${srcdir}/$pkgname-$pkgver"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/armadillo.install b/armadillo.install
new file mode 100644
index 000000000000..8ac337144c0f
--- /dev/null
+++ b/armadillo.install
@@ -0,0 +1,5 @@
+post_upgrade() {
+ if [ $(vercmp $2 5.000.0-1) -lt 0 ]; then
+ echo "Version 5.000.0 now uses 64-bit integer by default with C++11 compilers. Verify if this impacts your code. This behaviour can be changed in the config.hpp file."
+ fi
+} \ No newline at end of file