summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVishnu V K2019-07-22 23:50:49 +0530
committerVishnu V K2019-07-22 23:50:49 +0530
commitc5a25bc63467700b05b6aebe3bbcd49ad75354e1 (patch)
treeaa9ee4067f9c705e7d851fd1eb87efb741f6c3ad
downloadaur-c5a25bc63467700b05b6aebe3bbcd49ad75354e1.tar.gz
Initial
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD64
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9bc8f0c42b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = armagetronad-git
+ pkgdesc = A Tron Clone in 3D.
+ pkgver = r4128.7392b902f
+ pkgrel = 1
+ url = http://armagetronad.net/
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ depends = sdl2_image
+ depends = libxml2
+ depends = sdl2_mixer
+ depends = ftgl
+ depends = boost-libs
+ depends = protobuf
+ optdepends = python2: language updater
+ provides = armagetronad
+ conflicts = armagetronad
+ source = git://gitlab.com/armagetronad/armagetronad.git
+ sha1sums = SKIP
+
+pkgname = armagetronad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66b8717e5b9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# $Id$
+# Maintainer: physkets <physkets // at // tutanota dot com>
+# Contributor: Kyle Keen <keenerd@gmail.com>
+# Contributor: Mateusz Herych <heniekk@gmail.com>
+# Contributor: Filippo 'JoeyrS' Civiletti <joeyrs@gmail.com>
+
+_pkgname=armagetronad
+pkgname=${_pkgname}-git
+pkgver='r4128.7392b902f'
+pkgrel=1
+pkgdesc='A Tron Clone in 3D.'
+arch=('x86_64')
+url='http://armagetronad.net/'
+license=('GPL')
+depends=('sdl2_image' 'libxml2' 'sdl2_mixer' 'ftgl' 'boost-libs' 'protobuf')
+optdepends=('python2: language updater')
+makedepends=('boost')
+provides=('armagetronad')
+conflicts=('armagetronad')
+source=("git://gitlab.com/armagetronad/armagetronad.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare(){
+ cd "$srcdir/$_pkgver"
+
+ # python2 fix
+ sed -i 's_#!/usr/bin/python_#!/usr/bin/python2_' language/update.py
+}
+
+pkgver(){
+ cd "$srcdir/$_pkgver"
+ printf "r%s" "$(bzr revno)"
+}
+
+build() {
+ cd "$srcdir/$_pkgver"
+
+ ./bootstrap.sh
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --disable-games \
+ --enable-automakedefaults \
+ --disable-uninstall
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgver"
+ make DESTDIR="$pkgdir" install
+ install -D -m 644 "desktop/$_pkgname-armagetronad.desktop" "$pkgdir/usr/share/applications/$_pkgname-armagetronad.desktop"
+ install -d "$pkgdir/usr/share/pixmaps/"
+ ln -s /usr/share/armagetronad/desktop/icons/large/armagetronad.png \
+ "$pkgdir/usr/share/pixmaps/$_pkgname-armagetronad.png"
+ mv "$pkgdir/usr/bin/armagetronad" "$pkgdir/usr/bin/armagetronad_bin"
+ printf "#!/bin/bash\n/usr/bin/armagetronad_bin --configdir /etc/armagetronad --datadir /usr/share/armagetronad" > "$pkgdir/usr/bin/armagetronad"
+ chmod +x "$pkgdir/usr/bin/armagetronad"
+}