summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Anderson2019-03-11 10:18:04 +0000
committerAndrew Anderson2019-03-11 10:18:04 +0000
commitaeed7274e1c085e031bcdcec6d67d378282bcdfc (patch)
treeccf68d283b4f7af1e6e029a43964b583052660fd
downloadaur-aeed7274e1c085e031bcdcec6d67d378282bcdfc.tar.gz
Init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD61
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7903d7687bb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = armcl-opencl-debug
+ pkgdesc = ARM Computer Vision and Machine Learning Library (x86_64 OpenCL Backend, debug build)
+ pkgver = 19.02
+ pkgrel = 1
+ url = https://github.com/ARM-software/ComputeLibrary
+ arch = x86_64
+ license = MIT
+ makedepends = scons>=2.3
+ makedepends = git
+ makedepends = doxygen>=1.8.5
+ conflicts = armcl-opencl
+ replaces = armcl-opencl
+ options = !strip
+ source = git+https://github.com/ARM-software/ComputeLibrary.git
+ sha1sums = SKIP
+
+pkgname = armcl-opencl-debug
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71fba9d637ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Andrew Anderson <aanderso@tcd.ie>
+
+pkgname=armcl-opencl-debug
+pkgver=19.02
+pkgrel=1
+
+epoch=
+pkgdesc="ARM Computer Vision and Machine Learning Library (x86_64 OpenCL Backend, debug build)"
+arch=( 'x86_64' )
+url="https://github.com/ARM-software/ComputeLibrary"
+license=('MIT')
+groups=()
+depends=()
+makedepends=( 'scons>=2.3' 'git' 'doxygen>=1.8.5' )
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=( 'armcl-opencl' )
+replaces=( 'armcl-opencl' )
+backup=()
+options=( !strip )
+install=
+changelog=
+source=("git+https://github.com/ARM-software/ComputeLibrary.git")
+sha1sums=('SKIP')
+
+build() {
+ cd "${srcdir}/ComputeLibrary"
+ git checkout "v$pkgver"
+ scons -j`cat /proc/cpuinfo | grep -i "processor" | wc -l` \
+ os=linux arch=x86_64 build=native \
+ Werror=0 debug=1 asserts=1 \
+ neon=0 \
+ opencl=1 gles_compute=0 embed_kernels=1 \
+ examples=0 \
+ set_soname=0 \
+ openmp=0 cppthreads=1 \
+ pmu=0 \
+ mali=0 \
+ validation_tests=0 \
+ benchmark_tests=0 \
+ extra_cxx_flags="-fPIC"
+}
+
+#check() {}
+
+package() {
+ cd "${srcdir}/ComputeLibrary"
+ mkdir -p ${pkgdir}/usr/lib/
+ cp -r build/*.a ${pkgdir}/usr/lib/
+ cp -r build/*.so ${pkgdir}/usr/lib/
+
+ # The Compute Library OpenCL runtime
+ mkdir -p ${pkgdir}/usr/lib/arm_compute/
+ cp -r build/src/runtime/CL/* ${pkgdir}/usr/lib/arm_compute/
+
+ mkdir -p ${pkgdir}/usr/include/arm_compute/
+ cp -r arm_compute/* ${pkgdir}/usr/include/arm_compute/
+ cp -r support ${pkgdir}/usr/include/arm_compute/
+ cp -r include/* ${pkgdir}/usr/include/arm_compute/
+}