summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryellowsink2021-05-31 17:34:01 +0100
committeryellowsink2021-05-31 17:36:05 +0100
commitc676ba0ac465135e4325ce5a5c0b3bb8df54a7c8 (patch)
treec93a3a5f7d6e62f4faff9775d4f913b597cf7b94
downloadaur-c676ba0ac465135e4325ce5a5c0b3bb8df54a7c8.tar.gz
should work fine
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c33d694a62e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = armcord-bin
+ pkgdesc = Discord client for lower end and ARM devices.
+ pkgver = 2.4
+ pkgrel = 1
+ url = https://github.com/smartfrigde/armcord
+ arch = arm64
+ license = MIT
+ options = !strip
+ source = https://github.com/smartfrigde/armcord/releases/download/2.4/armcord-linux-arm64.tar.gz
+ sha256sums = 022c6944ee1111e657b8d9899a2c7fd92f6dc42a34e6f08e4aa54a0f844a7c6f
+
+pkgname = armcord-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a392e748835
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+## Maintainer: Cain Atkinson <yellowsink@protonmail.com>
+
+pkgname=armcord-bin
+pkgver=2.4
+pkgrel=1
+pkgdesc="Discord client for lower end and ARM devices."
+arch=('arm64')
+url="https://github.com/smartfrigde/armcord"
+license=('MIT')
+options=(!strip)
+
+source=("https://github.com/smartfrigde/armcord/releases/download/2.4/armcord-linux-arm64.tar.gz")
+sha256sums=("022c6944ee1111e657b8d9899a2c7fd92f6dc42a34e6f08e4aa54a0f844a7c6f")
+
+package() {
+ # enter directory
+ cd "$srcdir/armcord-linux-arm64"
+
+ # move all files to the appropriate place
+ mkdir -p "$pkgdir/opt/armcord"
+ cp -r * "$pkgdir/opt/armcord/"
+
+ # fix perms
+ chmod 644 -R "$pkgdir/opt/armcord/"*
+ chmod 755 "$pkgdir/opt/armcord/armcord"
+
+ # create link
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/armcord/armcord" "$pkgdir/usr/bin/armcord"
+}