summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAiden2024-06-25 20:04:06 -0400
committerAiden2024-06-25 20:04:06 -0400
commitf3eb9830ed23fb08cf61dfb81d97251fcf1795aa (patch)
tree92fef30b854dbe65a6843828cef77246ecc99690
parent4f65f8f987fb57e0ca67a116780e2dbd6a254555 (diff)
downloadaur-f3eb9830ed23fb08cf61dfb81d97251fcf1795aa.tar.gz
Use Corepack
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f12533415c4..65ff9184727f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = armcord-git
pkgdesc = ArmCord dev build using the system electron. ArmCord is a custom client designed to enhance your Discord experience while keeping everything lightweight
- pkgver = r756.81273de
+ pkgver = r1123.4559a39
pkgrel = 1
url = https://github.com/ArmCord/ArmCord
install = notes.install
@@ -9,7 +9,7 @@ pkgbase = armcord-git
license = custom:OSL-3.0
makedepends = git
makedepends = nodejs
- makedepends = npm
+ makedepends = yarn-pnpm-corepack
depends = electron
optdepends = libnotify: Notifications
optdepends = xdg-utils: Open links, files, etc
diff --git a/PKGBUILD b/PKGBUILD
index a47eac861c66..067661466d36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Vendicated <vendicated at riseup dot net>
+# Co-Maintainer Aiden <amb at aspy dot dev>
pkgname=armcord-git
pkgdesc="ArmCord dev build using the system electron. ArmCord is a custom client designed to enhance your Discord experience while keeping everything lightweight"
-pkgver=r756.81273de
+pkgver=r1190.b4f8871
pkgrel=1
arch=("x86_64" "aarch64")
url="https://github.com/ArmCord/ArmCord"
license=("custom:OSL-3.0")
-makedepends=("git" "nodejs" "npm")
+makedepends=("git" "nodejs" "yarn-pnpm-corepack")
depends=("electron")
optdepends=(
'libnotify: Notifications'
@@ -39,8 +40,8 @@ pkgver() {
build() {
cd "$pkgname"
- npx pnpm install --frozen-lockfile --ignore-scripts
- npm run packageQuick
+ pnpm install --frozen-lockfile --ignore-scripts
+ pnpm run packageQuick
}
package() {