summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel-Andrew Pollo-Guilbert2020-10-22 10:58:07 -0400
committerGabriel-Andrew Pollo-Guilbert2020-10-22 10:58:07 -0400
commitae8a16986091851f1aac2b38a5daa5b29cb972b7 (patch)
treed6642084904e46cd6530410a9a8606b0af1bc5ab
downloadaur-ae8a16986091851f1aac2b38a5daa5b29cb972b7.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23b11a399858
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = armeb-none-eabi-gcc75-linaro-bin
+ pkgdesc = The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) big-endian target.
+ pkgver = 7.5_2019.12
+ pkgrel = 1
+ url = https://www.linaro.org/downloads/
+ arch = x86_64
+ license = GPL
+ source = https://releases.linaro.org/components/toolchain/binaries/7.5-2019.12/armeb-eabi/gcc-linaro-7.5.0-2019.12-x86_64_armeb-eabi.tar.xz
+ md5sums = SKIP
+
+pkgname = armeb-none-eabi-gcc75-linaro-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf84e26a88c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Gabriel-Andrew Pollo-Guilbert <gabrielpolloguilbert@gmail.com>
+
+_ver=7.5
+_verfull=${_ver}.0
+_abi=armeb-eabi
+_release=2019.12
+_toolchain="gcc-linaro-${_verfull}-${_release}-x86_64_${_abi}"
+
+pkgname=armeb-none-eabi-gcc75-linaro-bin
+pkgver=${_ver}_${_release}
+pkgrel=1
+pkgdesc='The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) big-endian target.'
+arch=('x86_64')
+url='https://www.linaro.org/downloads/'
+license=('GPL')
+source=(
+ "https://releases.linaro.org/components/toolchain/binaries/${_ver}-${_release}/${_abi}/${_toolchain}.tar.xz"
+)
+md5sums=(
+ 'SKIP'
+)
+
+package() {
+ mkdir -p "${pkgdir}/opt/${pkgname}/"
+ cp -Rv "${srcdir}/${_toolchain}/." "${pkgdir}/opt/${pkgname}"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ for binary in "${srcdir}/${_toolchain}/bin/"*; do
+ ln -sv "/opt/${pkgname}/bin/$(basename ${binary})" "${pkgdir}/usr/bin/$(basename "${binary}")"
+ done
+}