summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLemonBoy2015-09-03 20:01:38 +0200
committerLemonBoy2015-09-03 20:01:38 +0200
commit32c8ecffeec9ab1293b31137a7b0e376bccd38fe (patch)
treed9e41ec181982a981ffbd2135b522d0ac6dde3e7
downloadaur-32c8ecffeec9ab1293b31137a7b0e376bccd38fe.tar.gz
Initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4072137a5b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = armips-git
+ pkgdesc = MIPS/ARM assembler
+ pkgver = 20150903.8bd93be
+ pkgrel = 1
+ url = https://github.com/Kingcom/armips
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ provides = armips
+ conflicts = armips
+ source = git+https://github.com/Kingcom/tinyformat
+ source = git+https://github.com/Kingcom/armips.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = armips-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dcfb30eda50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: The Lemon Man
+
+pkgname=armips-git
+pkgver=20150903.8bd93be
+pkgrel=1
+pkgdesc='MIPS/ARM assembler'
+arch=('i686' 'x86_64')
+url='https://github.com/Kingcom/armips'
+license=('MIT')
+makedepends=('git' 'cmake')
+provides=('armips')
+conflicts=('armips')
+source=('git+https://github.com/Kingcom/tinyformat'
+ 'git+https://github.com/Kingcom/armips.git')
+sha256sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/armips"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+prepare() {
+ cd "$srcdir/armips"
+
+ git submodule init
+ git config submodule.ext/tinyformat.url "$srcdir"/tinyformat
+ git submodule update ext/tinyformat
+}
+
+build() {
+ cd "$srcdir/armips"
+ cmake .
+ make
+}
+
+package() {
+ cd "$srcdir/armips"
+ mkdir -p "$pkgdir"/usr/bin
+ install -Dm755 armips "$pkgdir"/usr/bin/armips
+}