summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Toombs2020-12-20 02:23:26 -0500
committerEric Toombs2020-12-20 02:23:26 -0500
commit256c554abc1dd7f733de9e03be19672e6d6716d6 (patch)
treedcaa9826ae1b62387eef0483af31d1b166dfef2e
downloadaur-256c554abc1dd7f733de9e03be19672e6d6716d6.tar.gz
First commit!
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85cc47ef5ed2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = armpl
+ pkgdesc = ARM's closed-source high-performance numerical programming library. Includes BLAS, CBLAS, and LAPACK implementations.
+ pkgver = 20.3
+ pkgrel = 1
+ url = https://developer.arm.com/tools-and-software/server-and-hpc/downloads/arm-performance-libraries
+ arch = aarch64
+ license = custom
+ depends = gcc-fortran
+ provides = blas
+ provides = lapack
+ provides = cblas
+ source = https://developer.arm.com/-/media/Files/downloads/hpc/arm-performance-libraries/20-3-0/Ubuntu16.04/arm-performance-libraries_20.3_Ubuntu-16.04_gcc-9.3.tar
+ sha256sums = 8fc078d78443894bdde71a49f7b39d513cf1f5e02db723eb833370d0cb2d635a
+
+pkgname = armpl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34c05c00b884
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Eric Toombs
+
+pkgname='armpl'
+pkgver='20.3'
+pkgrel='1'
+pkgdesc='ARM'\''s closed-source high-performance numerical programming library. Includes BLAS, CBLAS, and LAPACK implementations.'
+url='https://developer.arm.com/tools-and-software/server-and-hpc/downloads/arm-performance-libraries'
+depends=()
+arch=('aarch64')
+depends=('gcc-fortran')
+provides=('blas' 'lapack' 'cblas')
+license=('custom')
+source=(
+ "https://developer.arm.com/-/media/Files/downloads/hpc/arm-performance-libraries/20-3-0/Ubuntu16.04/arm-performance-libraries_20.3_Ubuntu-16.04_gcc-9.3.tar"
+)
+sha256sums=('8fc078d78443894bdde71a49f7b39d513cf1f5e02db723eb833370d0cb2d635a')
+
+package() {
+ cd "$srcdir/arm-performance-libraries_20.3_Ubuntu-16.04"
+ ./arm-performance-libraries_20.3_Ubuntu-16.04.sh -a -f -s .
+ bsdtar xvf 'armpl_20.3_gcc-9.3.deb'
+ cd "$pkgdir"
+ tar xvf "$srcdir/arm-performance-libraries_20.3_Ubuntu-16.04/data.tar.gz"
+
+ install_lib_dir='/opt/arm/armpl_20.3_gcc-9.3/lib'
+
+ # Provide compatibility to binaries expecting any of these generic BLAS
+ # and LAPACK so names.
+ mkdir -p 'usr/lib'
+ cd "$pkgdir/usr/lib"
+ ln -s "$install_lib_dir/libarmpl.so" 'liblapack.so.3'
+ ln -s 'liblapack.so.3' 'liblapack.so'
+ ln -s "$install_lib_dir/libarmpl.so" 'libblas.so.3'
+ ln -s 'libblas.so.3' 'libblas.so'
+ ln -s "$install_lib_dir/libarmpl.so" 'libcblas.so.3'
+ ln -s 'libcblas.so.3' 'libcblas.so'
+
+ # Provide compatibility to binaries specifically expecting armpl.
+ mkdir -p "$pkgdir/etc/ld.so.conf.d"
+ echo "$install_lib_dir" >"$pkgdir/etc/ld.so.conf.d/armpl.conf"
+}