summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjon2016-12-09 23:42:19 -0500
committerjon2016-12-09 23:43:12 -0500
commit01195a096f70dce2b2170d07dfec4357b1b59271 (patch)
tree2a0443f5da5701e5832501f2d1cd7303716539a9
parent6c2eb62cdc19944452ed8af2e63e3581e0766cb9 (diff)
downloadaur-01195a096f70dce2b2170d07dfec4357b1b59271.tar.gz
update to version 2.1
-rw-r--r--.SRCINFO22
-rw-r--r--ARMSim.exe.config.patch11
-rw-r--r--PKGBUILD34
-rw-r--r--armsimsharp5
-rw-r--r--armsimsharp.patch6
5 files changed, 38 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc71a8c6bb63..916ee5dbfda4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Dec 10 04:42:49 UTC 2016
pkgbase = armsimsharp
- pkgdesc = The ARMSim# program.
- pkgver = 1.91
- pkgrel = 1
- url = http://armsim.cs.uvic.ca/index.html
+ pkgdesc = A desktop application for simulating the execution of ARM assembly language programs.
+ pkgver = 2.1
+ pkgrel = 0
+ url = http://webhome.cs.uvic.ca/~nigelh/ARMSim-V2.1
arch = any
+ license = GPL
+ depends = arm-none-eabi-binutils
depends = mono
- source = http://armsim.cs.uvic.ca/Downloads/ARMSim-191-MAC.zip
- source = ARMSim.exe.config.patch
source = armsimsharp
- md5sums = ea523500526e19c73965b4fb8108163f
- md5sums = 9d411f7f252516fa289756efe6eed5cd
- md5sums = 815e1e557b89f634b136a252c6fc61db
+ source = armsimsharp.patch
+ source = http://webhome.cs.uvic.ca/~nigelh/ARMSim-V2.1/LinuxFiles/ARMSimLinuxFiles.zip
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 53d7c46165b10ad8777fac8e5ee76ce4fca47ac1d606d5fa7fbfc09810527884
pkgname = armsimsharp
diff --git a/ARMSim.exe.config.patch b/ARMSim.exe.config.patch
deleted file mode 100644
index 47323629c7b6..000000000000
--- a/ARMSim.exe.config.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ARMSim.exe.config 2009-12-09 12:25:56.000000000 -0500
-+++ ARMSim.exe.configNew 2015-11-15 14:22:08.689964100 -0500
-@@ -13,7 +13,7 @@
- <!-- This key defines which window manager to use. -->
- <!-- Leave it commented out to use the Docking Windows version (usually for Windows) -->
- <!-- Uncomment it to use the static windows (usually for MONO) -->
-- <!-- <add key="DockingWindowStyle" value="StaticWindows"></add> -->
-+ <add key="DockingWindowStyle" value="StaticWindows"></add>
-
- </appSettings>
- </configuration>
diff --git a/PKGBUILD b/PKGBUILD
index 10e102b4196e..80e863098ae2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Maintainer: Stephen Smith <stephen304@gmail.com>
pkgname=armsimsharp
-pkgver=1.91
-pkgrel=1
-pkgdesc="The ARMSim# program."
-arch=(any)
-url="http://armsim.cs.uvic.ca/index.html"
-depends=(mono)
-source=("http://armsim.cs.uvic.ca/Downloads/ARMSim-191-MAC.zip" "ARMSim.exe.config.patch" "armsimsharp")
-md5sums=('ea523500526e19c73965b4fb8108163f'
- '9d411f7f252516fa289756efe6eed5cd'
- '815e1e557b89f634b136a252c6fc61db')
+pkgver=2.1
+pkgrel=0
+pkgdesc='A desktop application for simulating the execution of ARM assembly language programs.'
+url="http://webhome.cs.uvic.ca/~nigelh/ARMSim-V${pkgver}"
+license=('GPL')
+arch=('any')
+depends=('arm-none-eabi-binutils' 'mono')
+source=("${pkgname}" "${pkgname}.patch" "http://webhome.cs.uvic.ca/~nigelh/ARMSim-V${pkgver}/LinuxFiles/ARMSimLinuxFiles.zip")
+sha256sums=('SKIP' 'SKIP' '53d7c46165b10ad8777fac8e5ee76ce4fca47ac1d606d5fa7fbfc09810527884')
+
prepare() {
- rm ARMSim-191-MAC.zip
- patch -d "${srcdir}" < ARMSim.exe.config.patch
- rm ARMSim.exe.config.patch
+ patch --quiet --strip=0 "--directory=${srcdir}" "--input=${srcdir}/${pkgname}.patch"
+ ln --symbolic /usr/bin/arm-none-eabi-as "${srcdir}/arm-none-eabi-as"
}
+
package() {
- install -d "$pkgdir/opt/armsimsharp"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
- rm armsimsharp
- install -Dm644 "$srcdir/"* "$pkgdir/opt/armsimsharp/"
+ install -D --mode=u=rwx,go=rx "--target-directory=${pkgdir}/usr/bin" "${srcdir}/${pkgname}"
+ install -D --mode=u=rw,go=r "--target-directory=${pkgdir}/opt/${pkgname}" "${srcdir}"/*.{config,dll,exe}
+ cp --no-dereference "${srcdir}/arm-none-eabi-as" "${pkgdir}/opt/${pkgname}"
}
diff --git a/armsimsharp b/armsimsharp
index 37942262b367..a4a7c3049095 100644
--- a/armsimsharp
+++ b/armsimsharp
@@ -1,2 +1,3 @@
-#!/bin/bash
-mono /opt/armsimsharp/ARMSim.exe
+#!/bin/sh
+
+mono /opt/armsimsharp/ARMSim.exe "$@"
diff --git a/armsimsharp.patch b/armsimsharp.patch
new file mode 100644
index 000000000000..632090b4e5da
--- /dev/null
+++ b/armsimsharp.patch
@@ -0,0 +1,6 @@
+--- ARMSim.exe.config
++++ ARMSim.exe.config
+16c16
+< <add key="DockingWindowStyle" value="DockingWindows2"></add>
+---
+> <add key="DockingWindowStyle" value="StaticWindows"></add>