summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Smith2015-11-15 16:12:50 -0500
committerStephen Smith2015-11-15 16:12:50 -0500
commit2c97ad6ee741119361ea1a86b2d63519c59bb346 (patch)
tree65105060e2a920b3630178e4355a65aab24b1502
downloadaur-2c97ad6ee741119361ea1a86b2d63519c59bb346.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--ARMSim.exe.config.patch11
-rw-r--r--PKGBUILD23
-rw-r--r--armsimsharp2
4 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8657d60e88c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = armsimsharp
+ pkgdesc = The ARMSim# program.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://armsim.cs.uvic.ca/index.html
+ arch = any
+ depends = mono
+ source = http://armsim.cs.uvic.ca/Downloads/ARMSim-191-MAC.zip
+ source = ARMSim.exe.config.patch
+ source = armsimsharp
+ md5sums = ea523500526e19c73965b4fb8108163f
+ md5sums = 9d411f7f252516fa289756efe6eed5cd
+ md5sums = 815e1e557b89f634b136a252c6fc61db
+
+pkgname = armsimsharp
+
diff --git a/ARMSim.exe.config.patch b/ARMSim.exe.config.patch
new file mode 100644
index 000000000000..47323629c7b6
--- /dev/null
+++ b/ARMSim.exe.config.patch
@@ -0,0 +1,11 @@
+--- ARMSim.exe.config 2009-12-09 12:25:56.000000000 -0500
++++ ARMSim.exe.configNew 2015-11-15 14:22:08.689964100 -0500
+@@ -13,7 +13,7 @@
+ <!-- This key defines which window manager to use. -->
+ <!-- Leave it commented out to use the Docking Windows version (usually for Windows) -->
+ <!-- Uncomment it to use the static windows (usually for MONO) -->
+- <!-- <add key="DockingWindowStyle" value="StaticWindows"></add> -->
++ <add key="DockingWindowStyle" value="StaticWindows"></add>
+
+ </appSettings>
+ </configuration>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d01c9c2cd36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stephen Smith <stephen304@gmail.com>
+pkgname=armsimsharp
+pkgver=1.0
+pkgrel=1
+pkgdesc="The ARMSim# program."
+arch=(any)
+url="http://armsim.cs.uvic.ca/index.html"
+depends=(mono)
+source=("http://armsim.cs.uvic.ca/Downloads/ARMSim-191-MAC.zip" "ARMSim.exe.config.patch" "armsimsharp")
+md5sums=('ea523500526e19c73965b4fb8108163f'
+ '9d411f7f252516fa289756efe6eed5cd'
+ '815e1e557b89f634b136a252c6fc61db')
+# install=$pkgname.install
+
+prepare() {
+ patch -d "${srcdir}" < ARMSim.exe.config.patch
+}
+
+package() {
+ install -d "$pkgdir/opt/armsimsharp"
+ install -Dm644 "$srcdir/"* "$pkgdir/opt/armsimsharp/"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/armsimsharp b/armsimsharp
new file mode 100644
index 000000000000..37942262b367
--- /dev/null
+++ b/armsimsharp
@@ -0,0 +1,2 @@
+#!/bin/bash
+mono /opt/armsimsharp/ARMSim.exe