summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjon2017-03-01 15:37:26 -0500
committerjon2017-03-01 15:37:26 -0500
commit5bcec4cd7a81a9e4ae086eff8a627ed751f3a4ac (patch)
tree34febad89e26835d2efb6cc6d273149ca4f3fdb1
parent419982bd9137ca0c4cec89ca0db0b50208e81f69 (diff)
downloadaur-5bcec4cd7a81a9e4ae086eff8a627ed751f3a4ac.tar.gz
replace link with script so that arm-none-eabi-as comes from path
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--arm-none-eabi-as4
-rw-r--r--armsimsharp3
4 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2288e68daf48..5d546de3f00e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Sat Dec 10 05:19:21 UTC 2016
pkgbase = armsimsharp
pkgdesc = A desktop application for simulating the execution of ARM assembly language programs.
pkgver = 2.1
@@ -11,9 +9,11 @@ pkgbase = armsimsharp
depends = mono
source = armsimsharp
source = armsimsharp.patch
+ source = arm-none-eabi-as
source = https://webhome.cs.uvic.ca/~nigelh/ARMSim-V2.1/LinuxFiles/ARMSimLinuxFiles.zip
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 53d7c46165b10ad8777fac8e5ee76ce4fca47ac1d606d5fa7fbfc09810527884
pkgname = armsimsharp
diff --git a/PKGBUILD b/PKGBUILD
index b055a0ad594f..38837bcd5b62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,17 @@ url="https://webhome.cs.uvic.ca/~nigelh/ARMSim-V${pkgver}/"
license=('GPL')
arch=('any')
depends=('arm-none-eabi-binutils' 'mono')
-source=("${pkgname}" "${pkgname}.patch" "https://webhome.cs.uvic.ca/~nigelh/ARMSim-V${pkgver}/LinuxFiles/ARMSimLinuxFiles.zip")
-sha256sums=('SKIP' 'SKIP' '53d7c46165b10ad8777fac8e5ee76ce4fca47ac1d606d5fa7fbfc09810527884')
+source=("${pkgname}" "${pkgname}.patch" 'arm-none-eabi-as' "https://webhome.cs.uvic.ca/~nigelh/ARMSim-V${pkgver}/LinuxFiles/ARMSimLinuxFiles.zip")
+sha256sums=('SKIP' 'SKIP' 'SKIP' '53d7c46165b10ad8777fac8e5ee76ce4fca47ac1d606d5fa7fbfc09810527884')
prepare() {
patch --quiet --strip=0 "--directory=${srcdir}" "--input=${srcdir}/${pkgname}.patch"
- ln --symbolic /usr/bin/arm-none-eabi-as "${srcdir}/arm-none-eabi-as"
}
package() {
install -D --mode=u=rwx,go=rx "--target-directory=${pkgdir}/usr/bin" "${srcdir}/${pkgname}"
install -D --mode=u=rw,go=r "--target-directory=${pkgdir}/opt/${pkgname}" "${srcdir}"/*.{config,dll,exe}
- cp --no-dereference "${srcdir}/arm-none-eabi-as" "${pkgdir}/opt/${pkgname}"
+ install -D --mode=u=rwx,go=rx "--target-directory=${pkgdir}/opt/${pkgname}" "${srcdir}/arm-none-eabi-as"
}
diff --git a/arm-none-eabi-as b/arm-none-eabi-as
new file mode 100644
index 000000000000..2ec82a5e5273
--- /dev/null
+++ b/arm-none-eabi-as
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+
+exec arm-none-eabi-as "${@}"
diff --git a/armsimsharp b/armsimsharp
index a4a7c3049095..81cef8aedbdb 100644
--- a/armsimsharp
+++ b/armsimsharp
@@ -1,3 +1,4 @@
#!/bin/sh
-mono /opt/armsimsharp/ARMSim.exe "$@"
+
+mono /opt/armsimsharp/ARMSim.exe "${@}"