summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël PORTAY2023-10-03 02:25:59 +0200
committerGaël PORTAY2023-10-03 02:25:59 +0200
commit4dfc464346f4dcfc8f03df7deb36596377f295d2 (patch)
treeb47e2090c7497e74651d75966e9e4ff91f3f1363
parent33a2ac58a24ad10a332926712d0e53d576873a35 (diff)
downloadaur-4dfc464346f4dcfc8f03df7deb36596377f295d2.tar.gz
v2023.08-1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
-rw-r--r--hooks.install-armv5-eabi-glibc-bleeding-edge-toolchain7
-rw-r--r--profile.sh-armv5-eabi-glibc-bleeding-edge-toolchain3
4 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e08ddea9a58..7ee800ecaf3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,10 +3,13 @@ pkgbase = armv5-eabi-glibc-bleeding-edge-toolchain
pkgver = 2023.08
pkgrel = 1
url = https://toolchains.bootlin.com/
+ install = hooks.install-armv5-eabi-glibc-bleeding-edge-toolchain
arch = x86_64
license = GPL
source = https://toolchains.bootlin.com/downloads/releases/toolchains/armv5-eabi/tarballs/armv5-eabi--glibc--bleeding-edge-2023.08-1.tar.bz2
+ source = profile.sh-armv5-eabi-glibc-bleeding-edge-toolchain
sha256sums = 79e017a9f7455a679eeb734c029cf17b32c62c30e85e39d48154645f2bef7f11
+ sha256sums = 0393a397690b72ed670dcd34aa3fd2b5f85f2edac4dd08b7837377b7ff8110ef
pkgname = armv5-eabi-glibc-bleeding-edge-toolchain
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index c3fb1fee3754..ccc9a9b0e6b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,11 @@ pkgdesc="Ready-to-use cross-compilation toolchain provided by bootlin.com"
arch=("x86_64")
url="https://toolchains.bootlin.com/"
license=("GPL")
-source=("https://toolchains.bootlin.com/downloads/releases/toolchains/armv5-eabi/tarballs/armv5-eabi--glibc--bleeding-edge-2023.08-1.tar.bz2")
-sha256sums=('79e017a9f7455a679eeb734c029cf17b32c62c30e85e39d48154645f2bef7f11')
+source=("https://toolchains.bootlin.com/downloads/releases/toolchains/armv5-eabi/tarballs/armv5-eabi--glibc--bleeding-edge-2023.08-1.tar.bz2"
+ "profile.sh-armv5-eabi-glibc-bleeding-edge-toolchain")
+install="hooks.install-armv5-eabi-glibc-bleeding-edge-toolchain"
+sha256sums=('79e017a9f7455a679eeb734c029cf17b32c62c30e85e39d48154645f2bef7f11'
+ '0393a397690b72ed670dcd34aa3fd2b5f85f2edac4dd08b7837377b7ff8110ef')
build() {
cd "armv5-eabi--glibc--bleeding-edge-2023.08-1"
@@ -24,4 +27,7 @@ package() {
mkdir -p "$pkgdir/opt/armv5-eabi-glibc-bleeding-edge/"
cp -a * "$pkgdir/opt/armv5-eabi-glibc-bleeding-edge/"
rm -f "$pkgdir/opt/armv5-eabi-glibc-bleeding-edge/{buildroot.config,relocate-sdk.sh,summary.csv,share/buildroot/sdk-location}"
+
+ mkdir -p "$pkgdir/etc/profile.d/"
+ install -m0644 "$srcdir/profile.sh-armv5-eabi-glibc-bleeding-edge-toolchain" "$pkgdir/etc/profile.d/armv5-eabi-glibc-bleeding-edge-toolchain.sh"
}
diff --git a/hooks.install-armv5-eabi-glibc-bleeding-edge-toolchain b/hooks.install-armv5-eabi-glibc-bleeding-edge-toolchain
new file mode 100644
index 000000000000..76989424bb48
--- /dev/null
+++ b/hooks.install-armv5-eabi-glibc-bleeding-edge-toolchain
@@ -0,0 +1,7 @@
+post_install() {
+ echo "bootlin toolchain installed to /opt/armv5-eabi-glibc-bleeding-edge"
+ echo "The PATH variable will be updated on re-login. To immediately load it:"
+ echo ""
+ echo " source /etc/profile.d/armv5-eabi-glibc-bleeding-edge.sh"
+ echo ""
+}
diff --git a/profile.sh-armv5-eabi-glibc-bleeding-edge-toolchain b/profile.sh-armv5-eabi-glibc-bleeding-edge-toolchain
new file mode 100644
index 000000000000..6d58a0bf780f
--- /dev/null
+++ b/profile.sh-armv5-eabi-glibc-bleeding-edge-toolchain
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+export PATH="$PATH:/opt/armv5-eabi-glibc-bleeding-edge/bin"