summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël PORTAY2023-10-01 16:36:44 +0200
committerGaël PORTAY2023-10-01 16:36:44 +0200
commit9493401462920aa264b099ab4ebe0480418a3116 (patch)
tree5e77970bb16c6954ffbd7548c785019bac1cea9f
downloadaur-9493401462920aa264b099ab4ebe0480418a3116.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e89053a75984
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = armv7-eabihf-musl-bleeding-edge-toolchain
+ pkgdesc = Ready-to-use cross-compilation toolchain provided by bootlin.com
+ pkgver = 2023.08
+ pkgrel = 1
+ url = https://toolchains.bootlin.com/
+ arch = x86_64
+ license = GPL
+ source = https://toolchains.bootlin.com/downloads/releases/toolchains/armv7-eabihf/tarballs/armv7-eabihf--musl--bleeding-edge-2023.08-1.tar.bz2
+ sha256sums = 6422c3fe6cb66694a0c3384e39ffe352b3e69cf4035e64180765a23973bb00d1
+
+pkgname = armv7-eabihf-musl-bleeding-edge-toolchain
+ options = !strip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8839588fa20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gaël PORTAY <gael.portay@gmail.com>
+
+pkgname=armv7-eabihf-musl-bleeding-edge-toolchain
+pkgver=2023.08
+pkgrel=1
+pkgdesc="Ready-to-use cross-compilation toolchain provided by bootlin.com"
+arch=("x86_64")
+url="https://toolchains.bootlin.com/"
+license=("GPL")
+source=("https://toolchains.bootlin.com/downloads/releases/toolchains/armv7-eabihf/tarballs/armv7-eabihf--musl--bleeding-edge-2023.08-1.tar.bz2")
+sha256sums=('6422c3fe6cb66694a0c3384e39ffe352b3e69cf4035e64180765a23973bb00d1')
+
+build() {
+ cd "armv7-eabihf--musl--bleeding-edge-2023.08-1"
+
+ sh relocate-sdk.sh "/opt/armv7-eabihf-musl-bleeding-edge"
+}
+
+package() {
+ options=(!strip)
+
+ cd "armv7-eabihf--musl--bleeding-edge-2023.08-1"
+
+ mkdir -p "$pkgdir/opt/armv7-eabihf-musl-bleeding-edge/"
+ cp -a * "$pkgdir/opt/armv7-eabihf-musl-bleeding-edge/"
+ rm -f "$pkgdir/opt/armv7-eabihf-musl-bleeding-edge/{buildroot.config,relocate-sdk.sh,summary.csv,share/buildroot/sdk-location}"
+}