summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten de Vries2017-09-17 15:46:18 +0200
committerMaarten de Vries2017-09-17 15:46:18 +0200
commitc1e55eb71545221ccbc24e994ca8f6f3e19fd68f (patch)
treebbb4f151a5da18f2bb64f4bf80b59b9005a7e9e2
downloadaur-c1e55eb71545221ccbc24e994ca8f6f3e19fd68f.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD66
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..892e25f3466c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = armv7l-linux-gnueabihf-binutils
+ pkgdesc = A set of programs to assemble and manipulate binary and object files for the ARM64 target
+ pkgver = 2.29
+ pkgrel = 1
+ url = http://www.gnu.org/software/binutils/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = zlib
+ source = ftp://ftp.gnu.org/gnu/binutils/binutils-2.29.tar.bz2
+ source = ftp://ftp.gnu.org/gnu/binutils/binutils-2.29.tar.bz2.sig
+ validpgpkeys = EAF1C276A747E9ED86210CBAC3126D3B4AE55E93
+ sha1sums = 4376bce1e58d591c6a5dd44fc8713f154208d735
+ sha1sums = SKIP
+
+pkgname = armv7l-linux-gnueabihf-binutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3555ca503425
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Maarten de Vries <maarten@de-vri.es>
+# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+_target=armv7l-linux-gnueabihf
+pkgname=$_target-binutils
+pkgver=2.29
+pkgrel=1
+#_commit=2bd25930
+pkgdesc='A set of programs to assemble and manipulate binary and object files for the ARM64 target'
+arch=(i686 x86_64)
+url='http://www.gnu.org/software/binutils/'
+license=(GPL)
+depends=(zlib)
+source=(ftp://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig})
+sha1sums=('4376bce1e58d591c6a5dd44fc8713f154208d735'
+ 'SKIP')
+validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93') # Tristan Gingold <gingold@adacore.com>
+
+prepare() {
+ cd binutils-$pkgver
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+}
+
+build() {
+ cd binutils-$pkgver
+
+ if [ "${CARCH}" != "i686" ];
+ then
+ # enabling gold linker at i686 makes the install fail
+ enable_gold='--enable-gold'
+ fi
+
+ ./configure --target=$_target \
+ --with-sysroot=/usr/$_target \
+ --prefix=/usr \
+ --disable-multilib \
+ --with-gnu-as \
+ --with-gnu-ld \
+ --disable-nls \
+ --enable-ld=default \
+ $enable_gold \
+ --enable-plugins \
+ --enable-deterministic-archives
+
+ make
+}
+
+check() {
+ cd binutils-$pkgver
+
+ # unset LDFLAGS as testsuite makes assumptions about which ones are active
+ # do not abort on errors - manually check log files
+ make -k LDFLAGS="" check || true
+}
+
+package() {
+ cd binutils-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ # Remove file conflicting with host binutils and manpages for MS Windows tools
+ rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,nlmconv,windres,windmc}*
+
+ # Remove info documents that conflict with host version
+ rm -r "$pkgdir"/usr/share/info
+}