summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorflygoat2017-01-27 13:23:57 +0800
committerflygoat2017-01-27 13:23:57 +0800
commitb2b15eeed7c008ee84d192daa2717fffd85c8322 (patch)
treeeb658ad85f0dc48cd429a0163f7eed5a64b42117
downloadaur-armv8l-linux-gnueabihf-gdb.tar.gz
Add files
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..175494514bf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = armv8l-linux-gnueabihf-gdb
+ pkgdesc = The GNU Debugger for the ARM hard float target
+ pkgver = 7.11
+ pkgrel = 1
+ url = http://www.gnu.org/software/gdb/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = texinfo
+ depends = xz
+ depends = ncurses
+ depends = expat
+ depends = python2
+ depends = guile
+ options = !emptydirs
+ source = http://ftp.gnu.org/gnu/gdb/gdb-7.11.tar.xz
+ sha256sums = 7a434116cb630d77bb40776e8f5d3937bed11dea56bafebb4d2bc5dd389fe5c1
+
+pkgname = armv8l-linux-gnueabihf-gdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..caf2278d36f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+_target=armv8l-linux-gnueabihf
+pkgname=$_target-gdb
+pkgver=7.11
+pkgrel=1
+pkgdesc='The GNU Debugger for the ARM hard float target'
+arch=(i686 x86_64)
+url='http://www.gnu.org/software/gdb/'
+license=(GPL3)
+depends=(xz ncurses expat python2 guile)
+makedepends=(texinfo)
+options=(!emptydirs)
+source=(http://ftp.gnu.org/gnu/gdb/gdb-$pkgver.tar.xz)
+sha256sums=('7a434116cb630d77bb40776e8f5d3937bed11dea56bafebb4d2bc5dd389fe5c1')
+
+build() {
+ cd gdb-$pkgver
+
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+
+ ./configure --target=$_target \
+ --prefix=/usr \
+ --enable-multilib \
+ --enable-interwork \
+ --with-system-readline \
+ --disable-nls \
+ --with-python=/usr/bin/python2 \
+ --with-system-gdbinit=/etc/gdb/gdbinit
+ make
+}
+
+package() {
+ cd gdb-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ # Following files conflict with 'gdb' package
+ rm -r "$pkgdir"/usr/share/info
+ # TOTHINK: we remove python module used for debugging. It means arm-*-gdb alone will not be able to debug and 'gdb' package
+ # should be installed. File a bug upstream - ask a separate python module folder for cross tools.
+ rm -r "$pkgdir"/usr/share/gdb
+ rm -r "$pkgdir"/usr/include/gdb
+ rm -r "$pkgdir"/usr/share/man/man5
+}