summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2017-12-02 18:01:22 +0100
committerJaroslav Lichtblau2017-12-02 18:01:22 +0100
commit4c2e46446c8f26538ece7e08543ad3a1e50c7252 (patch)
tree956534395f258027ef1761b4db5f55b76e3a8622
parenta3f817fcc87231e279dc525636ed2823452e4653 (diff)
downloadaur-4c2e46446c8f26538ece7e08543ad3a1e50c7252.tar.gz
arno-iptables-firewall-2.0.2a-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 27 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf1dd257f782..8b8e11ccdfba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Oct 11 16:57:26 UTC 2016
+# Sat Dec 2 17:01:16 UTC 2017
pkgbase = arno-iptables-firewall
pkgdesc = A secure stateful firewall for both single and multi-homed machine
- pkgver = 2.0.1g
+ pkgver = 2.0.2a
pkgrel = 1
url = https://github.com/arno-iptables-firewall/aif/
arch = any
@@ -21,15 +21,21 @@ pkgbase = arno-iptables-firewall
backup = etc/arno-iptables-firewall/plugins/linux-upnp-igd.conf
backup = etc/arno-iptables-firewall/plugins/mac-address-filter.conf
backup = etc/arno-iptables-firewall/plugins/multiroute.conf
+ backup = etc/arno-iptables-firewall/plugins/nat-loopback.conf
+ backup = etc/arno-iptables-firewall/plugins/outbound-snat.conf
+ backup = etc/arno-iptables-firewall/plugins/parasitic-net.conf
+ backup = etc/arno-iptables-firewall/plugins/pptp-vpn-passthrough.conf
+ backup = etc/arno-iptables-firewall/plugins/pptp-vpn.conf
+ backup = etc/arno-iptables-firewall/plugins/rpc.conf
backup = etc/arno-iptables-firewall/plugins/sip-voip.conf
backup = etc/arno-iptables-firewall/plugins/ssh-brute-force-protection.conf
backup = etc/arno-iptables-firewall/plugins/traffic-accounting.conf
backup = etc/arno-iptables-firewall/plugins/traffic-shaper.conf
backup = etc/arno-iptables-firewall/plugins/transparent-dnat.conf
backup = etc/arno-iptables-firewall/plugins/transparent-proxy.conf
- source = http://rocky.eld.leidenuniv.nl/arno-iptables-firewall/arno-iptables-firewall_2.0.1g.tar.gz
+ source = arno-iptables-firewall-2.0.2a.tar.gz::https://github.com/arno-iptables-firewall/aif/archive/2.0.2a.tar.gz
source = arno-iptables-firewall.patch
- sha256sums = 0bafd85ddc235752250eaec0c7fdb21e530912483f6807a97f86158ed2d301f7
+ sha256sums = 41df5f37d1d9f34398c35be2640355f841ad2902f455b3653119ae23bfb41590
sha256sums = fbac95bced8565b00f5ff7b403579b1aaf7d386deb61c0f4a9acf50408a8200d
pkgname = arno-iptables-firewall
diff --git a/PKGBUILD b/PKGBUILD
index 087c4065fb0e..f4a74c8d25ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Arto Puranen <purcher@gmail.com>
pkgname=arno-iptables-firewall
-pkgver=2.0.1g
+pkgver=2.0.2a
pkgrel=1
pkgdesc="A secure stateful firewall for both single and multi-homed machine"
arch=('any')
@@ -21,22 +21,31 @@ backup=(etc/${pkgname}/firewall.conf
etc/${pkgname}/plugins/linux-upnp-igd.conf
etc/${pkgname}/plugins/mac-address-filter.conf
etc/${pkgname}/plugins/multiroute.conf
+ etc/${pkgname}/plugins/nat-loopback.conf
+ etc/${pkgname}/plugins/outbound-snat.conf
+ etc/${pkgname}/plugins/parasitic-net.conf
+ etc/${pkgname}/plugins/pptp-vpn-passthrough.conf
+ etc/${pkgname}/plugins/pptp-vpn.conf
+ etc/${pkgname}/plugins/rpc.conf
etc/${pkgname}/plugins/sip-voip.conf
etc/${pkgname}/plugins/ssh-brute-force-protection.conf
etc/${pkgname}/plugins/traffic-accounting.conf
etc/${pkgname}/plugins/traffic-shaper.conf
etc/${pkgname}/plugins/transparent-dnat.conf
etc/${pkgname}/plugins/transparent-proxy.conf)
-source=(http://rocky.eld.leidenuniv.nl/$pkgname/${pkgname}_${pkgver}.tar.gz
- ${pkgname}.patch)
-sha256sums=('0bafd85ddc235752250eaec0c7fdb21e530912483f6807a97f86158ed2d301f7'
+source=($pkgname-$pkgver.tar.gz::https://github.com/arno-iptables-firewall/aif/archive/${pkgver}.tar.gz
+ $pkgname.patch)
+sha256sums=('41df5f37d1d9f34398c35be2640355f841ad2902f455b3653119ae23bfb41590'
'fbac95bced8565b00f5ff7b403579b1aaf7d386deb61c0f4a9acf50408a8200d')
-package() {
- cd "${srcdir}"/${pkgname}_${pkgver}
+prepare() {
+ cd "${srcdir}"/aif-${pkgver}
-# patch
patch -Np0 -i "${srcdir}"/${pkgname}.patch
+}
+
+package() {
+ cd "${srcdir}"/aif-${pkgver}
# conf files
install -d -m 0755 etc/${pkgname}/plugins/ "${pkgdir}"/etc/${pkgname}/plugins/
@@ -65,7 +74,7 @@ package() {
install -Dm0644 share/man/man8/${pkgname}.8 "${pkgdir}"/usr/share/man/man8/${pkgname}.8
# systemd script
- install -Dm0644 "${srcdir}"/${pkgname}_${pkgver}/lib/systemd/system/${pkgname}.service \
+ install -Dm0644 "${srcdir}"/aif-${pkgver}/lib/systemd/system/${pkgname}.service \
"${pkgdir}"/usr/lib/systemd/system/${pkgname}.service
sed 's|local/s||g' -i "${pkgdir}"/usr/lib/systemd/system/${pkgname}.service
}