summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormegadrivers2015-06-09 18:45:25 +0200
committermegadrivers2015-06-09 18:45:25 +0200
commitb6f4d6f95e0ba8e4b4e16934a28c0d53df3c8de4 (patch)
treee0b89b7fdaa49faddc948f8782e5d1b96d702e92
downloadaur-b6f4d6f95e0ba8e4b4e16934a28c0d53df3c8de4.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--arnold.desktop10
-rw-r--r--arnold.pngbin0 -> 2754 bytes
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9825a11f9df6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = arnold
+ pkgdesc = An Amstrad CPC emulator using SDL with a GTK+ interface
+ pkgver = 2009.05.31
+ pkgrel = 3
+ url = http://www.yasara.org/cpc/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl
+ depends = libgl
+ depends = gtk2
+ depends = alsa-lib
+ depends = pulseaudio
+ source = http://www.yasara.org/cpc/arnold_tng.zip
+ source = arnold.desktop
+ source = arnold.png
+ md5sums = b9fcee41371a3d16b1ce2e268778a2c6
+ md5sums = d9ef043bfb472c30b58f858c4fbd80ef
+ md5sums = 7914c93646818037948eebba293520bc
+
+pkgname = arnold
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5745df4cb171
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: megadriver <megadriver at gmx dot com>
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: milko
+
+pkgname=arnold
+pkgver=2009.05.31
+pkgrel=3
+pkgdesc="An Amstrad CPC emulator using SDL with a GTK+ interface"
+arch=('i686' 'x86_64')
+url="http://www.yasara.org/cpc/"
+depends=('sdl' 'libgl' 'gtk2' 'alsa-lib' 'pulseaudio')
+license=('GPL')
+source=("http://www.yasara.org/cpc/arnold_tng.zip" arnold.desktop arnold.png)
+md5sums=('b9fcee41371a3d16b1ce2e268778a2c6'
+ 'd9ef043bfb472c30b58f858c4fbd80ef'
+ '7914c93646818037948eebba293520bc')
+
+build() {
+ cd "$srcdir"/arnold_tng/src
+
+ ./configure
+ sed -e 's/-DHAVE_SDL=1/-DHAVE_SDL=1 -DHAVE_GL=1/g' -e 's/-lSDL/-lSDL -lGL/g' -i Makefile
+ make clean
+ make
+
+}
+package () {
+ cd "$srcdir"/arnold_tng/src
+
+ install -D ../arnold "$pkgdir"/usr/bin/arnold
+ install -D -m644 "$srcdir"/arnold.desktop "$pkgdir"/usr/share/applications/arnold.desktop
+ install -D -m644 "$srcdir"/arnold.png "$pkgdir"/usr/share/pixmaps/arnold.png
+}
diff --git a/arnold.desktop b/arnold.desktop
new file mode 100644
index 000000000000..68a8f392e5b6
--- /dev/null
+++ b/arnold.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Arnold
+GenericName=Amstrad CPC emulator
+Exec=arnold
+Icon=/usr/share/pixmaps/arnold.png
+Type=Application
+Categories=System;Emulator;
+Encoding=UTF-8
+
+
diff --git a/arnold.png b/arnold.png
new file mode 100644
index 000000000000..42168b88b266
--- /dev/null
+++ b/arnold.png
Binary files differ