summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSylvain2023-06-29 11:17:20 +0200
committerSylvain2023-06-29 11:17:20 +0200
commit61f191c5016d21f8b21574163614f321178dae8e (patch)
tree8588bd011df7e7782c821853ad23bd6459ff6ba7
parent776bd6530fcef6d77554702942d975706bfff4ba (diff)
downloadaur-61f191c5016d21f8b21574163614f321178dae8e.tar.gz
add around to PATH (fix #1) and no more need to clean build on upgrade
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e1ca1bca9fc..8e1338783b92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = around
pkgdesc = Video conferencing with AI-based camera framing.
pkgver = 0.64.107
- pkgrel = 1
+ pkgrel = 2
url = https://www.around.co/
arch = x86_64
license = unknown
depends = fuse2
- noextract = Around.AppImage
+ noextract = Around-0.64.107.AppImage
options = !strip
- source = https://downloads.around.co/Around.AppImage
+ source = Around-0.64.107.AppImage::https://downloads.around.co/Around.AppImage
source = https://avatars.githubusercontent.com/u/62425723
sha256sums = af9d58708bd3e3df9d2ca3c2cf081da27d2a35578bfbc502d780f5d18c336007
sha256sums = 60d9081bbf0cfc6af58973d54e68c286d7ac3b21e875fef8f811c5114f34c7dc
diff --git a/PKGBUILD b/PKGBUILD
index 67feadf2ae78..e5d252cf29a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgname=around
pkgver=0.64.107
-pkgrel=1
+pkgrel=2
pkgdesc="Video conferencing with AI-based camera framing."
arch=('x86_64')
url='https://www.around.co/'
license=('unknown')
depends=('fuse2')
options=("!strip")
-_appimage="Around.AppImage"
+_appimage="Around-${pkgver}.AppImage"
_icon="62425723"
-source=("https://downloads.around.co/${_appimage}" "https://avatars.githubusercontent.com/u/${_icon}")
+source=("${_appimage}::https://downloads.around.co/Around.AppImage" "https://avatars.githubusercontent.com/u/${_icon}")
noextract=("${_appimage}")
sha256sums=("af9d58708bd3e3df9d2ca3c2cf081da27d2a35578bfbc502d780f5d18c336007" "60d9081bbf0cfc6af58973d54e68c286d7ac3b21e875fef8f811c5114f34c7dc")
prepare() {
@@ -36,5 +36,9 @@ package() {
# Create shortcut
install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Create symlink in PATH
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s "${pkgdir}/opt/${pkgname}/${_appimage}" "${pkgdir}/usr/bin/around"
}