summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Günter2017-03-21 01:47:46 +0000
committerAdrian Günter2017-03-21 01:47:46 +0000
commita0e3051f6887f806759d642092872875910d66a5 (patch)
tree0b4528102e468726467a30b8e624df68639827c0
downloadaur-a0e3051f6887f806759d642092872875910d66a5.tar.gz
Initial commit (3.0-1)
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD44
-rw-r--r--arpon-ng.install8
-rw-r--r--arpon.service15
-rw-r--r--arpon.service.conf7
6 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09a95029784a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = arpon-ng
+ pkgdesc = Prevents MITM attacks on the Address Resolution Protocol (ARP)
+ pkgver = 3.0
+ pkgrel = 1
+ url = http://arpon.sourceforge.net
+ install = arpon-ng.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake>=2.6
+ depends = libpcap>=1.0.0
+ depends = libnet>=1.1.2.1
+ depends = libdnet>=1.11
+ provides = arpon
+ conflicts = arpon
+ backup = etc/arpon.conf
+ backup = etc/conf.d/arpon
+ source = ArpON-3.0-ng.tar.gz::https://sourceforge.net/projects/arpon/files/arpon/ArpON-3.0-ng.tar.gz/download
+ source = arpon.service
+ source = arpon.service.conf
+ md5sums = a89ef9bc18e6f0fc9aa8a89aa676a281
+ md5sums = 3630b18dc67f9133acc8e3615462e341
+ md5sums = 01432a91eaa5f9c2a9fc490ebc7b300d
+
+pkgname = arpon-ng
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..13d706a30bcc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/*.tar.*
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06d7bbc830a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Adrian Günter <adrian at gntr dot me>
+
+pkgname=arpon-ng
+pkgver=3.0
+pkgrel=1
+pkgdesc="Prevents MITM attacks on the Address Resolution Protocol (ARP)"
+arch=('i686' 'x86_64')
+url="http://arpon.sourceforge.net"
+license=('BSD')
+depends=('libpcap>=1.0.0' 'libnet>=1.1.2.1' 'libdnet>=1.11')
+makedepends=('cmake>=2.6')
+conflicts=('arpon')
+provides=('arpon')
+backup=('etc/arpon.conf' 'etc/conf.d/arpon')
+install="${pkgname}.install"
+source=("ArpON-${pkgver}-ng.tar.gz::https://sourceforge.net/projects/arpon/files/arpon/ArpON-${pkgver}-ng.tar.gz/download"
+ 'arpon.service'
+ 'arpon.service.conf')
+md5sums=('a89ef9bc18e6f0fc9aa8a89aa676a281'
+ '3630b18dc67f9133acc8e3615462e341'
+ '01432a91eaa5f9c2a9fc490ebc7b300d')
+
+prepare() {
+ cd "ArpON-${pkgver}-ng"
+ mkdir -p build
+ sed -i -e 's:/sbin:/usr/bin:g' src/CMakeLists.txt README
+}
+
+build() {
+ cd "ArpON-${pkgver}-ng/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/ ..
+ make
+}
+
+package() {
+ install -Dm 644 arpon.service "${pkgdir}/usr/lib/systemd/system/arpon.service"
+ install -Dm 644 arpon.service.conf "${pkgdir}/etc/conf.d/arpon"
+ cd "ArpON-${pkgver}-ng"
+ make DESTDIR="${pkgdir}" -C build/etc install
+ make DESTDIR="${pkgdir}" -C build/man8 install
+ make DESTDIR="${pkgdir}" -C build/src install
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
+}
diff --git a/arpon-ng.install b/arpon-ng.install
new file mode 100644
index 000000000000..35da63dd1c87
--- /dev/null
+++ b/arpon-ng.install
@@ -0,0 +1,8 @@
+post_install() {
+ printf '\n\e[1;33m'
+ printf ' ==== ATTENTION =========================================\n'
+ printf ' You must edit the file /etc/conf.d/arpon before starting\n'
+ printf ' the arpon systemd service. See its header for more info.\n'
+ printf ' ========================================================\n'
+ printf '\e[m\n'
+}
diff --git a/arpon.service b/arpon.service
new file mode 100644
index 000000000000..aec8f198b815
--- /dev/null
+++ b/arpon.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=ARP Handler Inspection Daemon
+Before=network.target
+After=network-pre.target
+
+[Service]
+EnvironmentFile=/etc/conf.d/arpon
+PIDFile=/run/arpon.pid
+ExecStart=/usr/bin/arpon $ARPON_OPTS
+ExecReload=/usr/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=always
+
+[Install]
+WantedBy=network.target
diff --git a/arpon.service.conf b/arpon.service.conf
new file mode 100644
index 000000000000..b3159121e756
--- /dev/null
+++ b/arpon.service.conf
@@ -0,0 +1,7 @@
+# Uncomment and modify ARPON_OPTS line below to the desired network interface
+# (-i,--interface) and ARP inspection mode (-S,--sarpi|-D,--darpi|-H,--harpi)
+# before enabling and starting the systemd service. For more information
+# on interface and ARP inspection mode selection consult the arpon man page.
+# IMPORTANT: Do NOT set the daemon (-d,--daemon) option!
+
+#ARPON_OPTS="--interface eth0 --harpi"