summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2020-02-24 22:28:32 +0100
committermax.bra2020-02-24 22:28:32 +0100
commit071c7c65dc1ee06b6d566714b4e559183ef88ecf (patch)
treea65c788baa4e8216d6d2579768de78a0365bfd59
parent46b8121292c4fe243847e0e8534597d39c752b8c (diff)
downloadaur-071c7c65dc1ee06b6d566714b4e559183ef88ecf.tar.gz
icons path fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b46d1a6559ab..50b1bedde855 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arronax
pkgdesc = A program to create and modify starters/launchers (technically: .desktop files) for applications and locations (URLs).
pkgver = 0.7.1
- pkgrel = 3
+ pkgrel = 4
url = http://www.florian-diesch.de/software/arronax/
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 28041f463d03..67ea765b30b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Contributor: yochananmarqos <mark.wagie@tutanota.com>
# Maintainer: max.bra <max dot bra at alice dot it>
pkgname=arronax
pkgver=0.7.1
-pkgrel=3
+pkgrel=4
pkgdesc='A program to create and modify starters/launchers (technically: .desktop files) for applications and locations (URLs).'
arch=('any')
license=('GPL3')
@@ -17,6 +18,12 @@ source=(http://www.florian-diesch.de/software/$pkgname/dist/$pkgname-$pkgver.tar
md5sums=('f8a61c58ff5b4a27b9f1ba0c5593e81c')
+prepare() {
+ # Fix icon location
+ cd "$srcdir"/$pkgname-$pkgver
+ sed -i 's|share/icons/hicolor/{s}x{s}|share/icons/hicolor/{s}x{s}/apps|g' setup.py
+}
+
build() {
cd "$srcdir"/$pkgname-$pkgver
/usr/bin/python setup.py build