summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-01-11 14:36:38 -0500
committeracxz2020-01-11 14:36:38 -0500
commitb9ef63b329be4e1c06ab67531c0ff3b21974dd65 (patch)
treedcbe701530e4d45fbea0045de17a456138f1d19a
downloadaur-b9ef63b329be4e1c06ab67531c0ff3b21974dd65.tar.gz
create arrow-git package
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD57
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bcdb4dc6a1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = arrow-git
+ pkgdesc = A columnar in-memory analytics layer for big data.
+ pkgver = r5711.ce4fa0166
+ pkgrel = 1
+ url = https://arrow.apache.org
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = apache-orc
+ makedepends = boost
+ makedepends = cmake
+ makedepends = flatbuffers
+ makedepends = python-numpy
+ depends = boost-libs
+ depends = brotli
+ depends = double-conversion
+ depends = c-ares-cmake
+ depends = gflags
+ depends = grpc
+ depends = google-glog
+ depends = lz4
+ depends = protobuf
+ depends = rapidjson
+ depends = snappy
+ depends = thrift
+ depends = uriparser
+ depends = zstd
+ provides = parquet-cpp
+ conflicts = parquet-cpp
+ source = git+https://github.com/apache/arrow.git
+ sha256sums = SKIP
+
+pkgname = arrow-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9353f51889a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
+pkgname=arrow-git
+pkgver=r5711.ce4fa0166
+pkgrel=1
+pkgdesc="A columnar in-memory analytics layer for big data."
+arch=('x86_64')
+url="https://arrow.apache.org"
+license=('Apache')
+depends=('boost-libs' 'brotli' 'double-conversion' 'c-ares-cmake' 'gflags' 'grpc' 'google-glog' 'lz4' 'protobuf' 'rapidjson' 'snappy' 'thrift' 'uriparser' 'zstd')
+optdepends=()
+makedepends=('git' 'apache-orc' 'boost' 'cmake' 'flatbuffers' 'python-numpy')
+provides=('parquet-cpp')
+conflicts=('parquet-cpp')
+_name=arrow
+source=("git+https://github.com/apache/arrow.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build(){
+ cd "$srcdir"
+ mkdir -p build
+ cd "$srcdir/build"
+ ARROW_BUILD_TOOLCHAIN=/usr ORC_HOME=/usr DOUBLE_CONVERSION_HOME=/usr cmake \
+ ../${_name}/cpp -DARROW_DEPENDENCY_SOURCE=SYSTEM \
+ -DARROW_PYTHON=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DARROW_BUILD_TESTS=ON \
+ -DARROW_ALTIVEC=OFF \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DARROW_COMPUTE=ON \
+ -DARROW_IPC=ON \
+ -DARROW_JEMALLOC=ON \
+ -DARROW_ORC=ON \
+ -DARROW_PARQUET=ON \
+ -DARROW_PLASMA=ON \
+ -DARROW_TENSORFLOW=ON \
+ -DARROW_USE_SIMD=ON \
+ -DARROW_FLIGHT=ON \
+ -DARROW_GANDIVA=OFF \
+ -DARROW_PROTOBUF_USE_SHARED=ON \
+ -DARROW_GFLAGS_USE_SHARED=ON \
+ -DARROW_USE_GLOG=ON \
+ -DGTest_SOURCE=BUNDLED
+ make
+}
+
+package(){
+ cd "$srcdir/build"
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}/usr/lib/" -name "*testing*" -delete
+}