summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2024-10-28 11:59:05 +0530
committertxtsd2024-10-28 11:59:05 +0530
commit3addc88ec3957036c176d8549d0541e06923f232 (patch)
treef8b1f73bac8b058196938b772bee14575b841578
downloadaur-3addc88ec3957036c176d8549d0541e06923f232.tar.gz
upgpkg: art_standalone-git r167.57f9bbd9-1
Signed-off-by: txtsd <code@ihavea.quest>
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore5
-rw-r--r--.nvchecker.toml2
-rw-r--r--PKGBUILD60
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcb649297679
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = art_standalone-git
+ pkgdesc = A standalone version of Dalvik with Art built in
+ pkgver = r167.57f9bbd9
+ pkgrel = 1
+ url = https://gitlab.com/android_translation_layer/art_standalone
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = LicenseRef-Unknown
+ makedepends = git
+ makedepends = bsd-compat-headers
+ makedepends = libcap
+ makedepends = meson
+ makedepends = jdk8-openjdk
+ makedepends = python
+ makedepends = valgrind
+ makedepends = zip
+ depends = wolfssl-jni
+ depends = libbsd
+ depends = icu
+ depends = xz
+ depends = lz4
+ depends = java-runtime
+ depends = zlib
+ depends = expat
+ depends = libunwind
+ depends = openssl
+ depends = bionic_translation
+ depends = gcc-libs
+ depends = bash
+ depends = glibc
+ provides = art_standalone
+ conflicts = art_standalone
+ source = git+https://gitlab.com/android_translation_layer/art_standalone.git
+ sha256sums = SKIP
+
+pkgname = art_standalone-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218cc907c9ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!.nvchecker.toml
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..cf031b6705cf
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,2 @@
+[art_standalone-git]
+source = "manual"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59f21ef033b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: txtsd <aur.archlinux@ihavea.quest>
+
+pkgname=art_standalone-git
+_pkgname=${pkgname%%-git}
+pkgver=r167.57f9bbd9
+pkgrel=1
+pkgdesc='A standalone version of Dalvik with Art built in'
+url='https://gitlab.com/android_translation_layer/art_standalone'
+arch=('x86_64' 'aarch64' 'armv7h')
+license=('LicenseRef-Unknown')
+depends=(
+ wolfssl-jni
+ libbsd
+ icu
+ xz
+ lz4
+ java-runtime
+ zlib
+ expat
+ libunwind
+ openssl
+ bionic_translation
+ gcc-libs
+ bash
+ glibc
+)
+makedepends=(
+ git
+ bsd-compat-headers
+ libcap
+ meson
+ jdk8-openjdk
+ python
+ valgrind
+ zip
+)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${_pkgname}
+ make PREFIX=/usr ____LIBDIR=lib
+}
+
+package() {
+ cd ${_pkgname}
+ DESTDIR="$pkgdir" make \
+ ____PREFIX="$pkgdir"/usr \
+ ____INSTALL_ETC="$pkgdir"/etc \
+ ____LIBDIR=lib \
+ install
+}
+