summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-01-21 19:44:17 -0800
committerclintval2018-01-21 19:44:17 -0800
commit0bc6bc8241d8dc41b605e0560d544cab40adf268 (patch)
tree0c9d2f5b7f711bca89bde520de3dbbf889d9dd83
parent8ed09fc067f7237d7d1d6709ffa4fda37b14f888 (diff)
downloadaur-0bc6bc8241d8dc41b605e0560d544cab40adf268.tar.gz
artemis to 16.0.9
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD35
2 files changed, 21 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b643a2db4366..0ea4a7c84c7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = artemis
- pkgdesc = Artemis is a free genome viewer and annotation tool that allows visualization of sequence features and the results of analyses within the context of the sequence, and its six-frame translation.
- pkgver = 16.0.0
+ pkgdesc = A free genome viewer and annotation tool that allows visualization of biological sequence features
+ pkgver = 16.0.9
pkgrel = 1
url = http://www.sanger.ac.uk/resources/software/
- arch = i686
arch = x86_64
license = GPL2
depends = java-runtime>=1.6
- provides = artemis
- conflicts = artemis
- source = ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/artemis.tar.gz
- md5sums = bf6d9d9df113b8676857e3eb3dedd990
+ source = artemis-16.0.9.tar.gz::ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/artemis.tar.gz
+ sha256sums = 84a79eef8887994facb786ed095400ca5d7ddbfb1b126b2f3906db3dc1775813
pkgname = artemis
diff --git a/PKGBUILD b/PKGBUILD
index 77b7489644b2..d23ec9d216e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
pkgname='artemis'
-pkgver='16.0.0'
+pkgver=16.0.9
pkgrel=1
-pkgdesc='Artemis is a free genome viewer and annotation tool that allows visualization of sequence features and the results of analyses within the context of the sequence, and its six-frame translation.'
-arch=('i686' 'x86_64')
+pkgdesc='A free genome viewer and annotation tool that allows visualization of biological sequence features'
+arch=('x86_64')
url=http://www.sanger.ac.uk/resources/software/"${artemis}"
license=('GPL2')
depends=('java-runtime>=1.6')
-provides=('artemis')
-conflicts=('artemis')
-source=(ftp://ftp.sanger.ac.uk/pub/resources/software/"${pkgname}"/"${pkgname}".tar.gz)
-md5sums=('bf6d9d9df113b8676857e3eb3dedd990')
+source=("${pkgname}"-"${pkgver}".tar.gz::ftp://ftp.sanger.ac.uk/pub/resources/software/"${pkgname}"/"${pkgname}".tar.gz)
+sha256sums=('84a79eef8887994facb786ed095400ca5d7ddbfb1b126b2f3906db3dc1775813')
package() {
- cd "${srcdir}"/"${pkgname}"
+ cd "${srcdir}"/"${pkgname}"
- mkdir -p "${pkgdir}"/usr/bin
- mkdir -p "${pkgdir}"/opt/"${pkgname}"/
+ sed -i 's#ARTEMIS_HOME=`dirname "$PRG"`/.#ARTEMIS_HOME=/opt/artemis/#' art
+ sed -i 's#ACT_HOME=`dirname "$PRG"`/.#ACT_HOME=/opt/artemis/#' act
+ sed -i 's#ARTEMIS_HOME=`dirname "$PRG"`/.#ARTEMIS_HOME=/opt/artemis/#' dnaplotter
- cp -a * "${pkgdir}"/opt/"${pkgname}"/
+ mkdir -p "${pkgdir}"/opt/"${pkgname}"/
+ cp -a * "${pkgdir}"/opt/"${pkgname}"/
- scripts=('act' 'art' 'dnaplotter')
+ scripts=('act' 'art' 'dnaplotter')
+ for script in "${scripts[@]}"; do
+ install -Dm775 "${script}" "${pkgdir}"/usr/bin/"${script}"
+ rm "${pkgdir}"/opt/"${pkgname}"/"${script}"
+ done
- for script in "${scripts[@]}"
- do
- ln -s "${pkgdir}"/opt/artemis/"${script}" "${pkgdir}"/usr/bin/"${script}"
- done
-
- install -Dm644 README "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ install -Dm644 README "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
}