summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben De Smet2017-03-18 22:01:08 +0100
committerRuben De Smet2017-03-18 22:01:08 +0100
commit680d7c552a20273394ba051e1a345ede4756b693 (patch)
tree2f4ff53d741864ab794d2dbe23fb50770b6054da
parent711f43d968a113ffa06ad9fa49d84fef7880a977 (diff)
downloadaur-680d7c552a20273394ba051e1a345ede4756b693.tar.gz
v0.6.5 -- no need for Rust nightly
I believed Rust nightly was needed before, but apparently, I confused it with rust-clippy...
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb2bfe6e491a..de2adcd5c3a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Mar 7 15:47:19 UTC 2017
+# Sat Mar 18 21:01:06 UTC 2017
pkgbase = artifact
pkgdesc = The design doc tool made for developers
- pkgver = 0.6.4
+ pkgver = 0.6.5
pkgrel = 1
url = http://vitiral.github.io/artifact/
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = artifact
makedepends = cargo
depends = glibc
depends = gcc-libs
- source = https://github.com/vitiral/artifact/archive/v0.6.4.tar.gz
- sha512sums = a10f013f77e27412242da5895ab427cadc0cee13b3de67fdb87f211e8ad4390f89ba8315c479a733e52330b37a9989b94b04af88c1ccb44ace4eb75eb49f7d96
+ source = https://github.com/vitiral/artifact/archive/v0.6.5.tar.gz
+ sha512sums = 146530a6cf56226047a5b14bb9f5c7421ccecb1cb93a3d81d55a3b5a54765c43178a0a6546cff2cab7b33aa8f90a70b1ba73f6c722dc327c14e06a283702b884
pkgname = artifact
diff --git a/PKGBUILD b/PKGBUILD
index cbf31c5055b3..b75cab5f423e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ruben De Smet <me at rubdos dot be>
pkgname='artifact'
-pkgver="0.6.4"
+pkgver="0.6.5"
pkgrel=1
pkgdesc='The design doc tool made for developers'
url='http://vitiral.github.io/artifact/'
@@ -13,7 +13,7 @@ source=(
"https://github.com/vitiral/artifact/archive/v${pkgver}.tar.gz"
)
sha512sums=(
- 'a10f013f77e27412242da5895ab427cadc0cee13b3de67fdb87f211e8ad4390f89ba8315c479a733e52330b37a9989b94b04af88c1ccb44ace4eb75eb49f7d96'
+ '146530a6cf56226047a5b14bb9f5c7421ccecb1cb93a3d81d55a3b5a54765c43178a0a6546cff2cab7b33aa8f90a70b1ba73f6c722dc327c14e06a283702b884'
)
arch=(
'x86_64'
@@ -23,10 +23,6 @@ depends=(
'glibc'
'gcc-libs'
)
-# Currently, this package needs serde_derive v0.9.9, which needs nightly rust.
-# A big big warning will be displayed when rustup is not used.
-# We currently cannot depend on rust-nightly, because community/rustup
-# does not provide rust-nightly
makedepends=(
'rust'
'cargo'
@@ -35,12 +31,8 @@ makedepends=(
build() {
pushd "artifact-${pkgver}"
if [[ $(command -v rustup) ]]; then
- rustup run nightly cargo build --release
+ rustup run stable cargo build --release
else
- echo "WARNING: It seems like you are not running rustup.\nKeep in mind that `artifact` needs a recent version of rust nightly!"
- echo "Currently, this package needs serde_derive v0.9.9, which needs nightly rust."
- echo "We currently cannot depend on rust-nightly, because community/rustup"
- echo "does not `provide` rust-nightly, while it can actually provide it"
cargo build --release
fi
popd