summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben De Smet2017-03-07 16:47:25 +0100
committerRuben De Smet2017-03-07 16:47:25 +0100
commit711f43d968a113ffa06ad9fa49d84fef7880a977 (patch)
tree43f4ea830289136edd5a0a4016842df91e86ec02
parent98e82248f1716c93ae26965bd765284e2dd7ea94 (diff)
downloadaur-711f43d968a113ffa06ad9fa49d84fef7880a977.tar.gz
For people on community/rustup.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5af37a77836d..eb2bfe6e491a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Mar 4 23:24:34 UTC 2017
+# Tue Mar 7 15:47:19 UTC 2017
pkgbase = artifact
pkgdesc = The design doc tool made for developers
pkgver = 0.6.4
- pkgrel = 0
+ pkgrel = 1
url = http://vitiral.github.io/artifact/
arch = x86_64
arch = i686
license = LGPL3+
license = CC0
- makedepends = rust-nightly
+ makedepends = rust
makedepends = cargo
depends = glibc
depends = gcc-libs
diff --git a/PKGBUILD b/PKGBUILD
index 6df808318383..cbf31c5055b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='artifact'
pkgver="0.6.4"
-pkgrel=0
+pkgrel=1
pkgdesc='The design doc tool made for developers'
url='http://vitiral.github.io/artifact/'
license=(
@@ -24,14 +24,26 @@ depends=(
'gcc-libs'
)
# Currently, this package needs serde_derive v0.9.9, which needs nightly rust.
+# A big big warning will be displayed when rustup is not used.
+# We currently cannot depend on rust-nightly, because community/rustup
+# does not provide rust-nightly
makedepends=(
- 'rust-nightly'
+ 'rust'
'cargo'
)
build() {
pushd "artifact-${pkgver}"
- cargo build --release
+ if [[ $(command -v rustup) ]]; then
+ rustup run nightly cargo build --release
+ else
+ echo "WARNING: It seems like you are not running rustup.\nKeep in mind that `artifact` needs a recent version of rust nightly!"
+ echo "Currently, this package needs serde_derive v0.9.9, which needs nightly rust."
+ echo "We currently cannot depend on rust-nightly, because community/rustup"
+ echo "does not `provide` rust-nightly, while it can actually provide it"
+ cargo build --release
+ fi
+ popd
}
package() {