summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2016-08-12 11:33:53 -0700
committerDonald Carr2016-08-12 11:46:17 -0700
commit99182f9d57fa6f2af2c5325aad2966e000aac60a (patch)
treee190f0096731fa0128a292d1bda20c959dc7f46d
parente6367ac6e1d037a595d23f65a9c294349f4d37d4 (diff)
downloadaur-99182f9d57fa6f2af2c5325aad2966e000aac60a.tar.gz
Cross compilation is a useful beast
Change-Id: I2f78cd37c41e36e3ad3bed70710f3bff55a24443
-rw-r--r--PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 129a741c288a..afb0d4fc70db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,22 @@
# Maintainer: Donald Carr<sirspudd at gmail dot com>
+_qmake="qmake"
+_piver=""
+
+if [[ -z $_piver ]] && [[ -n $LOCAL_PI_VER ]]; then
+ _piver=$LOCAL_PI_VER
+fi
+
+if [[ -n "$_piver" ]]; then
+ _qmake="/opt/qt-sdk-raspberry-pi${_piver}/bin/qmake"
+fi
+
# Uncomment for a debug build
#_qmake_args="CONFIG+=debug"
pkgname=artriculate
conflicts=('pi-launcher')
pkgver=0.1
-pkgrel=4
+pkgrel=5
pkgdesc='QML box2d application for displaying artwork'
arch=('any')
url='https://github.com/sirspudd/artriculate'
@@ -13,10 +24,11 @@ license=('GPL3')
depends=('qt5-declarative' 'qml-box2d')
source=("git://github.com/sirspudd/artriculate#tag=${pkgver}")
sha256sums=('SKIP')
+options=('!strip')
build() {
cd "$srcdir"/"$pkgname"
- qmake
+ $_qmake
make
}