summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-06-24 16:25:45 +0200
committerGoliathLabs2020-06-24 16:25:45 +0200
commit2194f072e8b17efc86eb88bc41f45de21aed167c (patch)
tree2543d4a1d4650c1a0fe2357c9441e2f45986c95a
downloadaur-2194f072e8b17efc86eb88bc41f45de21aed167c.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD28
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff168846569b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = arx-libertatis-bin
+ pkgdesc = Cross-platform port of Arx Fatalis, a first-person role-playing game. (binary version)
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = http://arx-libertatis.org/
+ arch = x86_64
+ license = GPL3
+ depends = sdl
+ depends = openal
+ depends = glew1.10
+ optdepends = qt5-base: enable built-in crash handler (Qt5 version; recompile needed)
+ optdepends = gdb: generate detailed crash reports
+ optdepends = arxfatalis-data-copy: Arx Fatalis game data, required to play
+ optdepends = arxfatalis-data-demo: Arx Fatalis game data from the demo, required to play
+ optdepends = arxfatalis-data-gog: Arx Fatalis game data from the GOG installer, required to play
+ provides = arxlibertatis
+ conflicts = arxlibertatis
+ conflicts = arx-libertatis-git
+ source = https://download.opensuse.org/repositories/home:/dscharrer/Fedora_Rawhide/x86_64/arx-libertatis-1.1.2-9.23.x86_64.rpm
+ sha256sums = 0db7510fa261d06023fd3953b63a55928da2e3ae74fea3960098bf73a05296d7
+
+pkgname = arx-libertatis-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c2b161389cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Valerio Pizzi (Pival81) <pival81@yahoo.com>
+
+_pkgname=arx-libertatis
+pkgname=$_pkgname-bin
+pkgver=1.1.2
+pkgrel=1
+rpmrel=9.23
+pkgdesc='Cross-platform port of Arx Fatalis, a first-person role-playing game. (binary version)'
+url='http://arx-libertatis.org/'
+arch=('x86_64')
+license=('GPL3')
+depends=('sdl' 'openal' 'glew1.10')
+optdepends=('qt5-base: enable built-in crash handler (Qt5 version; recompile needed)'
+ 'gdb: generate detailed crash reports'
+ 'arxfatalis-data-copy: Arx Fatalis game data, required to play'
+ 'arxfatalis-data-demo: Arx Fatalis game data from the demo, required to play'
+ 'arxfatalis-data-gog: Arx Fatalis game data from the GOG installer, required to play')
+
+provides=('arxlibertatis')
+conflicts=('arxlibertatis' 'arx-libertatis-git')
+source=("https://download.opensuse.org/repositories/home:/dscharrer/Fedora_Rawhide/x86_64/$_pkgname-$pkgver-$rpmrel.x86_64.rpm")
+sha256sums=('0db7510fa261d06023fd3953b63a55928da2e3ae74fea3960098bf73a05296d7')
+
+package() {
+ bsdtar -C $pkgdir -xf $srcdir/$_pkgname-$pkgver-*.rpm
+}
+