summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-07-07 13:29:37 +0200
committerGoliathLabs2020-07-07 13:29:37 +0200
commitca4c5a359a898cab7a16bb2ad7ec78357647827b (patch)
tree3bd0e4af1175579c93f407290067ca979cb550d7
downloadaur-ca4c5a359a898cab7a16bb2ad7ec78357647827b.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD79
-rw-r--r--arx-libertatis-1.1.2-cmake-3.5.patch34
-rw-r--r--arx-libertatis.install9
4 files changed, 155 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2d1bcd46c8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = arx-libertatis-git
+ pkgdesc = Cross-platform port of Arx Fatalis, a first-person role-playing game (executables only) (Git)
+ pkgver = 1.21.r18839.g8ed0d4b7b
+ pkgrel = 1
+ url = https://arx-libertatis.org/
+ install = arx-libertatis.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = boost
+ makedepends = cmake
+ makedepends = git
+ depends = sdl
+ depends = zlib
+ depends = boost-libs
+ depends = glm
+ depends = freetype2
+ depends = openal
+ depends = glew
+ optdepends = qt5-tools: enable built-in crash handler (Qt5 version; recompile needed)
+ optdepends = qt4: enable built-in crash handler (Qt4 version; recompile needed)
+ optdepends = gdb: generate detailed crash reports
+ provides = arx
+ conflicts = arxlibertatis-git
+ source = git+https://github.com/arx/ArxLibertatis.git
+ source = git+https://github.com/arx/ArxLibertatisData.git
+ source = arx-libertatis-1.1.2-cmake-3.5.patch
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = c1da4981c407bc94ce87b520e2b6288fd6bac437a14dc3b54e8c2c7b01cbda0938b6995581938a2381d1f035ace95df58f3d894e8f7c6070986a5bc43f5e54c2
+
+pkgname = arx-libertatis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c3c1ec45562
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Sam S. <smls75@gmail.com>
+# Contributor: Daniel Scharrer <daniel@constexpr.org>
+
+_pkgname=arx-libertatis
+pkgname=$_pkgname-git
+pkgver=1.21.r18839.g8ed0d4b7b
+pkgrel=1
+pkgdesc='Cross-platform port of Arx Fatalis, a first-person role-playing game (executables only) (Git)'
+url='https://arx-libertatis.org/'
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('sdl' 'zlib' 'boost-libs' 'glm' 'freetype2' 'openal' 'glew')
+optdepends=('qt5-tools: enable built-in crash handler (Qt5 version; recompile needed)'
+ 'qt4: enable built-in crash handler (Qt4 version; recompile needed)'
+ 'gdb: generate detailed crash reports')
+makedepends=('boost' 'cmake' 'git')
+provides=('arx')
+conflicts=('arxlibertatis-git')
+source=("git+https://github.com/arx/ArxLibertatis.git"
+ "git+https://github.com/arx/ArxLibertatisData.git"
+ "arx-libertatis-1.1.2-cmake-3.5.patch")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'c1da4981c407bc94ce87b520e2b6288fd6bac437a14dc3b54e8c2c7b01cbda0938b6995581938a2381d1f035ace95df58f3d894e8f7c6070986a5bc43f5e54c2')
+install='arx-libertatis.install'
+
+pkgver() {
+ cd "$srcdir/ArxLibertatis"
+ # cutting off 'ArxFatalis.' prefix that presents in the git tag
+ git describe --long | sed 's/^ArxFatalis.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+
+}
+
+build() {
+ cd "$srcdir/ArxLibertatis"
+
+ patch < "$srcdir"/arx-libertatis-1.1.2-cmake-3.5.patch
+
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib/arx \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_EDITOR=OFF \
+ -DICONDIR=/usr/share/icons/hicolor/128x128/apps \
+ -DINSTALL_SCRIPTS=ON \
+ -DSTRICT_USE=ON \
+ -DUSE_NATIVE_FS=ON \
+ -DUSE_OPENAL=ON \
+ -DUSE_OPENGL=ON \
+ -DUSE_SDL=ON
+
+ # UNITY_BUILD
+ # produces a more optimized binary, but uses a lot of RAM during
+ # compilation - disable if low on memory.
+ #
+ # CMAKE_BUILD_TYPE=Release
+ # can be changed to CMAKE_BUILD_TYPE=Debug to get a debug build,
+ # which will run signifincantly slower but enables more runtime
+ # checks and generates better crash reports.
+
+ make
+}
+
+package() {
+ cd "$srcdir/ArxLibertatis"
+
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 README.md \
+ "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 CHANGELOG \
+ "$pkgdir/usr/share/doc/$pkgname/CHANGELOG"
+ install -Dm644 AUTHORS \
+ "$pkgdir/usr/share/doc/$pkgname/AUTHORS"
+ install -Dm644 LICENSE \
+ "$pkgdir"/usr/share/licenses/$_installname/LICENSE
+ install -Dm644 LICENSE.DejaVu \
+ "$pkgdir"/usr/share/licenses/$_installname/LICENSE.DejaVu
+}
diff --git a/arx-libertatis-1.1.2-cmake-3.5.patch b/arx-libertatis-1.1.2-cmake-3.5.patch
new file mode 100644
index 000000000000..d085afafe393
--- /dev/null
+++ b/arx-libertatis-1.1.2-cmake-3.5.patch
@@ -0,0 +1,34 @@
+From c4262bc600dc01d3ddbacc7811132b29ea46ad3b Mon Sep 17 00:00:00 2001
+From: Daniel Scharrer <daniel@constexpr.org>
+Date: Thu, 24 Mar 2016 22:47:44 +0100
+Subject: [PATCH] CMake: Disable variable expansion for quoted strings in if()
+
+This makes the build system more robust against stray variables
+coming from included CMake scripts provided by the system.
+
+Fixes build with CMake 3.5.
+
+This has been fixed in master with commit 60e43c.
+---
+ CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 93f1ee3..8347544 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -13,6 +13,11 @@ else()
+ cmake_minimum_required(VERSION 2.8)
+ endif()
+
++if(POLICY CMP0054)
++ # CMake 3.1+: Only interpret if() arguments as variables or keywords when unquoted.
++ cmake_policy(SET CMP0054 NEW)
++endif()
++
+
+ # Define configuration options
+
+--
+2.7.4
+
diff --git a/arx-libertatis.install b/arx-libertatis.install
new file mode 100644
index 000000000000..0217d5871aac
--- /dev/null
+++ b/arx-libertatis.install
@@ -0,0 +1,9 @@
+
+post_install() {
+ echo 'Note:'
+ echo ' | This package only provides the game executables.'
+ echo ' | You will also need to install the (demo or full) game data - using one'
+ echo ' | of the "arx-fatalis-data-*" AUR packages (system-wide installation),'
+ echo ' | or by running `arx-install-data` (per-user installation).'
+ echo ' | For more info see http://wiki.arx-libertatis.org/Getting_the_game_data'
+}