summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2023-07-30 14:18:00 +0200
committerMichael Laß2023-07-30 14:20:41 +0200
commit4aa9bb6b894f3135e92af854e448b474115b17e4 (patch)
tree14329d94b440938d8ba5a151e0f34ea94a67cac1
parent3db31bfc0341c77e618732f763ecc9c81896e5c4 (diff)
downloadaur-4aa9bb6b894f3135e92af854e448b474115b17e4.tar.gz
Use PEP 517, add missing urllib3 dependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8131f219acc3..92a715266954 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = arxiv-collector
pkgdesc = Small script to collect LaTeX sources for upload to the arXiv
pkgver = 0.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dougalsutherland/arxiv-collector
arch = any
license = BSD
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python-urllib3
depends = texlive-core
source = https://github.com/djsutherland/arxiv-collector/archive/0.4.1.tar.gz
sha256sums = 4fdb51c9db0d8641fc65cde3c085df14af67bfb8a149a3f267057ba5d81fe72b
pkgname = arxiv-collector
-
diff --git a/PKGBUILD b/PKGBUILD
index b5f45d26b6ae..cb7881834421 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,24 @@
pkgname=arxiv-collector
pkgver=0.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="Small script to collect LaTeX sources for upload to the arXiv"
arch=(any)
url="https://github.com/dougalsutherland/arxiv-collector"
license=('BSD')
-depends=(texlive-core)
-makedepends=(python-setuptools)
+depends=(python-urllib3 texlive-core)
+makedepends=(python-build python-installer python-setuptools python-wheel)
source=("https://github.com/djsutherland/$pkgname/archive/$pkgver.tar.gz")
sha256sums=('4fdb51c9db0d8641fc65cde3c085df14af67bfb8a149a3f267057ba5d81fe72b')
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
# License
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE