summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-07-05 02:23:27 +0200
committerhaawda2020-07-05 02:23:27 +0200
commit04be5be4081f39cf6234174bc667d59500e1e0ee (patch)
treedafd41f181003ec22d027f979c73f1b127abcfca
parent8a6e29da4eb54982a4922b74127c896ae8a60436 (diff)
downloadaur-arxivcheck.tar.gz
switch to python3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 494ec3d38dc9..2cc3d7241986 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = arxivcheck
pkgdesc = Generate a bibtex given a arxiv id or title, check if published
pkgver = 0.3.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/bibcure/arxivcheck
arch = any
license = AGPL3
- depends = python2-future
- depends = python2-unidecode
- depends = python2-feedparser
- depends = python2-bibtexparser
+ depends = python-future
+ depends = python-unidecode
+ depends = python-feedparser
+ depends = python-bibtexparser
depends = doi2bib
source = arxivcheck-0.3.1.tar.gz::https://github.com/bibcure/arxivcheck/archive/0.3.1.tar.gz
sha256sums = ce833cdbc6e3145180167e43462757453150bd2eaafe62c00f4a6349c0716837
diff --git a/PKGBUILD b/PKGBUILD
index 72019ad24b31..b43f40eddbdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
-# Maintainer: Excitable Snowball <excitablesnowball@gmail.com>
+# Contributor: Excitable Snowball <excitablesnowball@gmail.com>
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=arxivcheck
pkgver=0.3.1
-pkgrel=3
+pkgrel=4
pkgdesc="Generate a bibtex given a arxiv id or title, check if published"
url="https://github.com/bibcure/arxivcheck"
arch=('any')
license=('AGPL3')
-depends=('python2-future' 'python2-unidecode' 'python2-feedparser' 'python2-bibtexparser' 'doi2bib')
+depends=('python-future' 'python-unidecode' 'python-feedparser' 'python-bibtexparser' 'doi2bib')
source=("$pkgname-$pkgver.tar.gz::https://github.com/bibcure/arxivcheck/archive/$pkgver.tar.gz")
sha256sums=('ce833cdbc6e3145180167e43462757453150bd2eaafe62c00f4a6349c0716837')
package() {
cd $pkgname-$pkgver
- python2 setup.py install --root="$pkgdir"/ --optimize=1
+ python setup.py install --root="$pkgdir"/ --optimize=1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}