summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPival812016-09-01 18:40:05 +0200
committerPival812016-09-01 18:40:05 +0200
commit1456ce9934cef4aab7ee1cd084c4abe5ecf7d161 (patch)
treed2b823d192cbc9b4269a9dddd3c6b54345b064cf
downloadaur-1456ce9934cef4aab7ee1cd084c4abe5ecf7d161.tar.gz
yet another commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD34
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e75822bebfa5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Thu Sep 1 16:40:04 UTC 2016
+pkgbase = arxlibertatis-bin
+ pkgdesc = Cross-platform port of Arx Fatalis, a first-person role-playing game. (binary version)
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = http://arx-libertatis.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = rpmextract
+ depends = sdl
+ depends = openal
+ depends = glew1.10
+ optdepends = qt: enable built-in crash handler (Qt5 version; recompile needed)
+ optdepends = qt4: enable built-in crash handler (Qt4 version; recompile needed)
+ optdepends = gdb: generate detailed crash reports
+ optdepends = arxfatalis-data-copy: Arx Fatalis game data, required to play
+ optdepends = arxfatalis-data-demo: Arx Fatalis game data from the demo, required to play
+ optdepends = arxfatalis-data-gog: Arx Fatalis game data from the GOG installer, required to play
+ provides = arxlibertatis
+ conflicts = arxlibertatis
+ conflicts = arx-libertatisgit
+ source_x86_64 = http://download.opensuse.org/repositories/home:/dscharrer/Fedora_23/x86_64/arx-libertatis-1.1.2-4.1.x86_64.rpm
+ md5sums_x86_64 = 576b07947d3a834d07e49232791753bd
+
+pkgname = arxlibertatis-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d47258e1532
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Valerio Pizzi (Pival81) <pival81@yahoo.com>
+
+pkgname=arxlibertatis-bin
+_pkgname=arx-libertatis
+pkgver=1.1.2
+pkgrel=1
+rpmrel=4
+pkgdesc='Cross-platform port of Arx Fatalis, a first-person role-playing game. (binary version)'
+url='http://arx-libertatis.org/'
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('sdl' 'openal' 'glew1.10')
+optdepends=('qt: enable built-in crash handler (Qt5 version; recompile needed)'
+ 'qt4: enable built-in crash handler (Qt4 version; recompile needed)'
+ 'gdb: generate detailed crash reports'
+ 'arxfatalis-data-copy: Arx Fatalis game data, required to play'
+ 'arxfatalis-data-demo: Arx Fatalis game data from the demo, required to play'
+ 'arxfatalis-data-gog: Arx Fatalis game data from the GOG installer, required to play')
+
+provides=('arxlibertatis')
+conflicts=('arxlibertatis' 'arx-libertatisgit')
+makedepends=('rpmextract')
+
+source_x86_64=("http://download.opensuse.org/repositories/home:/dscharrer/Fedora_23/x86_64/$_pkgname-$pkgver-$rpmrel.1.x86_64.rpm")
+source_i386=("http://download.opensuse.org/repositories/home:/dscharrer/Fedora_23/i686/$_pkgname-$pkgver-$rpmrel.1.i686.rpm")
+
+md5sums_x86_64=("576b07947d3a834d07e49232791753bd")
+md5sums_i386=("042f113c9e3e82715c0c7554b3fdfb2c ")
+
+package() {
+ cd $pkgdir
+ rpmextract.sh $srcdir/$_pkgname-$pkgver-*.rpm
+}
+